Community discussions

MikroTik App
 
suntan
just joined
Topic Author
Posts: 2
Joined: Tue Sep 10, 2013 6:28 pm

pppoe-client and nat rule problem

Fri Oct 18, 2013 12:05 pm

Hi All,

Strange problem I have been having for months now, running an RB951G-2HnD attached to a TPLINK ADSL modem. Using pppoe client on router. Running wireless network and rest of ports bridged. All runs fine except when PPP connection drops for whatever reason I have to manually bring it back up by ssh'ing in and running the following commands to firstly bring up the ppp interface and then change the out-interface back to pppoe-out1 as it reverts to ether1-gateway when the PPP connection drops.

I have had a look around this forum but can't find anyone with this exact problem. No doubt a configuration issue and an error on my part but could someone point me in the direction of a solution? This "fix" isn't exactly wife friendly and when the connection drops she can't fix when I'm away!

Tried setting a static default route in case that was it but it had no effect. The only line in the logs relating to the PPP connection being dropped is something about
 pppoe-out1: terminating.. - administrator request 
I certainly didn't request it to drop :)

[admin@MikroTik] /interface pppoe-client> print
Flags: X - disabled, R - running 
 0 X  name="pppoe-out1" max-mtu=1480 max-mru=1480 mrru=disabled interface=ether1-gateway user="****" password="****" 
      profile=default keepalive-timeout=60 service-name="" ac-name="" add-default-route=yes default-route-distance=1 dial-on-demand=yes 
      use-peer-dns=yes allow=pap,chap,mschap1,mschap2 

[admin@MikroTik] > /interface pppoe-client enable 0

[admin@MikroTik] > /ip firewall nat print
Flags: X - disabled, I - invalid, D - dynamic 
 0   ;;; default configuration
     chain=srcnat action=masquerade to-addresses=0.0.0.0 out-interface=ether1-gateway

[admin@MikroTik] > /ip firewall nat set 0 out-interface=pppoe-out1

Thanks in advance.

suntan
 
RB951G2HnD
newbie
Posts: 29
Joined: Mon Oct 21, 2013 9:52 am

Re: pppoe-client and nat rule problem

Wed Oct 23, 2013 9:51 am

Hi Suntan,

You need to change your NAT rule this way:
/ip firewall nat
remove 0
add action=masquerade chain=srcnat out-interface=pppoe-out1 src-address=192.168.0.0/27 to-addresses=0.0.0.0
But don't forget to modify your src-address value.

Andrew
---------------
Andrew
 
suntan
just joined
Topic Author
Posts: 2
Joined: Tue Sep 10, 2013 6:28 pm

Re: pppoe-client and nat rule problem

Wed Oct 23, 2013 10:18 am

Thanks Andrew, I will give that a go and see how I get on and report back.

EDIT: All has been fine since doing as you suggested, many thanks.

suntan

Who is online

Users browsing this forum: EdPa, erlinden, leonardogyn, MSN [Bot] and 103 guests