Community discussions

MUM Europe 2020
 
pradeepsekar
just joined
Topic Author
Posts: 13
Joined: Sun Oct 13, 2013 6:21 am

PPTP Disconnects

Fri Nov 01, 2013 5:20 pm

I'm facing a problem where my Mikrotik PPTP client disconnects from my ISP's PPTP server exactly 51 seconds later after getting connected (and keeps connecting and disconnecting). I think I've found the problem, but not the way to fix it - I've tried Googling it, but could not find any solution. Would be wonderful if someone experienced can help

The remote address assigned by the PPTP server is the same as the PPTP's own address (172.18.0.1). The PPTP client connects successfully to the server, and then adds a Dynamic Route of distance 0 to the remote address (172.18.0.1) via the pptp interface....!

The packets of the Mikrotik PPTP Client try going out through the PPTP interface and disappear (rightfully so). The PPTP server does not hear from the Mikrotik PPTP Client, and times out and disconnects the connection at 51 seconds.

Any static route with a distance of 1 that I set up gets overridden by the distance 0 dynamic route set up as soon as the PPTP connection gets established

I have not been able to find any other way by which the PPTP client's packets can be forced to go via ether2 (port 2 on my Mikrotik). Can someone help me configure my Mikrotik so that I can route the PPTP Client's packets via ether2, and not via the dynamic route configured by the PPTP Client itself...

Thanks,
Pradeep


Note 1: I am on RB951G-2HnD, running the latest RouterOS 6.5.

Note 2: If I tick "Add default route, a second dynamic route of distance 1 gets added with the remote address (172.18.0.1) as the gateway. I have verified that this rule is not the one that causes the problem, as the disconnection occurs even if I untick the box

Note 3: I do not have control on the ISP's PPTP server configuration. The ISP is not interested in changing their configuration as this problem has not been reported by any other user. The (cheap) ASUS router they supplied works fine establishing a stable connection with the ISP's PPTP server. Same with my DD-WRT router which works fine. Using a Windows PC also works fine. So asking them to do a special configuration just because I have a Mikrotik is not possible.
 
pradeepsekar
just joined
Topic Author
Posts: 13
Joined: Sun Oct 13, 2013 6:21 am

Re: PPTP Disconnects

Sat Nov 02, 2013 6:29 am

I set a firewall mangle rule to place a routing mark on all connections going from the router to the PPTP Server, and routed that traffic via ether2. I am still seeing disconnects...

I have verified that I am configuring the Mikrotik PPTP client properly by trying out a StrongVPN server - the PPTP Server IP, the Remote IP, and Gateway are different, and the service is rock solid.

However, my ISP's PPTP server gets disconnected every 51 seconds everytime. I do not know if there is a problem with the Mikrotik PPTP client when the PPTP server sets its own IP as the remote IP address and gateway. All other routers and windows appear to handle it just fine.

If someone knows what might be wrong, please help!
 
RB951G2HnD
newbie
Posts: 28
Joined: Mon Oct 21, 2013 9:52 am

Re: PPTP Disconnects

Tue Nov 05, 2013 1:05 pm

It is very interesting issue! Because I have exactly the same problem with often ISP disconnects on my side but using PPPoE.

Support Team could you advice how to make 'Always On' for the WAN link. At this moment it seems that it work like 'On Demand'.
---------------
Andrew

Who is online

Users browsing this forum: No registered users and 36 guests