Community discussions

MUM Europe 2020
 
hgumus
just joined
Topic Author
Posts: 2
Joined: Wed Jan 22, 2014 3:02 pm

block skype

Wed Jan 22, 2014 3:08 pm

How can I block skype ang online game on mikrotik
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24387
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: block skype

Wed Jan 22, 2014 3:12 pm

you can not block skype without accidentaly blocking something else too.

what kind of online game ?
No answer to your question? How to write posts
 
hgumus
just joined
Topic Author
Posts: 2
Joined: Wed Jan 22, 2014 3:02 pm

Re: block skype

Wed Jan 22, 2014 5:05 pm

COUNTER STRIKE
 
abubaker
just joined
Posts: 9
Joined: Mon Apr 01, 2013 4:13 pm
Contact:

Re: block skype

Thu Jan 30, 2014 3:19 pm

How can I block skype ang online game on mikrotik
Block Skype Successfully see my blog.

http://virtualitsupport.wordpress.com/2 ... -mikrotik/
 
rodolfo
Long time Member
Long time Member
Posts: 543
Joined: Sat Jul 05, 2008 11:50 am

Re: block skype

Thu Jan 30, 2014 9:59 pm

the link does not function
rodolfo
IZ0UQV
 
User avatar
aacable
Member
Member
Posts: 428
Joined: Wed Sep 17, 2008 11:58 am
Location: ISLAMIC Republic of PAKISTAN
Contact:

Re: block skype

Fri Jan 31, 2014 1:26 pm

COUNTER STRIKE
Counter strike uses TCP prot 27015 by default. But at some palces, CS admins uses different port, You can monitor its usage by TORCH tool too.

To block the default port of CS, use the following code ...
/ip firewall filter
add chain=input action=drop dst-port=27015 protocol=tcp
add chain=forward action=drop dst-port=27015 protocol=tcp
As normis said, Blocking Skype 100% without blocking something else is a bit difficult in long terms. You have to do some extensive monitoring in order to block the right skype hosts. SKYPE is using whole block of IP addresses from various ranges. Using Wireshark & some digging I found following pools which skype is using for its various functions.BUT do remember that with new updates/ver more hosts can be added. for this purpose you can use Catch Skype Script on mikrotik to detect new addresses and add them to the list.

Also it is possible that some valid/legitimate sites may get blocked with this approach, just find the right ip address of the particular site, and allow it before the deny rule.

Use following code and then try to connect to SKYPE and watch the results. This is purely Hit & Trial method , try it and post your comments or if you have some better way to block SKYPE do let me know.SKYPE have different server's for different regions, so probably these destinations may not work for you, but at least they are working in Pakistan.

Regard's
Syed Jahanzaib
/ip fi ad
add address=111.221.74.0/24 comment=disable_skype disabled=no list=skype_servers_z
add address=111.221.77.0/24 comment=disable_skype disabled=no list=skype_servers_z
add address=157.55.130.0/24 comment=disable_skype disabled=no list=skype_servers_z
add address=157.55.235.0/24 comment=disable_skype disabled=no list=skype_servers_z
add address=157.55.56.0/24 comment=disable_skype disabled=no list=skype_servers_z
add address=157.56.52.0/24 comment=disable_skype disabled=no list=skype_servers_z
add address=194.165.188.0/24 comment=disable_skype disabled=no list=skype_servers_z
add address=195.46.253.0/24 comment=disable_skype disabled=no list=skype_servers_z
add address=213.199.179.0/24 comment=disable_skype disabled=no list=skype_servers_z
add address=63.245.217.0/24 comment=disable_skype disabled=no list=skype_servers_z
add address=64.4.23.0/24 comment=disable_skype disabled=no list=skype_servers_z
add address=65.55.223.0/24 comment=disable_skype disabled=no list=skype_servers_z

/ip firewall filter
add action=drop chain=forward disabled=no dst-address-list=skype_servers_z
Read this too.
http://aacable.wordpress.com/2013/12/09 ... -mikrotik/
_____________
Regard's

Syed Jahanzaib
Web: http://aacable.wordpress.com
Email: aacable [at] hotmail.com
 
ShawnSaydi
just joined
Posts: 4
Joined: Sat Aug 13, 2016 10:00 pm
Location: Liberia
Contact:

Re: block skype

Tue Jul 11, 2017 4:06 am

I hope this may be useful for others.

After applying many methods to block skype across all my sites so of which block others useful sites. I have found this method to be useful and working fine for me.

Firstly make sure your box is running the latest firmware version of RouterOS.
and use the codes below L7 blocking.

add the L7 regexp
/ip firewall layer7-protocol
add comment="Drop all through" name="Block Skype" regexp=\
"^.+(skype|skype.com).*\\\$"

Now apply the firewall filter rule to activate the block.
/ip firewall filter
add action=drop chain=forward comment="Block Skype" layer7-protocol=\
"Block Skype" log-prefix="Block Skype" time=7h-19h,mon,tue,wed,thu,fri

I am blocking Skype on our networks from 7AM to 1900hr PM monday to friday.

Kindly let me know if this work well for you.
Hudson S. I. Kattieh
IT Systems Design, Monitoring and Security(Mikrotik Consultant)
IT Officer/ Network Engineer & SAP @ Golden Veroleum Liberia Inc.
MTCTCE, MTCRE, MTCNA

Who is online

Users browsing this forum: jirinec, plisken, rbuserdl, stensen and 32 guests