Community discussions

MUM Europe 2020
 
Narside
just joined
Topic Author
Posts: 5
Joined: Thu Jan 23, 2014 8:15 am

Mikrotik 951G-2HnD wi-fi speed issue

Thu Jan 23, 2014 8:28 am

Hello. This is my first mikrotik router. I've set up all required parameters of the AP (lan access and wi-fi access). my internet channel is 100 mb/s. If i check the speed via speedtest.net on my lan connection - it is about 94-96 mb/s. But wi-fi speed is the subject of discussion. I couldn't obtain more than 36 mb/s for download and 37 for upload. Is it the maximum possible speed or i shoul tune something? my settings are below.

/interface bridge
add l2mtu=1598 name=bridge-local
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode \
band=2ghz-onlyn disabled=no distance=indoors ht-guard-interval=long \
ht-rxchains=1 ht-txchains=0 hw-protection-mode=rts-cts hw-retries=15 l2mtu=\
2290 mode=ap-bridge nv2-cell-radius=10 on-fail-retry-time=1s \
periodic-calibration=enabled radio-name=2 ssid="za Nerzula" \
tdma-period-size=1 tx-power=16 tx-power-mode=all-rates-fixed \
wireless-protocol=802.11 wmm-support=enabled
/interface ethernet
set [ find default-name=ether2 ] name=LAN1
set [ find default-name=ether3 ] master-port=LAN1 name=LAN2
set [ find default-name=ether4 ] master-port=LAN1 name=LAN3
set [ find default-name=ether5 ] master-port=LAN1 name=LAN4
set [ find default-name=ether1 ] mac-address=B0:48:7A:E9:8F:C1 name=WAN1
/interface wireless nstreme
set wlan1 disable-csma=yes enable-nstreme=yes framer-policy=dynamic-size
/ip neighbor discovery
set wlan1 discover=no
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=\
dynamic-keys wpa-pre-shared-key=4756273475 wpa2-pre-shared-key=4756273475
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m \
mac-cookie-timeout=3d
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=3des
/ip pool
add name=dhcp_pool1 ranges=192.168.88.2-192.168.88.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=bridge-local name=dhcp1
/queue simple
add disabled=yes name=queue1 queue=ethernet-default/ethernet-default target=\
wlan1
/system logging action
set 0 memory-lines=100
set 1 disk-lines-per-file=100
/interface bridge port
add bridge=bridge-local interface=LAN1
add bridge=bridge-local interface=wlan1
/ip address
add address=192.168.0.1/24 interface=LAN1 network=192.168.0.0
add address=192.168.88.1/24 interface=wlan1 network=192.168.88.0
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
interface=WAN1
/ip dhcp-server network
add address=192.168.88.0/24 gateway=192.168.88.1 netmask=24
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip firewall filter
add chain=input comment="Added by webbox" protocol=icmp
add chain=input comment="Added by webbox" connection-state=established \
in-interface=WAN1
add chain=input comment="Added by webbox" connection-state=related \
in-interface=WAN1
add action=drop chain=input comment="Added by webbox" in-interface=WAN1
add action=jump chain=forward comment="Added by webbox" in-interface=WAN1 \
jump-target=customer
add chain=customer comment="Added by webbox" connection-state=established
add chain=customer comment="Added by webbox" connection-state=related
add action=drop chain=customer comment="Added by webbox"
/ip firewall nat
add action=masquerade chain=srcnat comment="Added by webbox" out-interface=WAN1 \
to-addresses=0.0.0.0
/ip proxy
set parent-proxy=0.0.0.0
/ip route
add distance=1 gateway=10.122.66.75
/ip service
set api disabled=yes
/ip upnp
set allow-disable-external-interface=no enabled=yes
/ip upnp interfaces
add interface=WAN1 type=external
add interface=LAN1 type=internal
add interface=LAN2 type=internal
add interface=LAN3 type=internal
add interface=LAN4 type=internal
add interface=wlan1 type=internal
add interface=bridge-local type=internal
/queue interface
set wlan1 queue=pcq-download-default
/system clock
set time-zone-name=Europe/Moscow
/system leds
set 0 interface=wlan1
/system ntp client
set enabled=yes mode=unicast primary-ntp=193.106.144.6 secondary-ntp=\
109.87.105.6
/system scheduler
add name="Wi-fi OFF" on-event="Wi-fi OFF" policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
start-date=jan/22/2014 start-time=23:59:00
add name="Wi-fi On" on-event="Wi-fi ON" policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
start-date=jan/22/2014 start-time=08:34:00
/system script
add name="Wi-fi OFF" policy=ftp,write,winbox,api source=\
"/interface disable wlan1"
add name="Wi-fi ON" policy=ftp,write,winbox,api source=\
"/interface enable wlan1"
/tool bandwidth-server
set allocate-udp-ports-from=1000 authenticate=no max-sessions=1
/tool graphing interface
add
[admin@MikroTik] >
 
Narside
just joined
Topic Author
Posts: 5
Joined: Thu Jan 23, 2014 8:15 am

Re: Mikrotik 951G-2HnD wi-fi speed issue

Thu Jan 23, 2014 8:50 am

i'm running routerOS 6.7
 
uldis
MikroTik Support
MikroTik Support
Posts: 3428
Joined: Mon May 31, 2004 2:55 pm

Re: Mikrotik 951G-2HnD wi-fi speed issue

Thu Jan 23, 2014 1:19 pm

you are using chain one chain and most likely 20mhz channel width option.
Please reset the wireless interface configuration and configure the settings you need. Here is the exact command for the reset:
/interface wireless reset-configuration wlan1
 
Narside
just joined
Topic Author
Posts: 5
Joined: Thu Jan 23, 2014 8:15 am

Re: Mikrotik 951G-2HnD wi-fi speed issue

Thu Jan 23, 2014 1:42 pm

Thank you for your respond. i tried to reset and reconfigure, but still no effect for me. Maybe there is a brilliant example of the most "powerful" setup for my case. All i need for right now is high speed in 33 sq. meters area via wi-fi.
 
Narside
just joined
Topic Author
Posts: 5
Joined: Thu Jan 23, 2014 8:15 am

Re: Mikrotik 951G-2HnD wi-fi speed issue

Thu Jan 23, 2014 8:54 pm

After reconfiguring all that i can see is 34 Mb/s for download and 33 Mb/s for upload. Any ideas will be highly appreciated.
 
deejayq
Member Candidate
Member Candidate
Posts: 195
Joined: Wed Feb 23, 2011 8:33 am

Re: Mikrotik 951G-2HnD wi-fi speed issue

Thu Jan 23, 2014 9:07 pm

so what you're trying to achieve is n speed? because from the tests it looks like maybe your devices get connected to g.
if you have a android device download wifi analyzer from google play and see what channels are occupied by other routers in the neighbourhood
you may want to set tx power to 18 dB or even lower.
if you use wireless security wpa2, use aes cipher, other ciphers break the n standard.
for n speeds, the channel width has to be 40MHz
also any other wireless protocols/technologies proprietary to routeros should not be used in conjunction with devices like smartphones, notebooks etc.
 
Narside
just joined
Topic Author
Posts: 5
Joined: Thu Jan 23, 2014 8:15 am

Re: Mikrotik 951G-2HnD wi-fi speed issue

Thu Jan 23, 2014 9:31 pm

My Band is Only n. My tx power is 17 dB. My WPA is aes ccm. Channel width is 20/40 Mhz ht Above - I can't put in 40 Mhz. What is the maximum speed that can be achived with this router or simular model? I check speed using speedtest app installed on my galaxy s3 and Asus transformer. Reaults are equal.
 
User avatar
hendry
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Sat Jan 18, 2014 9:59 am
Location: Singapore
Contact:

Re: Mikrotik 951G-2HnD wi-fi speed issue

Mon Jan 27, 2014 5:13 am

I'm not that happy about my wireless speeds either with my 951Ui-2HnD:
interface wireless export compact
# jan/27/2014 10:59:50 by RouterOS 6.7
# software id = RHMG-22TY
#
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-ht-above disabled=no distance=indoors frequency=2447 l2mtu=\
    2290 mode=ap-bridge ssid=SINGTEL-F726 wireless-protocol=802.11
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=dynamic-keys wpa-pre-shared-key=0011466534 wpa2-pre-shared-key=\
    0011466534
Image
Image

Chose channel 8 since it seems the least busy: http://ix.io/a8R

My only consolilation is the RouterOS out performs the Aztech router that my ISP provided.
http://www.speedtest.net/my-result/3261400751 versus http://www.speedtest.net/my-result/3261378836

Is there a way to use typical Linux tools like iperf with the MikroTik?

My client is a Thinkpad X220. Interestingly it doesn't seem to go to 40mhz width:
x220:~$ iw wlan0 info
Interface wlan0
        ifindex 2
        wdev 0x1
        addr 08:11:96:ae:2d:3c
        ssid SINGTEL-F726
        type managed
        wiphy 0
        channel 8 (2447 MHz), width: 20 MHz, center1: 2447 MHz

03:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] [8086:0085] (rev 34)
        Subsystem: Intel Corporation Centrino Advanced-N 6205 AGN [8086:1311]
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi
I wonder if I'm missing a trick or I'm hitting a bug like https://bbs.archlinux.org/viewtopic.php?id=161056 since I can't get width 40mhz
RouterBOARD 4xRB952Ui-5ac2nD & 1xRB952Ui-5ac2nD
https://natalian.org/2017/08/20/Choosin ... _Ubiquiti/
 
uldis
MikroTik Support
MikroTik Support
Posts: 3428
Joined: Mon May 31, 2004 2:55 pm

Re: Mikrotik 951G-2HnD wi-fi speed issue

Mon Jan 27, 2014 1:11 pm

My Band is Only n. My tx power is 17 dB. My WPA is aes ccm. Channel width is 20/40 Mhz ht Above - I can't put in 40 Mhz. What is the maximum speed that can be achived with this router or simular model? I check speed using speedtest app installed on my galaxy s3 and Asus transformer. Reaults are equal.
Usually phones have only one chain and 20mhz support option where the data-rates goes up to 65mbps and real traffic using some speed testing tools up to 35mbps.
 
Wurstbaum
just joined
Posts: 8
Joined: Mon Jan 27, 2014 11:59 am
Location: Northern Germany

Channel Width

Mon Jan 27, 2014 1:53 pm

I can confirm that when handling WiFi on mobile phones, the amount of chains is the neckbreaker for the throughput.
Whats the top connection speed, your laptop connects at?
 
User avatar
hendry
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Sat Jan 18, 2014 9:59 am
Location: Singapore
Contact:

Re: Mikrotik 951G-2HnD wi-fi speed issue

Thu Feb 06, 2014 5:07 pm

Just wanted to mention I think the wireless has improved with 6.9
# feb/06/2014 23:05:56 by RouterOS 6.9
# software id = RHMG-22TY
#
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-ht-below disabled=no distance=indoors frequency=2447 l2mtu=\
    2290 mode=ap-bridge ssid=SINGTEL-F726 wireless-protocol=802.11
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=dynamic-keys wpa-pre-shared-key=0011466534 wpa2-pre-shared-key=\
    0011466534
I can finally get 40mhz bandwidth!
x220:~$ iw dev wlan0 link
Connected to 00:0c:42:8b:60:da (on wlan0)
        SSID: SINGTEL-F726
        freq: 2447
        RX: 172298190 bytes (165337 packets)
        TX: 16905344 bytes (74138 packets)
        signal: -70 dBm
        tx bitrate: 40.5 MBit/s MCS 2 40MHz
        bss flags:      short-preamble short-slot-time
        dtim period:    1
        beacon int:     100
x220:~$ iw wlan0 info
Interface wlan0
        ifindex 2
        wdev 0x1
        addr 08:11:96:ae:2d:3c
        ssid SINGTEL-F726
        type managed
        wiphy 0
        channel 8 (2447 MHz), width: 40 MHz, center1: 2437 MHz
RouterBOARD 4xRB952Ui-5ac2nD & 1xRB952Ui-5ac2nD
https://natalian.org/2017/08/20/Choosin ... _Ubiquiti/

Who is online

Users browsing this forum: jayson13, negr0 and 55 guests