Page 1 of 1

log: excessive or late collision, link duplex mismatch ????

Posted: Sun Feb 16, 2014 1:25 am
by anas3009
in log keep this come up:
memory interface, warning excessive or late collision, link duplex mismatch
???!!!

what's this?


Image

Re: log: excessive or late collision, link duplex mismatch

Posted: Sun Feb 16, 2014 12:49 pm
by uldis
what board you have?
What do you have connected to ether3 interface and what ethernet settings you have on that device?
How long is the ethernet cable?
At what linkspeed the ethernet is linked under status?

Re: log: excessive or late collision, link duplex mismatch

Posted: Mon Feb 17, 2014 7:07 pm
by supaplex
I have this same problem after install 6.10 version

I have a bridge in six EoIP and one ethernet and in this ethernet say this message warings.
Cable length for this ethernet is max 0,5meters (patchcross) for next router.

RH1000x2.
previous version 6.7 worked well.

Re: log: excessive or late collision, link duplex mismatch

Posted: Wed Feb 19, 2014 9:49 pm
by leonardnovosel
I have this same problem after install 6.10 version

I have a bridge in six EoIP and one ethernet and in this ethernet say this message warings.
Cable length for this ethernet is max 0,5meters (patchcross) for next router.

RH1000x2.
previous version 6.7 worked well.
I have the same problem on multiple 751G-2HnD's that are connected to 750UP's via 60-70m cables.
The problems started after upgrading to 6.10.

Why am I always afraid to upgrade to latest version lately?
Last year due to port flapping we had to substitute CCR1036-12G-4S in a large hotel resort with RB1100AH because the latter worked, it struggled but it worked.
I hope that this will not be the same scenario where the router works for couple of hours and decides to go on a holiday.

Re: log: excessive or late collision, link duplex mismatch

Posted: Wed Feb 19, 2014 10:08 pm
by onnoossendrijver
In my experience (mostly with Cisco devices) late collissions are the result of bad cables.

Re: log: excessive or late collision, link duplex mismatch

Posted: Tue Mar 04, 2014 10:46 pm
by athlonxp78
Hi friends, i have the same error in this v6.10 "ether2 excessive or late collision, link duplex mismatch?" my setup is extremely simple:

RB450G - ROS v6.10

ether1-2-3-4 -> RSTP Bridge
ether5 -> WAN

In the bridge only use de ether1 linked to a RB750UP at 30mts

But... the error is logged at ether2 (unused)...

Any news about that?

EDIT: I`ll test updating the 750UP to v6.10... (actually v6.9 w/firm 3.12)

Thanks!!!

Re: log: excessive or late collision, link duplex mismatch

Posted: Mon Mar 31, 2014 8:24 am
by directel
Hi Guys

We are having the same problem here are our details.

RB2011UiAS with LCD
Router OS 6.11
Routerboard Firmware 3.12

Re: log: excessive or late collision, link duplex mismatch

Posted: Thu Apr 03, 2014 10:26 pm
by vaivars
Enjoying this problem on RB1100AHx2.

Re: log: excessive or late collision, link duplex mismatch

Posted: Sat Apr 05, 2014 12:07 pm
by omidkosari
Same problem here after upgrade from 6.1 to v6.11 on RB750G . Other side is RB411AH v5.22 with default ethernet config .

Re: log: excessive or late collision, link duplex mismatch

Posted: Sun Apr 06, 2014 9:14 pm
by dies
Same problem. RouterOS 6.11, Routerboard RB2011iL.

Re: log: excessive or late collision, link duplex mismatch

Posted: Mon Apr 07, 2014 12:09 pm
by omidkosari
Hello,

The logs are warning about a misconfiguration. There is a duplex mismatch on the
link. RB411AH has disabled autonegotiation (100Mbit, full duplex), but the RB750G
has autonegotiation enabled which leads to packet collisions on the link.

More information: http://en.wikipedia.org/wiki/Autonegoti ... x_mismatch

These log messages were not implemented in RouterOS version 5.

Regards,
Janis Becs
My problem solved .

Re: log: excessive or late collision, link duplex mismatch

Posted: Thu May 15, 2014 9:05 am
by cicserver
Hello,

The logs are warning about a misconfiguration. There is a duplex mismatch on the
link. RB411AH has disabled autonegotiation (100Mbit, full duplex), but the RB750G
has autonegotiation enabled which leads to packet collisions on the link.
More information: http://en.wikipedia.org/wiki/Autonegoti ... x_mismatch
Regards,Janis Becs
My problem solved .
omidkosari
I am experiencing the same with RB1100ahx2 / ROS 6.11/6.12 , How you managed to solve it ?
[There was no problem with 5.26]

Re: log: excessive or late collision, link duplex mismatch

Posted: Thu May 15, 2014 9:44 am
by onnoossendrijver
You should always configure both ends of the connection the same way.
So if you configure one end to autonegotiation you need to configure the other end also for autonegotiation.
If you configure one end to 100/full, the other end must also be 100/full.

Configuring one end to autonegotiation and the other end to 100/full WILL cause errors.

Re: log: excessive or late collision, link duplex mismatch

Posted: Tue May 20, 2014 3:08 am
by IPANetEngineer
Glad to see this feature is in 6.x...even setting gigabit ethernet to be hard coded on one side and autneg on the other can cause issues. Autoneg is the way to go unless you encounter a problem and then hard code both sides and move on.

Re: log: excessive or late collision, link duplex mismatch

Posted: Wed May 21, 2014 6:10 am
by aacable
I faced this issue in 6.11/6.12/6.13 on rb1100ahx2 few days back at wisp operator.
I tried EVERY POSSIBLE method available in the mikrotik forum and at Google, but no use.
Although this error was not effecting any communication but the wisp operator was getting annoyed by seeing these errors and relating every issue of network with this one :? So I reverted back to 5.26 and the error is not appearing in LOG window and the operator is happy now :lol:

Re: log: excessive or late collision, link duplex mismatch

Posted: Wed May 21, 2014 11:30 am
by becs
I faced this issue in 6.11/6.12/6.13 on rb1100ahx2 few days back at wisp operator.
I tried EVERY POSSIBLE method available in the mikrotik forum and at Google, but no use.
Although this error was not effecting any communication but the wisp operator was getting annoyed by seeing these errors and relating every issue of network with this one :? So I reverted back to 5.26 and the error is not appearing in LOG window and the operator is happy now :lol:
You could disable default logging entry about warnings and add custom entry which logs all except interface warnings.
/system logging
set 2 disabled=yes
add topics=warning,!interface

Re: log: excessive or late collision, link duplex mismatch

Posted: Tue Aug 12, 2014 9:30 pm
by rsobemg
Anybody here, got answer this problem ?

ether5 excessive or late collision, link duplex mismatch?

Re: log: excessive or late collision, link duplex mismatch

Posted: Wed Aug 13, 2014 2:16 pm
by rsobemg
Bom dia, Pessoal.

Eu conseguir resolver o meu problema dessa mensagem, após conferir os modos duplex e certificar que estavam todos alinhados com a mesma configuração em ambas as pontas. Eu atualizei a minha RB2011UiAs para a versão mais nova 6.18 e as mensagens pararam de ser emitidas.

Atualizem suas RB´s que estão com esse warning depois de conferir os modos duplex que possívelmente também será resolvido.

Abraços

Re: log: excessive or late collision, link duplex mismatch

Posted: Wed Sep 24, 2014 10:59 pm
by Erlington
I'm receiving the same warning on a RB751U-2HnD with Router OS 6.19, but in my case it's a computer connected. Is the wire that connect the computer the cause?

Re: log: excessive or late collision, link duplex mismatch

Posted: Fri Sep 26, 2014 10:04 pm
by LuizMeier
I solved this issue opening a ticket with my ISP.

In my case, the problem was the ISP Routers's port, which was not in Auto mode. And no, the ISP didn't tell me wich was the value configured before.

Re: log: excessive or late collision, link duplex mismatch

Posted: Mon Jan 12, 2015 2:58 pm
by zarvan
Open interfaces/ open ether1 in your case ether3/ click on ethernet select auto from drop down in front of Tx Row Control & Rx Row Control/ Apply/ OK after ether1 link down on log ether1 linke up (speed 100M, full duplex), you will not see this error any more in your log.
It work for me, hope work for every body have same problem as well. see attachment
error solved.JPG

Re: log: excessive or late collision, link duplex mismatch ????

Posted: Fri Jun 05, 2015 3:00 pm
by dleo
Hi @zarvan,

Thanks for your update, unfortunately this doesn't work for me.

I'm going deeper, maybe cable is damaged.

Regards.

David L.

Re: log: excessive or late collision, link duplex mismatch ????

Posted: Sun Apr 10, 2016 11:21 am
by suloveoun
Please take a look at your LAN and WAN interfaces make sure each interface are enabled or disabled "auto-negotiation".
If your LAN is enable "auto-negotiation" so make sure your WAN interface is also enable "auto-negotiation" too.

Below WAN interface is disable "auto-negotiation" and LAN interface is enable "auto-negotiation" so in Log file will warning as your problem. Hope it help. :D
>interface ethernet monitor WAN   
              name: WAN
            status: link-ok
[color=#FF0000]auto-negotiation: disabled[/color]
              rate: 100Mbps
       full-duplex: yes
   tx-flow-control: no
   rx-flow-control: no
>interface ethernet monitor LAN
                      name: LAN
                    status: link-ok
          [color=#FF0000]auto-negotiation: done[/color]
                      rate: 100Mbps
               full-duplex: yes
           tx-flow-control: no
           rx-flow-control: no
               advertising: 10M-half,10M-full,100M-half,100M-full,1000M-half,1000M-full
  link-partner-advertising: 10M-half,10M-full,100M-half,100M-full

Re: log: excessive or late collision, link duplex mismatch

Posted: Mon Oct 24, 2016 5:06 pm
by htetayeartun
Open interfaces/ open ether1 in your case ether3/ click on ethernet select auto from drop down in front of Tx Row Control & Rx Row Control/ Apply/ OK after ether1 link down on log ether1 linke up (speed 100M, full duplex), you will not see this error any more in your log.
It work for me, hope work for every body have same problem as well. see attachment error solved.JPG

Thanks -:) It works for me.

Re: log: excessive or late collision, link duplex mismatch ????

Posted: Mon Nov 21, 2016 7:18 pm
by eevee147
I had same problem and tryed all, checked cable, etc.
And this, soooo simple fix it:

On the interface you have the problem go to "Ethernet" section and turn off "Auto Negotiation", TX/RX flow could be off, on or auto (for me work better off), the select the speed of your isp device, in my case 100Mbps Full Duplex

Have a nice day!