Community discussions

MikroTik App
 
kneuzgi
just joined
Topic Author
Posts: 22
Joined: Thu Mar 13, 2014 10:33 am

local name resolution

Thu Mar 13, 2014 10:40 am

Hi

I'm a newbie with the routerOS software.

I'd like to have a local nameserver but I do not know where in the menu to activate.


I'm getting following information if i'm doing a local name request:

C:\>nslookup 192.168.88.100
Server: router
Address: 192.168.88.1

*** 192.168.88.100 wurde von router nicht gefunden: Non-existent domain.


Internet Name server is working fine !

C:\>nslookup www.google.de
Server: router
Address: 192.168.88.1

Nicht autorisierende Antwort:
Name: www.google.de
Addresses: 2a00:1450:4002:802::101f
173.194.35.55
173.194.35.63
173.194.35.56



Does anybody know how to fix that problem in the webinterface (or winbox) ?

Thanks
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2950
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: local name resolution

Thu Mar 13, 2014 12:38 pm

You can only add static ip address on
ip / dns / static

like mypc.local 192.168.88.100
I'm Italian, not English. Sorry for my imperfect grammar.
 
kneuzgi
just joined
Topic Author
Posts: 22
Joined: Thu Mar 13, 2014 10:33 am

Re: local name resolution

Thu Mar 13, 2014 2:41 pm

thanks but that doesn't solve my issue ...

i'm not able to ping with name :-(



C:\>nslookup 192.168.88.110
Server: router
Address: 192.168.88.1

Name: computer1
Address: 192.168.88.110


C:\>nslookup computer1
Server: router
Address: 192.168.88.1

Non-authoritative answer:
Name: dreambox
Address: 192.168.88.110


C:\>ping computer1
Ping request could not find host computer1. Please check the name and try again.
 
User avatar
j7n
newbie
Posts: 43
Joined: Mon Jan 06, 2014 9:55 pm

Re: local name resolution

Thu Mar 13, 2014 10:41 pm

This problem has to be solved in your Windows DNS client. Ping, as well as most other Windows software, uses its various methods of name resolution (dns, wins, Netbios) and cache. Nslookup bypasses it, and simply interprets the response of one chosen DNS server.

To resolve the problem, go to your network adapter -> TCP/IP -> Advanced - DNS -> Append these suffixes... And enter "." for no suffix as the only entry in the list. Alternatively, you can have a domain zone such as ".local" as the suffix on all your hosts, and then simply enter dreambox.local in Mikrotik DNS.

http://stackoverflow.com/questions/3303 ... ing-doesnt

When I was on Windows XP, I also had to completely uninstall IPv6, to get local name working. Because IPv6 added some IPv6 DNS servers, which bypassed the chosen local DNS server on Mikrotik.
 
kneuzgi
just joined
Topic Author
Posts: 22
Joined: Thu Mar 13, 2014 10:33 am

Re: local name resolution

Sun Mar 16, 2014 11:54 am

Thanks that helpded a little bit.

Before on my Fritzbox router I didn't need to change anything on my local computers ....

I have a windows 8 computer and there i have to activate following in the network settings:

"use DNS-suffix of this connection in DNS registration"


But what can I do that also DHCP requested IP's are also registered on mikrotik DNS ?

Thanks
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: local name resolution

Sun Mar 16, 2014 2:25 pm

On my computer, ping requires a FQDN. nslookup doesn't.

Change computer1 to computer1.com and it should work.
 
kneuzgi
just joined
Topic Author
Posts: 22
Joined: Thu Mar 13, 2014 10:33 am

Re: local name resolution

Fri Mar 21, 2014 2:47 pm

after a reboot i've got the same problem as before :-(

Any help will be appreciated.

Thanks
--------------------------
nslookup 192.168.88.100
Server: router
Address: 192.168.88.1

Name: computer1
Address: 192.168.88.100

--------------------------
nslookup computer1
Server: mikrotik_rtr
Address: 192.168.88.1

*** mikrotik_rtr can't find computer1: Non-existent domain

--------------------------
nslookup computer1.kneuzgi.local
Server: router
Address: 192.168.88.1

*** router can't find computer1.kneuzgi.local: Non-existent domain


on the router I can see following:

[admin@Kneuzgi_MikroTik] /ip dns> export
# mar/21/2014 13:43:31 by RouterOS 6.10
# software id = 3G1U-3LR6
#
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router
add address=192.168.88.1 name=mikrotik_rtr
add address=192.168.88.100 name=computer1
add address=192.168.88.101 name=computer2
add address=192.168.88.102 name=computer3
 
SurferTim
Forum Guru
Forum Guru
Posts: 4637
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: local name resolution

Fri Mar 21, 2014 3:12 pm

Mine still works. What did you reboot? The router or the computer? I rebooted the router and the domains in "/ip dns static" still resolve ok.
 
User avatar
j7n
newbie
Posts: 43
Joined: Mon Jan 06, 2014 9:55 pm

Re: local name resolution

Fri Mar 21, 2014 3:39 pm

I would start with using Winbox / Tools / Packet Sniffer configured to filter destination port 53 to see if DNS requests are made, to what destination, and also what is the content of the packets (if the names contain any suffix). Before every repeated lookup with ping, I'd use ipconfig /flushdns . If DNS requests are not made, Windows has to be convinced to do so, or if there is a suffix, that has to be appended to the static entries (or added as duplicates).

See if you have only one DNS server configured in Windows (the mikrotik), especially if you have any funny looking IPv6 "servers", because sometimes Windows will query those secondary servers for local names, which obviously fails.

They get removed if IPv6 is uninstalled, which restored my ability to look up local, unqualified names. Maybe there is a way to remove them in console without removing IPv6 support.

Screenshot of working lookup with Packet Sniffer.
 
kneuzgi
just joined
Topic Author
Posts: 22
Joined: Thu Mar 13, 2014 10:33 am

Re: local name resolution

Tue Mar 25, 2014 6:27 pm

after adding computer.local to dns and rebooting it's working ..
 
PavelJ
just joined
Posts: 3
Joined: Sun May 31, 2015 4:23 pm

Re: local name resolution

Sun May 31, 2015 4:45 pm

Hi, I had same problem as you described. I simply solved it by adding an WAN interface to src-nat (see picture). My Windows Home Server apps in tray (dependant on local DNS) started working immediately. :)
local network DNS resolution problem.PNG
PS: IPv6 is disabled on all computers and server.

PavelJ
You do not have the required permissions to view the files attached to this post.
Best Regards, Pavel
Don't change your original decision. Change it only, when new decision means 100% sure success.

Who is online

Users browsing this forum: dainosan and 33 guests