Community discussions

 
poisons
just joined
Topic Author
Posts: 11
Joined: Wed Sep 18, 2013 3:50 pm

Traffic priority, queue tree. Noob question

Wed Apr 09, 2014 5:42 pm

Hello, i have problem with marking packets and change their priorities.

First i mark connections and packets. I want to mark 2 types - http traffic and all other packets.
/ip firewall mangle
add action=mark-connection chain=prerouting comment=go_inside_http_connections dst-port=1024-65535 in-interface=Beeline-l2tp new-connection-mark=http protocol=tcp src-port=80
add action=mark-connection chain=prerouting comment=go_outside_http_connections dst-port=80 new-connection-mark=http protocol=tcp src-port=1024-65535
add action=mark-packet chain=prerouting comment=all_http_packets connection-mark=http new-packet-mark=service-hight
add action=mark-connection chain=prerouting comment=all_tcp_connections new-connection-mark=all_tcp protocol=tcp
add action=mark-connection chain=prerouting comment=all_udp_connections new-connection-mark=all_udp protocol=udp
add action=mark-packet chain=prerouting comment=all_tcp_packets connection-mark=all_tcp new-packet-mark=service-low packet-mark=!service-hight
add action=mark-packet chain=prerouting comment=all_upd_packets connection-mark=all_udp new-packet-mark=service-low packet-mark=!service-hight
Next i create to queues
/queue tree
add name=HIGHT_PRIORITY packet-mark=service-hight parent=global priority=1 queue=ethernet-default
add name=LOW_PRIORITY packet-mark=service-low parent=global priority=3 queue=ethernet-default
When im downloading file via http i see same traffic in HIGHT_PRIORITY and LOW_PRIORITY tree. I think that some mistake in mangle rules.

My device 951g, RouterOS 6.12rc1
ether1 connected to my isp beeline. ether2-5 for clients. My isp use l2tp vpn for internet access.

What i do wrong?

Who is online

Users browsing this forum: No registered users and 29 guests