Community discussions

 
edigaryev
just joined
Topic Author
Posts: 5
Joined: Sun Oct 20, 2013 7:50 pm

Mount point for USB storage is not consistent

Wed May 07, 2014 12:39 pm

Hello!

I've set up logging to USB stick on my RB951G-2HnD (running RouterOS v6.12) and run into a problem with usbX mountpoint not being consistent, i.e. when I boot up the router, USB storage is mounted to usb1/ and logging works flawlessly, but after some time the mountpoint changes to usb2/ and the logging to file stops.

Logging stopped because usb1/ no more exists:
[admin@MikroTik] > store disk pr detail     
Flags: S - system 
 0 S name="system" total-space=126976KiB free-space=112408KiB status=ready 

 1   name="usb2" total-space=7783060KiB free-space=7634460KiB status=ready 
[admin@MikroTik] > sys reboot
After reboot:
[admin@MikroTik] > store disk pr detail
Flags: S - system 
 0 S name="system" total-space=126976KiB free-space=112408KiB status=ready 

 1   name="usb1" total-space=7783060KiB free-space=7634460KiB status=ready 
Logging works for some time, but then suddenly usb1/ changes back to to usb2/ again and the logging stops.

The USB stick is directly connected to the one available port on the RouterBOARD:
[admin@MikroTik] > system resource usb pr
 # DEVICE VENDOR                                              NAME                                            SPEED                                           
 0 1:1    Linux 3.3.5 ehci_hcd                                RB400 EHCI                                      480 Mbps                                        
 1 1:2    JetFlash                                            Mass Storage Device                             480 Mbps                                        
export compact related sections:
/system logging action
set 0 memory-lines=500
set 1 disk-lines-per-file=100
add disk-file-count=128 disk-file-name=usb1/usb-stick-log disk-lines-per-file=65535 name=usb1 target=disk
/system logging
add action=usb1 disabled=no topics=!debug,!dns
Is there any way to somehow "glue" that specific USB storage to a constant mountpoint, perhaps by using UUID?
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1120
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Mount point for USB storage is not consistent

Wed May 07, 2014 3:47 pm

I would say contact Mikrotik support directly at support@mikrotik.com - this seems like an issues that support should look at.

One USB stick should really not present itself as usb1 and usb2 randomly.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: Mount point for USB storage is not consistent

Wed May 07, 2014 5:57 pm

It will not mount as usb1 if there already exists a directory in internal flash named usb1. Anyway the storage late mounting and unmounting itself is a tragedy.
 
Clauu
Member Candidate
Member Candidate
Posts: 205
Joined: Fri Mar 21, 2014 8:27 pm
Location: RO

Re: Mount point for USB storage is not consistent

Thu May 08, 2014 10:18 pm

Yep same problem here, email the mikrotik team with this issue and let;s hope for a solution soon
Having fun with RB850Gx2, RB2011UiAS-2HnD, RB260GSP, RB751U-2HnD, CRS112, RB3011UiAS, hAP ac, cAP ac and hAP ac². More others on the way :-)
 
edigaryev
just joined
Topic Author
Posts: 5
Joined: Sun Oct 20, 2013 7:50 pm

Re: Mount point for USB storage is not consistent

Fri May 09, 2014 9:11 pm

I would say contact Mikrotik support directly at support@mikrotik.com - this seems like an issues that support should look at.

One USB stick should really not present itself as usb1 and usb2 randomly.
Thanks, I did write to Mikrotik's support, now I'm waiting for contact from their side.
 
edigaryev
just joined
Topic Author
Posts: 5
Joined: Sun Oct 20, 2013 7:50 pm

Re: Mount point for USB storage is not consistent

Wed May 14, 2014 5:46 pm

Just a small update: the MikroTik support responded to my ticket today and said that they are aware of this problem and will try to fix it in the upcoming 6.xx versions.
 
edigaryev
just joined
Topic Author
Posts: 5
Joined: Sun Oct 20, 2013 7:50 pm

Re: Mount point for USB storage is not consistent

Mon Jun 09, 2014 9:41 pm

So, the new RouterOS 6.14 was released four days ago. Too bad that there's still no fix.
 
orelcho
just joined
Posts: 15
Joined: Wed Nov 12, 2014 3:13 pm

Re: Mount point for USB storage is not consistent

Tue Feb 09, 2016 8:38 am

Is there any solution of the problem? My USB flash drive is unmounting very often from yesterday. Before that it worked a few weeks without problem.
Is there any way to round the problem (may be script if there is ftp request and there is NO mounted device => restart the rooter, of if it possible mount device)?

Who is online

Users browsing this forum: No registered users and 36 guests