Community discussions

MikroTik App
 
gxmc
just joined
Topic Author
Posts: 20
Joined: Sat Jan 02, 2010 1:53 pm

Problems Forwarding ports to use Steam

Tue Jun 03, 2014 2:11 pm

Steam's page says the following:
Steam Client

UDP 27000 to 27015 inclusive (Game client traffic)
UDP 27015 to 27030 inclusive (Typically Matchmaking and HLTV)
TCP 27014 to 27050 inclusive (Steam downloads)
UDP 4380
Then I did the following rules
14   chain=dstnat action=dst-nat to-addresses=192.168.75.10 protocol=udp 
     dst-port=27000-27030 
15   chain=dstnat action=dst-nat to-addresses=192.168.75.10 protocol=tcp 
     dst-port=27014-27050 
16   chain=dstnat action=dst-nat to-addresses=192.168.75.10 protocol=udp 
     dst-port=4380 
I tested them with the PortForward's PortChecker tool and everything is fine but the Steam stops logging in when the rule 14 is active. Its one of those 30 UDP ports, I dunno which one but I guess it doesn't matter. I need to know the reason the Steam stops working when I redirect the ports and the redirecting is working properly according to the testing tool.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2954
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: Problems Forwarding ports to use Steam

Tue Jun 03, 2014 5:47 pm

I use Steam for play ;)

The username on steam are the same as here... ;)

You do not need to open anything, do not do any, remove all your rule, are all wrong,

simply enable UPNP on Routerboard and configure it correctly ;)

This is my UPNP config, I never have one game that not work with that:
/ip upnp
set allow-disable-external-interface=no enabled=yes show-dummy-rule=yes
/ip upnp interfaces
add disabled=no interface=MATRIX type=internal
add disabled=no interface=pppoe-client type=external
MATRIX must be your local ethernet / bridge
pppoe-client your internet source.
I'm Italian, not English. Sorry for my imperfect grammar.
 
Rudios
Forum Veteran
Forum Veteran
Posts: 966
Joined: Mon Mar 11, 2013 12:58 pm
Location: The Netherlands

Re: Problems Forwarding ports to use Steam

Tue Jun 03, 2014 8:40 pm

Steam's page says the following:
Steam Client

UDP 27000 to 27015 inclusive (Game client traffic)
UDP 27015 to 27030 inclusive (Typically Matchmaking and HLTV)
TCP 27014 to 27050 inclusive (Steam downloads)
UDP 4380
Then I did the following rules
14   chain=dstnat action=dst-nat to-addresses=192.168.75.10 protocol=udp 
     dst-port=27000-27030 
15   chain=dstnat action=dst-nat to-addresses=192.168.75.10 protocol=tcp 
     dst-port=27014-27050 
16   chain=dstnat action=dst-nat to-addresses=192.168.75.10 protocol=udp 
     dst-port=4380 
I tested them with the PortForward's PortChecker tool and everything is fine but the Steam stops logging in when the rule 14 is active. Its one of those 30 UDP ports, I dunno which one but I guess it doesn't matter. I need to know the reason the Steam stops working when I redirect the ports and the redirecting is working properly according to the testing tool.
Add the dst-address or in-interface parameter to the rules, this could solve your issue.
Testing setup with: 2 x RB750UP | 2 x RB750GL | 1 x RB951G-2HnD | 1 x RB2011UiAS-IN
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2954
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: Problems Forwarding ports to use Steam

Tue Jun 03, 2014 8:41 pm

Add the dst-address or in-interface parameter to the rules, this could solve your issue.
Have you Steam and using it?
I'm Italian, not English. Sorry for my imperfect grammar.
 
Rudios
Forum Veteran
Forum Veteran
Posts: 966
Joined: Mon Mar 11, 2013 12:58 pm
Location: The Netherlands

Re: Problems Forwarding ports to use Steam

Tue Jun 03, 2014 8:48 pm

Add the dst-address or in-interface parameter to the rules, this could solve your issue.
Have you Steam and using it?
Honestly no but I assumed this is 'normal' natting.
With the rules given, all packets will be dst-natted, inbound and outbound. That's why I thought about specifying in-interface could help.
Testing setup with: 2 x RB750UP | 2 x RB750GL | 1 x RB951G-2HnD | 1 x RB2011UiAS-IN
 
gxmc
just joined
Topic Author
Posts: 20
Joined: Sat Jan 02, 2010 1:53 pm

Re: Problems Forwarding ports to use Steam

Wed Jun 04, 2014 5:35 am

I use Steam for play ;)

The username on steam are the same as here... ;)

You do not need to open anything, do not do any, remove all your rule, are all wrong,

simply enable UPNP on Routerboard and configure it correctly ;)

This is my UPNP config, I never have one game that not work with that:
/ip upnp
set allow-disable-external-interface=no enabled=yes show-dummy-rule=yes
/ip upnp interfaces
add disabled=no interface=MATRIX type=internal
add disabled=no interface=pppoe-client type=external
MATRIX must be your local ethernet / bridge
pppoe-client your internet source.
I know how to activate the UPnP and I actually use it, I disabled it in order to test something that involves the manual port opening.
 
gxmc
just joined
Topic Author
Posts: 20
Joined: Sat Jan 02, 2010 1:53 pm

Re: Problems Forwarding ports to use Steam

Wed Jun 04, 2014 5:46 am

Add the dst-address or in-interface parameter to the rules, this could solve your issue.
Have you Steam and using it?
Honestly no but I assumed this is 'normal' natting.
With the rules given, all packets will be dst-natted, inbound and outbound. That's why I thought about specifying in-interface could help.
And it did, indicating the in-interface solved the problem, thanks.

Can you manage to explain it to me? I don't understand why the Port Checker had no problems being reached by the outside and the Steam Client didn't.

Who is online

Users browsing this forum: No registered users and 28 guests