Community discussions

 
rcampbell
just joined
Topic Author
Posts: 4
Joined: Wed Jul 23, 2014 11:12 pm

How to set HTTPS for WebFig

Thu Jul 24, 2014 12:07 am

How do you set the WebFig interface to use https (443) instead of port 80?
 
User avatar
jacekes
Member Candidate
Member Candidate
Posts: 167
Joined: Tue Aug 30, 2011 9:34 am
Location: Poznan, Poland
Contact:

Re: How to set HTTPS for WebFig

Thu Jul 24, 2014 11:30 am

I guess you need to enable https in /ip services and disable http.
This will affect all web-based interfaces.
I was certified a long time ago:
MTCNA# 1210NA193 MTCTCE# 1210TCE056 MTCWE# 1211WE010

ONE NETWORK DIAGRAM IS WORTH MORE THAN A THOUSAND WORDS!
 
Rudios
Forum Veteran
Forum Veteran
Posts: 966
Joined: Mon Mar 11, 2013 12:58 pm
Location: The Netherlands

Re: How to set HTTPS for WebFig

Thu Jul 24, 2014 12:52 pm

I guess you also have to insert some kind of certificate.
Testing setup with: 2 x RB750UP | 2 x RB750GL | 1 x RB951G-2HnD | 1 x RB2011UiAS-IN
 
User avatar
jacekes
Member Candidate
Member Candidate
Posts: 167
Joined: Tue Aug 30, 2011 9:34 am
Location: Poznan, Poland
Contact:

Re: How to set HTTPS for WebFig

Thu Jul 24, 2014 1:42 pm

Yes, but it can be a self-signed cetificate, and as far as I remember it can be generated directly on the RB.
I don't have access to any of my RB right now, so I'm bot able to test it.
I was certified a long time ago:
MTCNA# 1210NA193 MTCTCE# 1210TCE056 MTCWE# 1211WE010

ONE NETWORK DIAGRAM IS WORTH MORE THAN A THOUSAND WORDS!
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2946
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: How to set HTTPS for WebFig

Thu Jul 24, 2014 2:45 pm

Yes, but it can be a self-signed cetificate, and as far as I remember it can be generated directly on the RB.
I don't have access to any of my RB right now, so I'm bot able to test it.
Use search function on the forum...

http://forum.mikrotik.com/viewtopic.php ... ps#p429891
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
jacekes
Member Candidate
Member Candidate
Posts: 167
Joined: Tue Aug 30, 2011 9:34 am
Location: Poznan, Poland
Contact:

Re: How to set HTTPS for WebFig

Thu Jul 24, 2014 3:19 pm

Me? What for? It's on the wiki I guess and rcampbell can check it by himself.
I was certified a long time ago:
MTCNA# 1210NA193 MTCTCE# 1210TCE056 MTCWE# 1211WE010

ONE NETWORK DIAGRAM IS WORTH MORE THAN A THOUSAND WORDS!
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2946
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: How to set HTTPS for WebFig

Thu Jul 24, 2014 4:05 pm

Me? What for? It's on the wiki I guess and rcampbell can check it by himself.
Sorry, the mesasge is for rcampbell
I'm Italian, not English. Sorry for my imperfect grammar.
 
rcampbell
just joined
Topic Author
Posts: 4
Joined: Wed Jul 23, 2014 11:12 pm

Re: How to set HTTPS for WebFig

Sat Jul 26, 2014 1:12 am

Thanks for the help guys.

I had previously searched both the forums and the Wiki and didn't get a clear answer without dropping to command line. Hopefuly other people that are new to RouterOS will find this useful.

First off there seems to be a bug in WebFig so I had to use WinBox.
The bug can be found here - WebFig - System - Certificates - [Select your certificate] - Sign. The sign button doesn't work in WebFig (I tried Chrome, IE 11 in Normal and Compatibility Mode) so I used WinBox. Everything else can be done in WebFig except the 'Sign' button.

Step 1. Create a Certificate
-System - Certificates - '+'
-Create a name 'ssl-web-management' or whatever you like
-Country = US (or the two letter country code you want)
-Thats all we need for the self signed cert
-Click 'Sign'
-Click 'Sign' again on the popup dialog (you can leave CA as unknown)
-Click OK
The certificate should now be created and trusted.

Step 2. Enable Port 443 for management and assign the cert
-IP - Services
-Double click on 'www-ssl 443'
-On the pop up dialog select the certificate you created
-Click 'Enable' to enable 443 web management
-Click 'OK'

You should be able to browse to WebFig on port 443 now.
 
MikroTikFan
Member Candidate
Member Candidate
Posts: 196
Joined: Sat Aug 02, 2014 1:13 am

Re: How to set HTTPS for WebFig

Fri Oct 03, 2014 7:56 pm

I Did that all steps but didn't disable 80 port.
After that all I just tried to go to https:/192.168.1.1 (router) but I got

Kod błędu: ERR_SSL_VERSION_OR_CIPHER_MISMATCH

What key usage must be set?

I have set on:

-digital signature
-key encipherment
-ctrl sign
-data encipherment
-key cert. sign
-tls server

what option s required for https, anything else should be set ?

should I add anything to firewall ?

webfig on port 80 is still working properly.
 
clubs
just joined
Posts: 7
Joined: Tue Jan 06, 2015 1:20 pm

Re: How to set HTTPS for WebFig

Sat Jan 10, 2015 9:19 am

Thank you @rcampbell for pointing out that thing with broken "sign" button!

It's like 6 months after your post and it's still not fixed. I'm new to MikroTik and that's not the fist impression I was hoping for.

Who is online

Users browsing this forum: Majestic-12 [Bot] and 29 guests