Community discussions

 
Helios79
just joined
Topic Author
Posts: 2
Joined: Wed Sep 03, 2014 3:46 am

Speed limiting on torrents, P2P, and media streaming

Fri Sep 12, 2014 12:29 am

Howdy all,

Over the past couple of weeks, I have been fighting with getting some speed limitations up and going for WISP customers. Like any provider, we run into problems with people downloading torrents which saturates the Internet connection for everyone. I have tried quite a few QoS scripts that I have found online and they all fail to limit the speed.

I know that I can cure this problem with pfSense, but that isn't an option in this case. Is there a working script that works with 5.26? We cannot use 6.x due to problems with RADIUS authentication.

Thanks.
 
cliffborton
just joined
Posts: 7
Joined: Sun Aug 17, 2014 4:07 pm

Re: Speed limiting on torrents, P2P, and media streaming

Mon Sep 15, 2014 9:55 am

First let me know that you want to drop all traffic to torrent or you want to limit the users to use from torrent ? If you want to Block or drop all traffic to the torrent you can use this rule , I use it and it's work correct my friend :
/ip firewall filter
add action=drop chain=forward comment="Block torrentz Traffic" content=\
www.torrentz.com

Best Regards,
 
zulkamal
just joined
Posts: 5
Joined: Wed Sep 10, 2014 7:37 am

Re: Speed limiting on torrents, P2P, and media streaming

Tue Oct 07, 2014 7:55 am

First let me know that you want to drop all traffic to torrent or you want to limit the users to use from torrent ? If you want to Block or drop all traffic to the torrent you can use this rule , I use it and it's work correct my friend :
/ip firewall filter
add action=drop chain=forward comment="Block torrentz Traffic" content=\
http://www.torrentz.com

Best Regards,

Hi there...i'm also facing the same issue..

User download using torrent and make my traffic congest....can I block all the p2p download and at the same time I want to limit the download speed for all type of download?....please advice...thank you in advance...
 
skoenman
just joined
Posts: 24
Joined: Fri Nov 07, 2008 11:42 am

Re: Speed limiting on torrents, P2P, and media streaming

Tue Oct 07, 2014 11:17 pm

Hey guys i have also been having some issues with the people doing p2p connections and it is a problem. What i have found is the best way to mitigate this is to do the following
1. Mark connections you know the traffic of eg..http...ssh..email..
2. Mark the source ips of the guys detected to use p2p....limit there number of connections to 200 otherwise they going to limit your routerboards cpu very quickly.
3. Mark connections that use a certain amount of data and put under queue just for downloads. All connections over a certain connection amount gets marked as downloads.

What i have also found is if you have gamers you need to prioritise the ports aswell.

Big thing comes in when you have multiple lines and you need to do load balancing and qos on the same routerboard....

Hope it gives you a idea of what to do.
 
hipro5
Member Candidate
Member Candidate
Posts: 161
Joined: Sat Feb 09, 2013 11:48 am
Location: Hellas (Greece)

Re: Speed limiting on torrents, P2P, and media streaming

Mon Oct 27, 2014 11:40 am

IF ALL clients are MikroTik based hardware, YES you CAN cut both of their download and upload speed.

IF they are NOT, you can EASILY "cut" ONLY their download speed at the speed you wish, through ACCESS LIST of your MicroTik AP.

ADD them all at the access list and go through it and change the download and upload limit to anyone of them.

This is the easiest way.

Other ways through scripts are possible and people in here will help you do so (I'm not familiar with it).

Who is online

Users browsing this forum: No registered users and 25 guests