Community discussions

 
gidje
just joined
Topic Author
Posts: 2
Joined: Sat Jul 26, 2014 12:40 am

How to lock Internet. Access for children. At certain times

Sat Sep 20, 2014 3:02 am

Hello. Who can help me to get this done. Unfortunately I have no help in the area of ​​this router. But would like to know how I can block the Internet at certain times. For my children. So that they can not access the Internet. During the late evening hours This is called the wifi. Who, oh who could help me with. Thanks. Gideon
 
hipro5
Member Candidate
Member Candidate
Posts: 161
Joined: Sat Feb 09, 2013 11:48 am
Location: Hellas (Greece)

Re: How to lock Internet. Access for children. At certain ti

Mon Oct 27, 2014 11:48 am

If you have a MikroTik router/Wi-Fi, I can help you (done it for my own son... :D ), IF not, I just can't - sorry.

I have this one and done it. RouterBoard RB951Ui-2HnD 30dbm POE Output (RouterOS L4)
 
2dfx
just joined
Posts: 22
Joined: Tue Mar 05, 2013 6:30 pm

Re: How to lock Internet. Access for children. At certain ti

Mon Oct 27, 2014 3:55 pm

You can disable/enable default route by scheduler.
/system scheduler add name="Disable def.route" \
interval=24h on-event="/ip route set disabled=yes \
numbers=\"[ /ip route find dst-address=0.0.0.0/0 ]\"" \
start-time=22:00:00 policy=read,write
/system scheduler add name="Enable def.route" \
interval=24h on-event="/ip route set disabled=no \
numbers=\"[ /ip route find dst-address=0.0.0.0/0 ]\"" \
start-time=08:00:00 policy=read,write
or you can disable/enable WiFi interface
/system scheduler add name="Disable WiFi" \
interval=24h on-event="/interface wireless \
set [ find default-name=wlan1 ] disabled=yes" \
start-time=22:00:00 policy=read,write
/system scheduler add name="Enable WiFi" \
interval=24h on-event="/interface wireless \
set [ find default-name=wlan1 ] disabled=no" \
start-time=08:00:00 policy=read,write
 
gidje
just joined
Topic Author
Posts: 2
Joined: Sat Jul 26, 2014 12:40 am

Re: How to lock Internet. Access for children. At certain ti

Mon Oct 27, 2014 8:25 pm

Thanks,
I have a mikrotik RB2011UiAS-2Hnd
I have two wifi networks made
the one I want for the kids,
so we have just the parents still access

Just have now first another problem with the router,
it starts every time again so I must first see that problem remedy

any help is welcome,

gr gideon
 
2dfx
just joined
Posts: 22
Joined: Tue Mar 05, 2013 6:30 pm

Re: How to lock Internet. Access for children. At certain ti

Tue Oct 28, 2014 1:58 pm

You can replace name="" of kids wireless lan and start/stop time


/system scheduler add name="Disable WiFi" \
interval=24h on-event="/interface wireless \
set [ find name=KIDsWirelessLAN ] disabled=yes" \
start-time=22:00:00 policy=read,write

/system scheduler add name="Enable WiFi" \
interval=24h on-event="/interface wireless \
set [ find name=KIDsWirelessLAN ] disabled=no" \
start-time=08:00:00 policy=read,write
 
User avatar
cbrown
Trainer
Trainer
Posts: 1840
Joined: Thu Oct 14, 2010 8:57 pm
Contact:

Re: How to lock Internet. Access for children. At certain ti

Tue Oct 28, 2014 2:20 pm

C.Brown

cbrown[at]ravenrocknetworks.com
MTCNA - MTCRE - MTCWE - MTCTCE
MTCSE - TRAINER-0179
 
SystemErrorMessage
Member
Member
Posts: 378
Joined: Sat Dec 22, 2012 9:04 pm

Re: How to lock Internet. Access for children. At certain ti

Wed Nov 05, 2014 1:22 pm

Imagine if you had really smart kids who have their own routerboards and bypassing parental controls with them.

You can use the scheduler or you can even use mikrotik hotspot. Radius can give more control too but is a bit complicated to set up in a home environment. I'm not sure how much of a hacker your kids are but hostpot or radius authentication can add limits from safe surfing to timing with the help of scripts. I'm looking at implementing adblock plus in scripts but it takes a lot of time to read through the procedures different common firmwares use. You can use the scheduler and simple scripts to enable or disable wifi at certain times and even radius/hotspot accounts.

When i stayed in a shared house i used to deal with annoying flatmates using the L7 firewall to play around with their common applications. routerOS can give a very fine degree of control, there are so many things to try but it also depends on your skill.

Ofcourse routerOS can include a time based configuration for when certain things go online. ASUS AC routers have them in stock.
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: How to lock Internet. Access for children. At certain ti

Wed Nov 05, 2014 6:31 pm

I would make an address list for selected ip addresses of children devices and a drop rule for this list. Then enable/disable the rule by scheduler.

Who is online

Users browsing this forum: No registered users and 31 guests