Community discussions

MUM Europe 2020
 
vincentvega
just joined
Topic Author
Posts: 7
Joined: Tue Nov 04, 2014 10:48 am

port forwarding for ip cam

Tue Nov 04, 2014 7:17 pm

Hi! im new to Mikrotik and i have problem with my port forwarding? my router is rb951ui-2hnd.
My ip cam 192.168.88.36 ,router ip 192.168.88.1 , port 80.
i use rule posted by Forum Guru ;
/ip firewall nat
add action=dst-nat chain=dstnat dst-address=192.168.1.117 dst-port=6080 \
protocol=tcp to-addresses=192.168.88.51
add action=dst-nat chain=dstnat dst-address=192.168.1.117 dst-port=6001 \
protocol=tcp to-addresses=192.168.88.51
add action=dst-nat chain=dstnat dst-address=192.168.1.117 dst-port=6002 \
protocol=tcp to-addresses=192.168.88.51

my rule ;

/ip firewall nat
add action=dst-nat chain=dstnat dst-address=192.168.88.1 dst-port=80 \
protocol=tcp to-addresses=192.168.88.36
add action=dst-nat chain=dstnat dst-address=192.168.88.1 dst-port=80 \
protocol=udp to-addresses=192.168.88.36
my port 80 stil closet i use canyouseeme.org.i see my cam on local net, but not outside
Thanks for help
 
imrankosi
Member Candidate
Member Candidate
Posts: 153
Joined: Wed Oct 15, 2008 4:51 pm

Re: port forwarding for ip cam

Wed Nov 05, 2014 5:14 pm

i think u wann to view from wan ip


for this you should have live ip or real ip on mikrotik than only you can view from wan
 
User avatar
gabrielpike
Frequent Visitor
Frequent Visitor
Posts: 84
Joined: Thu Apr 17, 2014 4:17 pm

Re: port forwarding for ip cam

Wed Nov 05, 2014 6:56 pm

You need to change your rules to include your public IP address.

/ip firewall nat
add action=dst-nat chain=dstnat dst-address=PUBLIC_IP_ADDRESS dst-port=80 \
protocol=tcp to-addresses=192.168.88.36
add action=dst-nat chain=dstnat dst-address=PUBLIC_IP_ADDRESS dst-port=80 \
protocol=udp to-addresses=192.168.88.36

This change should fix your problem.
Gabriel Pike
MTCNA
 
vincentvega
just joined
Topic Author
Posts: 7
Joined: Tue Nov 04, 2014 10:48 am

Re: port forwarding for ip cam

Wed Nov 05, 2014 10:33 pm

Big Thanks! Just Joined for help ,but my be i need some firewall rules too?i check on canyouseeme.org look like port 80 still closet .

Thanks fo help!!!
 
User avatar
gabrielpike
Frequent Visitor
Frequent Visitor
Posts: 84
Joined: Thu Apr 17, 2014 4:17 pm

Re: port forwarding for ip cam

Wed Nov 12, 2014 5:05 pm

If you are using the default firewall in the MT you will have to add these rules to the beginning of your list:

/ip firewall filter
add chain=input dst-port=80 protocol=tcp action=accept
add chain=input dst-port=80 protocol=udp action=accept
Gabriel Pike
MTCNA
 
ryandenis
newbie
Posts: 31
Joined: Fri Aug 29, 2014 7:40 am

Re: port forwarding for ip cam

Mon Nov 17, 2014 7:35 pm

I also have this problem but the question I have about the last comment is this, by just opening port 80 is that opening to vulnerabilities? or is that only forwarding it to the specified NAT rule?
 
vstman
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Sat Mar 27, 2010 9:05 pm

Re: port forwarding for ip cam

Tue Nov 18, 2014 5:50 pm

Use netmap with hairpin and port forwarding works fine for me.....................
 
User avatar
gabrielpike
Frequent Visitor
Frequent Visitor
Posts: 84
Joined: Thu Apr 17, 2014 4:17 pm

Re: port forwarding for ip cam

Tue Nov 18, 2014 6:00 pm

I also have this problem but the question I have about the last comment is this, by just opening port 80 is that opening to vulnerabilities? or is that only forwarding it to the specified NAT rule?
The second set of rules was intended to work with the dst-nat rules so port 80 is open to the NATed address on the LAN.
Gabriel Pike
MTCNA
 
ryandenis
newbie
Posts: 31
Joined: Fri Aug 29, 2014 7:40 am

Re: port forwarding for ip cam

Thu Nov 20, 2014 5:45 pm

I also have this problem but the question I have about the last comment is this, by just opening port 80 is that opening to vulnerabilities? or is that only forwarding it to the specified NAT rule?
The second set of rules was intended to work with the dst-nat rules so port 80 is open to the NATed address on the LAN.
Thank you much this is working for me on basic things such as web, ftp, etc.. but for whatever reason I cannot get plex media server to work.
 
User avatar
gabrielpike
Frequent Visitor
Frequent Visitor
Posts: 84
Joined: Thu Apr 17, 2014 4:17 pm

Re: port forwarding for ip cam

Thu Nov 20, 2014 10:48 pm

I also have this problem but the question I have about the last comment is this, by just opening port 80 is that opening to vulnerabilities? or is that only forwarding it to the specified NAT rule?
The second set of rules was intended to work with the dst-nat rules so port 80 is open to the NATed address on the LAN.
Thank you much this is working for me on basic things such as web, ftp, etc.. but for whatever reason I cannot get plex media server to work.

Try maybe opening the plex ports...

https://support.plex.tv/hc/en-us/articl ... -firewall-
Gabriel Pike
MTCNA
 
ryandenis
newbie
Posts: 31
Joined: Fri Aug 29, 2014 7:40 am

Re: port forwarding for ip cam

Thu Nov 20, 2014 10:52 pm

Try maybe opening the plex ports...

https://support.plex.tv/hc/en-us/articl ... -firewall-[/quote]


Thank you so much for that, I looked everywhere to see if there were more ports needed but couldn't find them. The strange thing is I have a pfsense with another customer and the only port they need opened is 32400. Its really strange that Mikrotik would need more ports open when just the one is sufficient for pfsense.

Who is online

Users browsing this forum: roeschlo, Y2mateM272 and 46 guests