Community discussions

 
Krisken
Member Candidate
Member Candidate
Topic Author
Posts: 132
Joined: Thu Oct 25, 2012 11:35 am

BGP Problem

Mon Dec 22, 2014 2:19 am

Hello,

This weekend, i've tried to set up a BGP session with our new provider to announce our own IP range (185.77.197.0/24). I connected the network of our provider to port 1 of the mikrotik and a simple client (Raspberry PI) on port 2 (IP : 185.77.197.197). A strange thing : we can ping the Mikrotik router from the Raspberry PI and we can ping the internet (eg 8.8.8.8) from the Mikrotik router. But we can't ping the internet from the Raspberry PI.

Very weird thing : the same setup works with another provider (with another IP block).

We tried the setup with a Routerboard RB2011UiAS-2HnD-IN. When working, we would replace it with a CCR.

Our AS : 48260
Our IP : 37.72.96.132/29 (gateway is 37.72.96.130 or .129 as VRRP)
Remote AS : 61029
Remote IP : 37.72.96.130
# dec/19/2014 16:08:36 by RouterOS 6.22
# software id = K6Z0-T31J
#
/interface ethernet
set [ find default-name=ether1 ] mac-address=D4:CA:6D:4A:B8:6A name=\
    "ether01 - Bitency BGP feed"
set [ find default-name=ether2 ] mac-address=D4:CA:6D:4A:B8:6B name=\
    "ether02 - Bitency Server Feed"
set [ find default-name=ether3 ] disabled=yes mac-address=D4:CA:6D:4A:B8:6C \
    master-port="ether02 - Bitency Server Feed" name=ether03
set [ find default-name=ether4 ] mac-address=D4:CA:6D:4A:B8:6D master-port=\
    "ether02 - Bitency Server Feed" name="ether04 - PFSense"
set [ find default-name=ether5 ] disabled=yes mac-address=D4:CA:6D:4A:B8:6E \
    name=ether05
set [ find default-name=ether6 ] disabled=yes mac-address=D4:CA:6D:4A:B8:6F \
    name=ether06
set [ find default-name=ether7 ] disabled=yes mac-address=D4:CA:6D:4A:B8:70 \
    name=ether07
set [ find default-name=ether8 ] disabled=yes mac-address=D4:CA:6D:4A:B8:71 \
    name=ether08
set [ find default-name=ether9 ] disabled=yes mac-address=D4:CA:6D:4A:B8:72 \
    name=ether09
set [ find default-name=ether10 ] disabled=yes mac-address=D4:CA:6D:4A:B8:73 \
    name="ether10 - Internal network"
set [ find default-name=sfp1 ] disabled=yes
/interface wireless
set [ find default-name=wlan1 ] l2mtu=2290 ssid="RTR DC Rijen"
/ip neighbor discovery
set "ether01 - Bitency BGP feed" discover=no
/interface ethernet switch port
set 5 default-vlan-id=0
set 6 default-vlan-id=0
set 7 default-vlan-id=0
set 8 default-vlan-id=0
set 9 default-vlan-id=0
set 12 default-vlan-id=0
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/port
set 0 name=serial0
/routing bgp instance
set default as=48260 redistribute-connected=yes redistribute-ospf=yes \
    redistribute-other-bgp=yes redistribute-rip=yes redistribute-static=yes \
    router-id=37.72.96.132
/system logging action
set 1 disk-file-name=""
set 2 remember=yes
/tool user-manager customer
/ip address
add address=37.72.96.132/29 comment="Bitency BGP" interface=\
    "ether01 - Bitency BGP feed" network=37.72.96.128
add address=185.77.197.1/24 comment="Bitency Internet" interface=\
    "ether02 - Bitency Server Feed" network=185.77.197.0
/ip cloud
set enabled=yes
/ip dhcp-client
add default-route-distance=100 dhcp-options=hostname,clientid disabled=no \
    interface="ether10 - Internal network" use-peer-dns=no use-peer-ntp=no
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www port=8080
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/ip upnp
set allow-disable-external-interface=no
/routing bgp peer
add address-families=ip,ipv6 default-originate=if-installed hold-time=\
    infinity keepalive-time=10s name="Bitency BGP" remote-address=\
    37.72.96.130 remote-as=61029 ttl=default
/snmp
set contact=support@teleweb.network enabled=yes location="Netherlands - Rijen" \
    trap-community=public
/system clock
set time-zone-name=Europe/Amsterdam
/system identity
set name="RTR DC Rijen"
/system lcd
set contrast=0 enabled=no port=parallel type=24x4
/system lcd page
set time disabled=yes display-time=5s
set resources disabled=yes display-time=5s
set uptime disabled=yes display-time=5s
set packets disabled=yes display-time=5s
set bits disabled=yes display-time=5s
set version disabled=yes display-time=5s
set identity disabled=yes display-time=5s
set wlan1 disabled=yes display-time=5s
set sfp1 disabled=yes display-time=5s
set "ether01 - Bitency BGP feed" disabled=yes display-time=5s
set "ether02 - Bitency Server Feed" disabled=yes display-time=5s
set ether03 disabled=yes display-time=5s
set "ether04 - PFSense" disabled=yes display-time=5s
set ether05 disabled=yes display-time=5s
set ether06 disabled=yes display-time=5s
set ether07 disabled=yes display-time=5s
set ether08 disabled=yes display-time=5s
set ether09 disabled=yes display-time=5s
set "ether10 - Internal network" disabled=yes display-time=5s
/system ntp client
set enabled=yes primary-ntp=195.130.132.18 secondary-ntp=195.13.23.5
/tool graphing interface
add
/tool graphing resource
add
/tool mac-server
set [ find default=yes ] disabled=yes
add interface="ether02 - Bitency Server Feed"
add interface=ether03
add interface="ether04 - PFSense"
add interface=ether05
add interface=ether06
add interface=ether07
add interface=ether08
add interface=ether09
add interface="ether10 - Internal network"
add
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface="ether02 - Bitency Server Feed"
add interface=ether03
add interface="ether04 - PFSense"
add interface=ether05
add interface=ether06
add interface=ether07
add interface=ether08
add interface=ether09
add interface="ether10 - Internal network"

 
BBVPS
just joined
Posts: 3
Joined: Sat Apr 03, 2010 7:15 pm

Re: BGP Problem

Mon Dec 22, 2014 10:58 am

You need to check the routing table on you raspberry pie. probably router is not set as your raspberry pie gateway.
 
Krisken
Member Candidate
Member Candidate
Topic Author
Posts: 132
Joined: Thu Oct 25, 2012 11:35 am

Re: BGP Problem

Mon Dec 22, 2014 5:26 pm

The router is set as gateway on the raspberry pi. So I suppose it 's a misconfiguration of the Mikrotik router.

Who is online

Users browsing this forum: No registered users and 25 guests