Page 1 of 1

RB2011 factory reset

Posted: Fri Jan 02, 2015 4:47 pm
by sejtam
I have the basic RB2011 model (just Ethernet, n console, wireless nor fibre)
A stupid typo locked me out of the device (firewall action=drop src-adress-list=rfc1918, aciddentally hit enter before specifying the interface)

So now I am trying to factory reset my router to get it back, but I cannot get it to work.

I tried the following methods:
a) power down, press-and-hold reset-button (quite tricky for a longer time), apply power, wait

I see the USER Led start blinking a few time slowly almost right away. releasing the button then doesn't do anything

If I try the same but hold the button longer, there is a singel beep, more waiting, then a double-beep, then more waiting
then all the interface LEDs start blinking for a short while until only the one of the attached interface
blinks (like normal traffic).

When I release the button then, still no luck.

b) anotehr older threat suggested that an older bootloader may be installed and make the reset button just
start netinstall, and that one should press it just AFTER applying power. (how soon is 'just after'?)

tried that, also no dice.

As it stands, I have a bricked RB2011


Re: RB2011 factory reset

Posted: Fri Jan 02, 2015 5:02 pm
by w0lt
Try connecting using the serial console port. We've all done some "Fat Fingering" at some point.. :)
Using the console port, you should be able to recover without resetting.


Re: RB2011 factory reset

Posted: Fri Jan 02, 2015 5:16 pm
by jarda
After reset try winbox mac connection on ether2. When in netinstall mode use ether1.

Re: RB2011 factory reset

Posted: Fri Jan 02, 2015 5:55 pm
by sejtam
I have no console port, so that is out. Also, I'm MAC only and have not installed wine yet.
But just after I posted it, I got it working somehow. Dont'really know what I did differently though...

Re: RB2011 factory reset

Posted: Fri Jan 02, 2015 10:45 pm
by ngnr
From my experience using WINBOX on a Macintosh I've found that when I need to connect with a factory-reset unit is best to put my computer IP config using DHCP. Obviously it can't find any and it will autoassign an IP address in the form of X.X.X.X . With this address set I can connect with WINBOX via MAC without issues and disconnects. Once I've done basic setup or loaded a config script I go back to WINBOX via IP. I know it's weird but this works for me 100% of the time and I stopped wasting time connecting to MKT units for the first time.

Hint: You have to wait until Macintosh has auto-assigned the address itself before attempting to connect.

Re: RB2011 factory reset

Posted: Tue Jan 13, 2015 4:02 am
by Turk182
I thought it best to jump in here, as I experience somewhat the same issues.

I had a linux firewall box die, so I set up the MikroTik Routerboard (RB2011UiAS-RM) and got it working with a few issues, but seemed to be okay. I have a small home business with a few statics, and using the RB2011 as a firewall, mail, web, dns, etc. I did this all a few weeks ago, but wanted to add additional items later/etc.

When I decided to make changes yesterday, I decided, for educational purposes to rest the router and start from scratch. Good experience right? :lol:

Well, after fighting with the Eth Boot versus Reset timing problem (thank you forum members) the RB was not answering with the IP, no matter what I did. Reboots, resets, etc. I tried various things for a few hours, with quite a bit of research, and no luck. No IP was assigned, no matter what I did reset-wise.

So in frustration, I unplugged the RB, and went to Best Buy to buy a Netgear firewall router to just get email and web server basics working. I got home about 1 hour or so later. On a whim, I plugged the RB back in, without resetting or anything else, and what do you know.. The RB2011 is showing an IP on the main screen, and its working on

So, there must be some sort of stored config that finally lets go (CMOS/SRAM? I'm not a EE, so apologies.)? This might explain what setjam saw as well.

Re: RB2011 factory reset

Posted: Tue Jan 13, 2015 6:25 pm
by jarda
Have you tried winbox connection with the mac address instead of looking for ip addresses in Web browser?