Community discussions

MUM Europe 2020
 
patrick2le
just joined
Topic Author
Posts: 14
Joined: Sun May 26, 2013 8:08 pm

RB2011UiAS-2HnD-IN forward service

Mon Jan 05, 2015 8:58 pm

Hello,

I have RB2011UiAS-2HnD-IN setup as adapter (ip 192.168.2.3) connect to another router with IP (192.168.2.1).
behind RB2011UiAS-2HnD-IN is my git server with ip 192.168.4.2; my git server name is gitserver.net.

from another pc (ip 192.168.2.4), I could forward the gitserver.net to 192.168.2.3; but I can not get throw the router RB2011UiAS-2HnD-IN
to be able to connect to 192.168.4.2.

I need some setup on RB2011UiAS-2HnD-IN, any help ?
I bridge all network 192.168.4.1 to 192.168.2.3

Pat
 
deanMKD1
Member
Member
Posts: 351
Joined: Fri Dec 12, 2014 12:06 am
Location: Macedonia
Contact:

Re: RB2011UiAS-2HnD-IN forward service

Tue Jan 06, 2015 2:38 am

1. First sete first router to work as AP.
2. Second Mikrotik 2011 set to work as Station Pseudobridge.
3. Open the port 80 to port 82 on RB2011 in first router where port 82 is your webserver.
4. Port Forward DST.Nat in RB 2011 from port 82 to local IP on your server on portr 80 (default).
5. Try to load your external IP. :D

p.s: set static ip to your server in pool 192.168.88.XXX.
 
patrick2le
just joined
Topic Author
Posts: 14
Joined: Sun May 26, 2013 8:08 pm

Re: RB2011UiAS-2HnD-IN forward service

Tue Jan 06, 2015 4:42 am

could I forward domain name(gitserver.net) to specific IP on router (Station Pseudobridge) ?
I don't want to change the port on my server.
if yes, how could i do it ?

thank
 
patrick2le
just joined
Topic Author
Posts: 14
Joined: Sun May 26, 2013 8:08 pm

Re: RB2011UiAS-2HnD-IN forward service

Tue Jan 06, 2015 6:14 pm

Hello,

I add a nat from wireless interface to the ethernet of my git server with port 80.

but, when i call gitserver.net I go directly to web page of mikrotik router, and not my git server.

any help ?

any service on mikrotik help to forward a domain name to specific ip ?

Patrick
 
User avatar
gabrielpike
Frequent Visitor
Frequent Visitor
Posts: 84
Joined: Thu Apr 17, 2014 4:17 pm

Re: RB2011UiAS-2HnD-IN forward service

Tue Jan 06, 2015 8:36 pm

I think what you are trying to do is done with 2 NAT rules. First create rules to NAT your LAN networks to the server and then create rules to dst-nat your public IP.

chain=srcnat action=masquerade protocol=tcp src-address=LAN_SUBNET_IP
dst-port=80

chain=dstnat action=dst-nat to-addresses=SERVER_IP_ADDRESS to-ports=80
protocol=tcp dst-address=PUBLIC_IP_ADDRESS dst-port=80
Gabriel Pike
MTCNA
 
deanMKD1
Member
Member
Posts: 351
Joined: Fri Dec 12, 2014 12:06 am
Location: Macedonia
Contact:

Re: RB2011UiAS-2HnD-IN forward service

Wed Jan 07, 2015 12:50 am

Please disable www from sevices when you want to redirect to port 80 on your webserver. Www use the same port as usual webserver.

Who is online

Users browsing this forum: Google [Bot], JacekG and 69 guests