Community discussions

MUM Europe 2020
 
shaheeduddin
just joined
Topic Author
Posts: 1
Joined: Thu Feb 12, 2015 10:03 am

required help to create DHCP for 1000 users

Thu Feb 12, 2015 10:18 am

i am first time user to mikrotik. it is RB450G with os 5.6 with me. i have to use this as a DHCP server and the addresses required are around 1000. internet is coming on eth1 with IP 10.11.53.25

how can i create a pool with 1000 IPs on eth2 and route them to eth1 so users will go to internet.

thanks in advance for help.
 
User avatar
PaulsMT
MikroTik Support
MikroTik Support
Posts: 283
Joined: Tue Feb 10, 2015 3:21 pm

Re: required help to create DHCP for 1000 users

Thu Feb 12, 2015 2:53 pm

Hello,

First, you should make IP for ether2 network, for example i'm using 22 mask bits, this will give me total 1022 hosts in network:

/ip address add address=10.0.0.1/22 interface=ether2 network=10.0.0.0
Add address that will be used for clients (in my example i'm using all available range from 10.0.0.1/22 network)
/ip pool add name=LAN ranges=10.0.0.1-10.0.3.254
Add dhcp server on ether 2 interface
/ip dhcp-server add address-pool=LAN disabled=no interface=ether2 lease-time=1d name=dhcp1
Add settings to your dhcp server
/ip dhcp-server network add address=10.0.0.0/22 dns-server=8.8.4.4 gateway=10.0.0.1

And finaly add gateway to internet:

/ip route add distance=1 gateway=10.11.53.25

and masqurade ether1 interface:
/ip firewall natadd action=masquerade chain=srcnat out-interface=ether1

This is the most basic setup to start.
 
User avatar
PaulsMT
MikroTik Support
MikroTik Support
Posts: 283
Joined: Tue Feb 10, 2015 3:21 pm

Re: required help to create DHCP for 1000 users

Fri Feb 13, 2015 8:35 am

There is also a good post about the same question:
http://forum.mikrotik.com/viewtopic.php?f=2&t=29577
 
User avatar
dunga
Member Candidate
Member Candidate
Posts: 254
Joined: Fri Jan 23, 2009 9:51 am
Location: Nigeria

Re: required help to create DHCP for 1000 users

Tue Feb 09, 2016 2:34 pm

Hello guys,
I am faced with such but mine case is that, in that network range, we are expected to access 1pc in that network.

The scenerio is this, 1pc is the database which all systems on the network will connect to to access an information, which about 1000 users are logging at the same time.

if seting up the address segment to /22 will all the system access that databse assuming the pc having the database or software is 178.30.20.3, will others in this segment 178.30.20.1/22 access it without any issues.

Thanks
 
kiaunel
Member Candidate
Member Candidate
Posts: 211
Joined: Mon Jul 21, 2014 7:59 pm
Location: Romania

Tue Feb 09, 2016 4:07 pm

Yes

Sent from my Lenovo K50-t5 using Tapatalk

Who is online

Users browsing this forum: No registered users and 38 guests