Community discussions

 
jgelderloos
just joined
Topic Author
Posts: 2
Joined: Wed Aug 19, 2015 11:01 pm

850Gx2 NAT Help

Wed Aug 19, 2015 11:10 pm

Hi, I am using a 850Gx2 with version 6.18. I am trying to setup a NAT so that I can telnet into a local device. I am using WebFig and my addresses are setup as follows:

192.168.10.100/24 - ether1-gateway
192.168.0.100/24 - ether5-slave-local
192.168.88.1/24 -ether2-master-local

I also have setup the NAT as follows:
dst-nat - Dst. Address: 192.168.10.100, To Address: 192.168.0.2
src-nat - Src. Address: 192.168.0.2, To Address: 192.168.10.100

When I try to communicate from ether1 on telnet I can see packets going through the dst-nat rule but I never see anything on the src-nat rule.

Another thing I noticed is that when using the packet sniffer I only ever see data on ehter1 and ether2, but never on ether 5. The data I see has the packets from 192.168.10.1 to 192.168.0.2 but nothing coming back from 192.168.0.2. However, when I torch ether2, I do see packets from 192.168.0.2 going to 192.168.10.1.

What am I doing wrong here?
 
GuJack20
Trainer
Trainer
Posts: 322
Joined: Sat Jun 12, 2004 9:44 pm
Location: Tirana
Contact:

Re: 850Gx2 NAT Help

Thu Aug 20, 2015 10:04 am

Too complicated setup for just a telnet that you need.
I would suggest to reset the router with: system reset no-default
Than make everything manually:
add ip to ether 1
add ip to ether 2
bridge ether2 to ether5
add masquerade
add dst-nat (no src-nat is required)

This way you have a clean router without those custom names of the interfaces and rules on firewall that may be blocking packets
--Do you remember that guy who gave up? Neither does anybody else!
 
jgelderloos
just joined
Topic Author
Posts: 2
Joined: Wed Aug 19, 2015 11:01 pm

Re: 850Gx2 NAT Help

Thu Aug 20, 2015 5:38 pm

So I tried doing what you said but it did not work. I had trouble with the no-default restart and could not talk to the router after this until I shorted the reset when powering up. Also when I made the bridge I did not see options for specifying what I was actually bridging.

I eventually solved my problem by doing the same thing that I had done before except I replaced the src-nat that I was using with a new src-nat for : Source Address: 192.168.10.1, To Address: 192.168.0.100.

Now when I send a packet Src: 192.168.10.1, Dst: 192.168.10.100 it correctly translates to Src: 192.168.0.100, Dst: 192.168.0.2.

Thanks for your willingness to help!

Who is online

Users browsing this forum: No registered users and 47 guests