Community discussions

 
User avatar
tejendragurung
just joined
Topic Author
Posts: 5
Joined: Wed Aug 15, 2018 2:18 pm
Location: Nepal

Juniper - Mikrotik LDP/BGP based VPLS

Wed Aug 15, 2018 2:37 pm

Query:
the BGP/LDP/VPLS/OSPF all protocols are UP and established but still the client_A to client_C can't ping in vlan_800(configured the BGP VPLS).
But within client_A to client_B (both connected to JUniper PE) can ping .
Please help to verify the configuration for establishing the VPLS connectivity between clients.
Any support would be thankfull.




Ping from Client A to client B and Client C
[admin@SITE-A-CLIENT] > ping 192.168.108.2
SEQ HOST SIZE TTL TIME STATUS
0 192.168.108.2 56 64 0ms
1 192.168.108.2 56 64 0ms
2 192.168.108.2 56 64 0ms
sent=3 received=3 packet-loss=0% min-rtt=0ms avg-rtt=0ms max-rtt=0ms

[admin@SITE-A-CLIENT] > ping 192.168.108.3
SEQ HOST SIZE TTL TIME STATUS
0 192.168.108.3 timeout
1 192.168.108.3 timeout
2 192.168.108.3 timeout
sent=3 received=0 packet-loss=100%

Ping from Client B to client A and Client C
[admin@SITE-B-CLIENT] > ping 192.168.108.1
SEQ HOST SIZE TTL TIME STATUS
0 192.168.108.1 56 64 0ms
1 192.168.108.1 56 64 0ms
2 192.168.108.1 56 64 0ms
sent=3 received=3 packet-loss=0% min-rtt=0ms avg-rtt=0ms max-rtt=0ms

[admin@SITE-B-CLIENT] > ping 192.168.108.3
SEQ HOST SIZE TTL TIME STATUS
0 192.168.108.3 timeout
1 192.168.108.3 timeout
2 192.168.108.3 timeout
sent=3 received=0 packet-loss=100%

vianoc@SITE-A> show vpls connections instance Juniper-Mikrotik
Layer-2 VPN connections:

Instance: Juniper-Mikrotik
Edge protection: Not-Primary
Local site: CLIENT-A (96)
connection-site Type St Time last up # Up trans
97 rmt Up Aug 14 15:36:49 2018 1
Remote PE: 103.10.30.97, Negotiated control-word: No
Incoming label: 47, Outgoing label: 51
Local interface: lsi.1048834, Status: Up, Encapsulation: VPLS
Description: Intf - vpls Juniper-Mikrotik local site 96 remote site 97
Flow Label Transmit: No, Flow Label Receive: No
98 rmt Up Aug 14 14:05:34 2018 1
Remote PE: 103.10.30.98, Negotiated control-word: No
Incoming label: 48, Outgoing label: 36
Local interface: lsi.1048832, Status: Up, Encapsulation: VPLS
Description: Intf - vpls Juniper-Mikrotik local site 96 remote site 98
Flow Label Transmit: No, Flow Label Receive: No





vianoc@SITE-B> show vpls connections instance Juniper-Mikrotik
Layer-2 VPN connections:

Instance: Juniper-Mikrotik
Edge protection: Not-Primary
Local site: CLIENT-B (97)
connection-site Type St Time last up # Up trans
96 rmt Up Aug 14 15:37:13 2018 1
Remote PE: 103.10.30.96, Negotiated control-word: No
Incoming label: 51, Outgoing label: 47
Local interface: lsi.1048833, Status: Up, Encapsulation: VPLS
Description: Intf - vpls Juniper-Mikrotik local site 97 remote site 96
Flow Label Transmit: No, Flow Label Receive: No
98 rmt Up Aug 14 15:39:14 2018 1
Remote PE: 103.10.30.98, Negotiated control-word: No
Incoming label: 37, Outgoing label: 37
Local interface: lsi.1048834, Status: Up, Encapsulation: VPLS
Description: Intf - vpls Juniper-Mikrotik local site 97 remote site 98
Flow Label Transmit: No, Flow Label Receive: No


[admin@SITE-C] > interface vpls print
Flags: X - disabled, R - running, D - dynamic, B - bgp-signaled, C - cisco-bgp-signaled
0 RDB name="vpls11" mtu=1500 l2mtu=1500 mac-address=02:3C:B1:FC:43:D2 arp=enabled arp-timeout=auto disable-running-check=no remote-peer=103.10.30.96
cisco-style=no cisco-style-id=0 advertised-l2mtu=1500 pw-type=raw-ethernet use-control-word=no vpls=Juniper-Mikrotik

1 RDB name="vpls12" mtu=1500 l2mtu=1500 mac-address=02:3C:B1:42:A5:DC arp=enabled arp-timeout=auto disable-running-check=no remote-peer=103.10.30.97
cisco-style=no cisco-style-id=0 advertised-l2mtu=1500 pw-type=raw-ethernet use-control-word=no vpls=Juniper-Mikrotik

2 RDB name="vpls13" mtu=1500 l2mtu=1500 mac-address=02:89:F0:C0:B4:B0 arp=enabled arp-timeout=auto disable-running-check=no remote-peer=103.10.30.96
cisco-style=no cisco-style-id=0 advertised-l2mtu=1500 pw-type=raw-ethernet use-control-word=no vpls=Juniper-Mikrotik-BGP

3 RDB name="vpls14" mtu=1500 l2mtu=1500 mac-address=02:92:C5:34:A7:B6 arp=enabled arp-timeout=auto disable-running-check=no remote-peer=103.10.30.97
cisco-style=no cisco-style-id=0 advertised-l2mtu=1500 pw-type=raw-ethernet use-control-word=no vpls=Juniper-Mikrotik-BGP
[admin@SITE-C] >





Topology :
client_A(Mikrotik) ----- SITE_A(Juniper)------------------SITE_C(Mikrotik)-----client_C(Mikrotik)


-------------------SITE-A JUNIPER----------------------------

vianoc@SITE-A> show configuration | display set
set version 17.4R1.16
set system host-name SITE-A
set interfaces xe-0/1/0 description "Uplink Provision"
set interfaces xe-0/1/1 description C_To:Site-B
set interfaces xe-0/1/1 vlan-tagging
set interfaces xe-0/1/1 unit 150 vlan-id 150
set interfaces xe-0/1/1 unit 150 family inet address 103.10.30.73/30
set interfaces xe-0/1/1 unit 150 family mpls

set interfaces xe-0/1/2 description "Provision for Site-3"
set interfaces xe-0/1/2 vlan-tagging
set interfaces xe-0/1/2 mtu 1600
set interfaces xe-0/1/2 unit 151 vlan-id 151
set interfaces xe-0/1/2 unit 151 family inet address 103.10.30.82/30
set interfaces xe-0/1/2 unit 151 family mpls

set interfaces xe-0/1/3 description "Provision for Client"
set interfaces xe-0/1/3 vlan-tagging
set interfaces xe-0/1/3 encapsulation vlan-vpls
set interfaces xe-0/1/3 unit 800 encapsulation vlan-vpls
set interfaces xe-0/1/3 unit 800 vlan-id 800
set interfaces xe-0/1/3 unit 800 family vpls
set interfaces xe-0/1/3 unit 1000 encapsulation vlan-vpls
set interfaces xe-0/1/3 unit 1000 vlan-id 1000
set interfaces xe-0/1/3 unit 1000 family vpls

set interfaces lo0 unit 0 family inet address 103.10.30.96/32

set routing-options router-id 103.10.30.96
set routing-options autonomous-system 65500
set routing-options forwarding-table export exp-to-fwd
set protocols rsvp interface all
set protocols rsvp interface xe-0/1/2.151
set protocols rsvp interface xe-0/1/1.150
set protocols mpls label-switched-path clientA-to-clientB to 103.10.30.97
set protocols mpls label-switched-path clientA-to-clientB primary path-AB
set protocols mpls label-switched-path siteA-siteC to 103.10.30.98
set protocols mpls label-switched-path siteA-siteC primary path-AC
set protocols mpls path path-AB 103.10.30.73
set protocols mpls path path-AB 103.10.30.97
set protocols mpls path path-AC 103.10.30.82
set protocols mpls path path-AC 103.10.30.98
set protocols mpls interface xe-0/1/1.150
set protocols mpls interface lo0.0
set protocols mpls interface xe-0/1/2.151
set protocols mpls interface all
set protocols bgp log-updown
set protocols bgp group Juniper-Mikrotik type internal
set protocols bgp group Juniper-Mikrotik local-address 103.10.30.96
set protocols bgp group Juniper-Mikrotik import match-all
set protocols bgp group Juniper-Mikrotik family l2vpn signaling
set protocols bgp group Juniper-Mikrotik neighbor 103.10.30.98
set protocols bgp group Juniper-Mikrotik neighbor 103.10.30.97
set protocols ospf traffic-engineering
set protocols ospf area 0.0.0.0 interface xe-0/1/1.150
set protocols ospf area 0.0.0.0 interface xe-0/1/2.151
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ldp egress-policy connected-only
set protocols ldp interface xe-0/1/1.150
set protocols ldp interface xe-0/1/2.151
set protocols ldp interface lo0.0
set policy-options prefix-list loopback-prefix 103.10.30.96/32
set policy-options policy-statement connected-only from prefix-list loopback-prefix
set policy-options policy-statement connected-only then accept
set policy-options policy-statement exp-to-fwd term a from protocol bgp
set policy-options policy-statement exp-to-fwd term a from community grn-com
set policy-options policy-statement exp-to-fwd term a then install-nexthop lsp siteA-siteC
set policy-options policy-statement exp-to-fwd term a then install-nexthop lsp clientA-to-clientB
set policy-options policy-statement exp-to-fwd term a then accept
set policy-options policy-statement match-all term acceptable then accept
set policy-options community grn-com members target:65500:5000
set routing-instances Juniper-Mikrotik instance-type vpls
set routing-instances Juniper-Mikrotik interface xe-0/1/3.800
set routing-instances Juniper-Mikrotik route-distinguisher 103.10.30.96:5000
set routing-instances Juniper-Mikrotik vrf-target target:65500:5000
set routing-instances Juniper-Mikrotik vrf-target import target:65500:5000
set routing-instances Juniper-Mikrotik vrf-target export target:65500:5000
set routing-instances Juniper-Mikrotik protocols vpls no-tunnel-services
set routing-instances Juniper-Mikrotik protocols vpls site CLIENT-A site-identifier 96
set vlans vlan-800 vlan-id 800
set vlans vlan-150 vlan-id 150
set vlans vlan-151 vlan-id 151



------------SITE-B JUNIPER ---------------------

vianoc@SITE-B> show configuration | display set
set version 17.4R1.16
set system host-name SITE-B
set interfaces xe-0/0/0 vlan-tagging
set interfaces xe-0/1/0 description C_To:Site-A
set interfaces xe-0/1/0 vlan-tagging
set interfaces xe-0/1/0 unit 150 vlan-id 150
set interfaces xe-0/1/0 unit 150 family inet address 103.10.30.74/30
set interfaces xe-0/1/0 unit 150 family mpls

set interfaces xe-0/1/1 description "Provision for SITE-C"
set interfaces xe-0/1/1 vlan-tagging
set interfaces xe-0/1/1 unit 152 vlan-id 152
set interfaces xe-0/1/1 unit 152 family inet address 103.10.30.77/30
set interfaces xe-0/1/1 unit 152 family mpls

set interfaces xe-0/1/2 description "C_To:Client RTR"
set interfaces xe-0/1/2 vlan-tagging
set interfaces xe-0/1/2 encapsulation vlan-vpls
set interfaces xe-0/1/2 unit 600 encapsulation vlan-vpls
set interfaces xe-0/1/2 unit 600 vlan-id 600
set interfaces xe-0/1/2 unit 600 family vpls
set interfaces xe-0/1/2 unit 800 encapsulation vlan-vpls
set interfaces xe-0/1/2 unit 800 vlan-id 800
set interfaces xe-0/1/2 unit 800 family vpls
set interfaces xe-0/1/2 unit 1000 encapsulation vlan-vpls
set interfaces xe-0/1/2 unit 1000 vlan-id 1000
set interfaces xe-0/1/2 unit 1000 family vpls

set interfaces lo0 unit 0 family inet address 103.10.30.97/32
set routing-options router-id 103.10.30.97
set routing-options autonomous-system 65500
set routing-options forwarding-table export exp-to-fwd
set protocols rsvp interface lo0.0
set protocols rsvp interface xe-0/1/0.150
set protocols rsvp interface all
set protocols mpls label-switched-path clientB-to-clientA to 103.10.30.96
set protocols mpls label-switched-path clientB-to-clientC to 103.10.30.98
set protocols mpls interface xe-0/1/0.150
set protocols mpls interface xe-0/1/1.151
set protocols mpls interface lo0.0
set protocols mpls interface all
set protocols bgp group Juniper-Mikrotik type internal
set protocols bgp group Juniper-Mikrotik local-address 103.10.30.97
set protocols bgp group Juniper-Mikrotik family l2vpn signaling
set protocols bgp group Juniper-Mikrotik neighbor 103.10.30.96
set protocols bgp group Juniper-Mikrotik neighbor 103.10.30.98
set protocols ospf traffic-engineering
set protocols ospf area 0.0.0.0 interface xe-0/1/0.150
set protocols ospf area 0.0.0.0 interface xe-0/1/1.152
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ldp interface xe-0/1/0.150
set protocols ldp interface xe-0/1/1.152
set protocols ldp interface lo0.0
set policy-options policy-statement exp-to-fwd term a from community grn-com
set policy-options policy-statement exp-to-fwd then install-nexthop lsp clientB-to-clientA
set policy-options policy-statement exp-to-fwd then install-nexthop lsp clientB-to-clientC
set policy-options policy-statement exp-to-fwd then accept
set policy-options community grn-com members target:65500:5000
set routing-instances Juniper-Mikrotik instance-type vpls
set routing-instances Juniper-Mikrotik interface xe-0/1/2.800
set routing-instances Juniper-Mikrotik route-distinguisher 103.10.30.97:5000
set routing-instances Juniper-Mikrotik vrf-target target:65500:5000
set routing-instances Juniper-Mikrotik vrf-target import target:65500:5000
set routing-instances Juniper-Mikrotik vrf-target export target:65500:5000
set routing-instances Juniper-Mikrotik protocols vpls no-tunnel-services
set routing-instances Juniper-Mikrotik protocols vpls site CLIENT-B site-identifier 97
set vlans vlan-800 vlan-id 800
set vlans vlan-150 vlan-id 150
set vlans vlan-151 vlan-id 151


-----------------------SITE-C MIKROTIK ----------------------

[admin@SITE-C] > export
# jan/12/1970 01:14:55 by RouterOS 6.40.4
# software id = 8315-513I
#
# model = CCR1072-1G-8S+
# serial number = 72730849B987
/interface bridge
add name=Juniper-Mikrotik protocol-mode=none
add name=loopback protocol-mode=none
/interface ethernet
set [ find default-name=sfp-sfpplus1 ] comment="C_To:Site-A xe-0/1/2" l2mtu=1632
set [ find default-name=sfp-sfpplus2 ] comment="C_To:Site-B xe-0/1/1"
set [ find default-name=sfp-sfpplus3 ] arp=disabled comment="C_To:SITE-C-CLIENT; SFP-1" mtu=1514
/interface vlan
add interface=sfp-sfpplus1 name=vlan151 vlan-id=151
add interface=sfp-sfpplus2 name=vlan152 vlan-id=152
add interface=sfp-sfpplus3 name=vlan800 vlan-id=800
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/mpls traffic-eng tunnel-path
add name=dyn
/interface traffic-eng
add disabled=no from-address=103.10.30.98 name=CtoA primary-path=dyn record-route=yes to-address=103.10.30.96
add disabled=no from-address=103.10.30.98 name=CtoB primary-path=dyn record-route=yes to-address=103.10.30.97
/routing bgp instance
set default as=65500 client-to-client-reflection=no router-id=103.10.30.98
/routing ospf instance
set [ find default=yes ] metric-other-ospf=20 mpls-te-area=backbone mpls-te-router-id=loopback redistribute-connected=as-type-1 redistribute-static=as-type-1 \
router-id=103.10.30.98
/interface bridge port
add bridge=Juniper-Mikrotik interface=vlan800
/interface vpls bgp-vpls
add bridge=Juniper-Mikrotik bridge-cost=0 bridge-horizon=1 export-route-targets=65500:5000 import-route-targets=65500:5000 name=Juniper-Mikrotik \
route-distinguisher=103.10.30.98:5000 site-id=98 use-control-word=no
add bridge=BGP-VPLS bridge-cost=0 bridge-horizon=1 export-route-targets=65500:1 import-route-targets=65500:1 name=Juniper-Mikrotik-BGP route-distinguisher=\
103.10.30.98:1 site-id=98 use-control-word=no
/ip address
add address=192.168.9.4/24 interface=ether1 network=192.168.9.0
add address=103.10.30.81/30 interface=vlan151 network=103.10.30.80
add address=103.10.30.78/30 interface=vlan152 network=103.10.30.76
add address=103.10.30.98 interface=loopback network=103.10.30.98
/ip route
add distance=1 dst-address=110.44.127.9/32 gateway=192.168.9.1
/lcd
set time-interval=hour
/lcd interface pages
set 0 interfaces=sfp-sfpplus1,sfp-sfpplus2,sfp-sfpplus3,sfp-sfpplus4,sfp-sfpplus5,sfp-sfpplus6,sfp-sfpplus7,sfp-sfpplus8
/mpls
set propagate-ttl=no
/mpls interface
set [ find default=yes ] mpls-mtu=1526
add interface=vlan151
add interface=vlan152
/mpls ldp
set enabled=yes lsr-id=103.10.30.98 transport-address=103.10.30.98
/mpls ldp advertise-filter
add prefix=103.10.30.0/24
add advertise=no
/mpls ldp interface
add interface=vlan151
add interface=vlan152
add interface=loopback
/mpls traffic-eng interface
add bandwidth=100kbps interface=vlan151
add bandwidth=100kbps interface=vlan152
/routing bgp peer
add address-families=l2vpn name=Juniper-Mikrotik remote-address=103.10.30.96 remote-as=65500 ttl=default update-source=loopback
add address-families=l2vpn name=Juniper-Mikrotik remote-address=103.10.30.97 remote-as=65500 ttl=default update-source=loopback
/routing ospf interface
add passive=yes
add interface=vlan151 network-type=broadcast
add interface=vlan152 network-type=broadcast
add interface=loopback network-type=point-to-point
/routing ospf network
add area=backbone network=103.10.30.76/30
add area=backbone network=103.10.30.80/30
add area=backbone network=103.10.30.98/32
/system identity
set name=SITE-C
 
Vooray
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Mon Feb 23, 2015 3:34 pm

Re: Juniper - Mikrotik LDP/BGP based VPLS

Wed Aug 15, 2018 9:05 pm

Tested both Martini and Kompella between Jun, cisco and Mikrotik some months ago and it worked fine.
There is a good book on subject :this week mpls from day one and good article on mikrotik wiki.
 
User avatar
tejendragurung
just joined
Topic Author
Posts: 5
Joined: Wed Aug 15, 2018 2:18 pm
Location: Nepal

Re: Juniper - Mikrotik LDP/BGP based VPLS

Thu Aug 16, 2018 7:06 am

Tested both Martini and Kompella between Jun, cisco and Mikrotik some months ago and it worked fine.
There is a good book on subject :this week mpls from day one and good article on mikrotik wiki.
Dear Vooray,
Thanks for reply.
I would be thankful if u could provide the config script for Kompella and martini VPLS for juniper-mikrotik .
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 959
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: Juniper - Mikrotik LDP/BGP based VPLS

Thu Aug 16, 2018 10:50 pm

Have you tired setting explicit null?

In the topology you have it looks like the PHP routers would be MikroTik and Juniper. We've seen issues before when the PHP routers are different vendors.
Global - MikroTik Support & Consulting - English | Francais | Español | Portuguese +1 855-645-7684
https://iparchitechs.com/services/mikro ... l-support/ mikrotiksupport@iparchitechs.com
 
User avatar
tejendragurung
just joined
Topic Author
Posts: 5
Joined: Wed Aug 15, 2018 2:18 pm
Location: Nepal

Re: Juniper - Mikrotik LDP/BGP based VPLS

Sun Aug 19, 2018 9:00 am

Have you tired setting explicit null?

In the topology you have it looks like the PHP routers would be MikroTik and Juniper. We've seen issues before when the PHP routers are different vendors.

### Thanks for reply and suggestion .
I tried with enabling the explicit null on mikrotik and juniper for CE connected Node, but still Client could not ping eachother.
Also i can see the both routers could learn the MAC for each client and vice-versa .
What could be the issue ? as both routers learn the MAC .

MIKROTIK
/mpls ldp
set enabled=yes lsr-id=103.10.30.98 transport-address=103.10.30.98 use-explicit-null=yes
vianoc@SITE-A> show configuration protocols mpls
explicit-null;

JUNIPER
vianoc@SITE-A> show vpls mac-table instance Juniper-Mikrotik

MAC flags (S -static MAC, D -dynamic MAC, L -locally learned, C -Control MAC
O -OVSDB MAC, SE -Statistics enabled, NM -Non configured MAC, R -Remote PE MAC, P -Pinned MAC)

Routing instance : Juniper-Mikrotik
Bridging domain : __Juniper-Mikrotik__, VLAN : NA
MAC MAC Logical NH MAC active
address flags interface Index property source
00:12:c0:80:3f:74 D lsi.1048853
cc:2d:e0:1c:45:59 D lsi.1048858
cc:2d:e0:c2:55:a5 D lsi.1048858
e4:8d:8c:3c:26:be D xe-0/1/3.800



[admin@SITE-C] > interface bridge host print
Flags: L - local, E - external-fdb
BRIDGE MAC-ADDRESS ON-INTERFACE AGE
Juniper-Mikrotik 00:12:C0:80:3F:74 vpls12 24s
L Juniper-Mikrotik 02:8E:A0:2F:42:D7 vpls12 0s
L Juniper-Mikrotik 02:AD:10:95:07:8A vpls11 0s
Juniper-Mikrotik CC:2D:E0:1C:45:59 vlan800 7s
L Juniper-Mikrotik CC:2D:E0:C2:55:A5 vlan800 0s
Juniper-Mikrotik E4:8D:8C:3C:26:BE vpls11 30s


[admin@SITE-A-CLIENT] > interface ethernet print
Flags: X - disabled, R - running, S - slave
# NAME MTU MAC-ADDRESS ARP
0 R ;;; SITE-A Uplink xe-0/1/3
ether1 1500 00:12:C0:80:3F:74 enabled


[admin@SITE-C-CLIENT] > interface ethernet print
Flags: X - disabled, R - running, S - slave
# NAME MTU MAC-ADDRESS ARP MASTER-PORT SWITCH
1 R ;;; C_To:SITE-C Uplink
sfp-sfpplus1 1500 CC:2D:E0:1C:45:59 enabled none
 
User avatar
tejendragurung
just joined
Topic Author
Posts: 5
Joined: Wed Aug 15, 2018 2:18 pm
Location: Nepal

Re: Juniper - Mikrotik LDP/BGP based VPLS

Wed Sep 05, 2018 7:42 am

Dear Mikrotik Support team / Friends,

Please help to provide the solution for configuring the Juniper-Mikrotik LDP/BGP based VPLS .. I had send the below config for analysis .
 
User avatar
tejendragurung
just joined
Topic Author
Posts: 5
Joined: Wed Aug 15, 2018 2:18 pm
Location: Nepal

Re: Juniper - Mikrotik LDP/BGP based VPLS

Thu Sep 13, 2018 2:06 pm

Dear Friends/Support team.

Currently i faced the issue: Can't ping the mpls ldp lsp from Juniper to Mikrotik Vice-versa, As from Juniper and Mikrotik we could learn the LSP for each path.
Please help to suggest .

[admin@SITE-C] /mpls ldp neighbor> print
Flags: X - disabled, D - dynamic, O - operational, T - sending-targeted-hello,
V - vpls
# TRANSPORT LOCAL-TRANSPORT PEER SEN
0 DO 103.10.30.97 103.10.30.98 103.10.30.97:0 no
1 DOTV 103.10.30.96 103.10.30.98 103.10.30.96:0 yes

[admin@SITE-C] /mpls ldp> interface print
Flags: X - disabled, I - invalid
# INTERFACE HELLO-INTERVAL HOLD-TIME
0 vlan151 5s 15s
1 vlan152 5s 15s


vianoc@SITE-A# run ping mpls ldp 103.10.30.97 detail
Request for seq 1, to interface 338, no label stack., packet size 80
Reply for seq 1, return code: Egress-ok, time: 8228334.309 ms
Local transmit time: 2018-09-13 16:14:41 UTC 722.479 ms
Remote receive time: 2018-09-13 18:31:50 UTC 56.788 ms
Request for seq 2, to interface 338, no label stack., packet size 80
Reply for seq 2, return code: Egress-ok, time: 8228333.140 ms
Local transmit time: 2018-09-13 16:14:42 UTC 721.995 ms
Remote receive time: 2018-09-13 18:31:51 UTC 55.135 ms
Request for seq 3, to interface 338, no label stack., packet size 80
Reply for seq 3, return code: Egress-ok, time: 8228333.439 ms
Local transmit time: 2018-09-13 16:14:43 UTC 728.908 ms
Remote receive time: 2018-09-13 18:31:52 UTC 62.347 ms
Request for seq 4, to interface 338, no label stack., packet size 80
Reply for seq 4, return code: Egress-ok, time: 8228333.153 ms
Local transmit time: 2018-09-13 16:14:44 UTC 721.443 ms
Remote receive time: 2018-09-13 18:31:53 UTC 54.596 ms
Request for seq 5, to interface 338, no label stack., packet size 80
Reply for seq 5, return code: Egress-ok, time: 8228333.506 ms
Local transmit time: 2018-09-13 16:14:45 UTC 720.444 ms
Remote receive time: 2018-09-13 18:31:54 UTC 53.950 ms

--- lsping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss

[edit routing-instances LDPVPLS protocols vpls]
vianoc@SITE-A# run ping mpls ldp 103.10.30.98 detail
Request for seq 1, to interface 333, no label stack., packet size 80
Request for seq 2, to interface 333, no label stack., packet size 80
Request for seq 3, to interface 333, no label stack., packet size 80
Timeout for seq 1
Request for seq 4, to interface 333, no label stack., packet size 80
Timeout for seq 2
Request for seq 5, to interface 333, no label stack., packet size 80
Timeout for seq 3
Timeout for seq 4
Timeout for seq 5

--- lsping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss


vianoc@SITE-B# run ping mpls ldp 103.10.30.96 detail
Request for seq 1, to interface 346, no label stack., packet size 80
Reply for seq 1, return code: Egress-ok, time: -8228331.732 ms
Local transmit time: 2018-09-13 18:33:08 UTC 367.860 ms
Remote receive time: 2018-09-13 16:16:00 UTC 36.128 ms
Request for seq 2, to interface 346, no label stack., packet size 80
Reply for seq 2, return code: Egress-ok, time: -8228331.778 ms
Local transmit time: 2018-09-13 18:33:09 UTC 365.077 ms
Remote receive time: 2018-09-13 16:16:01 UTC 33.299 ms
Request for seq 3, to interface 346, no label stack., packet size 80
Reply for seq 3, return code: Egress-ok, time: -8228331.871 ms
Local transmit time: 2018-09-13 18:33:10 UTC 359.834 ms
Remote receive time: 2018-09-13 16:16:02 UTC 27.963 ms
Request for seq 4, to interface 346, no label stack., packet size 80
Reply for seq 4, return code: Egress-ok, time: -8228331.212 ms
Local transmit time: 2018-09-13 18:33:11 UTC 365.091 ms
Remote receive time: 2018-09-13 16:16:03 UTC 33.879 ms
Request for seq 5, to interface 346, no label stack., packet size 80
Reply for seq 5, return code: Egress-ok, time: -8228331.917 ms
Local transmit time: 2018-09-13 18:33:12 UTC 359.838 ms
Remote receive time: 2018-09-13 16:16:04 UTC 27.921 ms

--- lsping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss

[edit routing-instances LDPVPLS protocols vpls]
vianoc@SITE-B# run ping mpls ldp 103.10.30.98 detail
Request for seq 1, to interface 335, no label stack., packet size 80
Request for seq 2, to interface 335, no label stack., packet size 80
Request for seq 3, to interface 335, no label stack., packet size 80
Timeout for seq 1
Request for seq 4, to interface 335, no label stack., packet size 80
Timeout for seq 2
Request for seq 5, to interface 335, no label stack., packet size 80
Timeout for seq 3
Timeout for seq 4
Timeout for seq 5

--- lsping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss
You do not have the required permissions to view the files attached to this post.
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 959
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: Juniper - Mikrotik LDP/BGP based VPLS

Sat Sep 15, 2018 5:30 pm

Can you post the output of the MPLS forwarding tables for the Juniper and MIkroTIk routers?
Global - MikroTik Support & Consulting - English | Francais | Español | Portuguese +1 855-645-7684
https://iparchitechs.com/services/mikro ... l-support/ mikrotiksupport@iparchitechs.com

Who is online

Users browsing this forum: No registered users and 3 guests