Community discussions

MikroTik App
 
orisis
just joined
Topic Author
Posts: 15
Joined: Fri Feb 05, 2016 12:15 am

OSPF config to pair with OpenWRT

Sat Apr 10, 2021 3:13 pm

Hi all,

I'd like to connct routerOS with openwrt..
My network already have ospfd running and redistributing network routing tables.
I tried to pair it with mikrotik router without success.
What do I need to do to match this config:
!
! OSPFD configuration
!
!
hostname NODE4
!
password xxxxx
enable password xxxxx
no banner motd
!
router ospf
	network 192.168.11.0/24 area 1
!
ospf router-id 192.168.11.1
!
redistribute connected
!
! Enable RFC-1583 compatibility to avoid routing loops
    compatible rfc1583 
!
line vty
!
!log file /var/log/quagga/ospfd.log
Thank you!
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1372
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: OSPF config to pair with OpenWRT

Sun Apr 11, 2021 2:19 am

Assuming the router id for the other side is 192.168.11.2 , this should be all you need to match that config.
/routing ospf instance
set [ find default=yes ] router-id=192.168.11.2 redistribute-connected=as-type-1
/routing ospf network
add area=backbone network=192.168.11.0/24
Global - MikroTik Support & Consulting - English | Español | Serbian | Danish +1 855-645-7684
https://iparchitechs.com/ecosystem/mikr ... consulting mikrotiksupport@iparchitechs.com

Who is online

Users browsing this forum: No registered users and 10 guests