Community discussions

MikroTik App
 
V0R0NA
just joined
Topic Author
Posts: 2
Joined: Fri Apr 09, 2021 10:23 am

OSPF via GRE/IPSec

Fri Apr 09, 2021 1:28 pm

Hello!
I try to configure dynamic routing with MikroTik.
Now I have working GRE tunnel between opnsense and routerboard.
After start ospf instanses I have corrects routes on opensense. But on MikroTik I have routes without gateway address and interface.


/routing ospf> neighbor print
0 instance=default router-id=172.26.0.1 address=100.100.100.41
interface=vorona-gate priority=1 dr-address=0.0.0.0
backup-dr-address=0.0.0.0 state="Full" state-changes=50 ls-retransmits=0
ls-requests=0 db-summaries=0 adjacency=23m31s

Here we can see, that address 100.100.100.41 (opensense)
But in recieved routes I have:

Image

Why I haven't gateway address here?

Also, I haven't this route in routing table for this reason.

configs:
Tik:
/routing ospf area
set [ find default=yes ] disabled=yes
add area-id=172.16.117.0 name=area1
/routing ospf instance
set [ find default=yes ] router-id=172.16.117.1
/routing ospf interface
add passive=yes
add interface=vorona-gate network-type=point-to-point
/routing ospf network
add area=area1 network=100.100.100.40/30
add area=area1 network=172.16.117.0/24

Opensense:
frr version 7.4
frr defaults datacenter
hostname gate.vorona.su
log syslog
!
interface gre1
ip ospf area 172.16.117.0
!
interface vtnet1
ip ospf area 0.0.0.0
!
router ospf
ospf router-id 172.26.0.1
passive-interface vtnet1
!
ip prefix-list test seq 10 permit 172.26.0.0/28
!
line vty
!
end

Gre interfaces has addresses from 100.100.100.40/30 network

What I'm doing wrong?
 
lz1dsb
Member Candidate
Member Candidate
Posts: 226
Joined: Wed Aug 07, 2013 11:48 am

Re: OSPF via GRE/IPSec

Sat Apr 17, 2021 8:59 pm

Looks like your default backbone area on the Router OS is being disabled:
/routing ospf area
set [ find default=yes ] disabled=yes
add area-id=172.16.117.0 name=area1

Could your try to enable it?
 
mikeeg02
Frequent Visitor
Frequent Visitor
Posts: 90
Joined: Fri Mar 30, 2018 2:28 am

Re: OSPF via GRE/IPSec

Wed Apr 21, 2021 4:36 pm

Looks like your default backbone area on the Router OS is being disabled:
/routing ospf area
set [ find default=yes ] disabled=yes
add area-id=172.16.117.0 name=area1

Could your try to enable it?
It looks like hes using area-id=172.16.117.0 on the gre interface between the opensense and mikrotik, and the opensense is acting as an ABR because it also has backbone listed.
Im not familiar with the opensense, but is its default ospf interfaces point to point? I dont see a line in the config saying type, but in the mikrotik you are specifying point to point.

Are your MTUs correct on interfaces? That can cause ospf oddities too.
 
V0R0NA
just joined
Topic Author
Posts: 2
Joined: Fri Apr 09, 2021 10:23 am

Re: OSPF via GRE/IPSec

Wed Apr 21, 2021 5:32 pm

Hello!
I'm not using BB zone here, for this reason I disabled it. But I try to use BB zone. Result same. I see route, but there is no gateway here.

MTU at both sides of tunnel same. In case, when MTU different MT say it in logs.

Is there more ideas?
 
mikeeg02
Frequent Visitor
Frequent Visitor
Posts: 90
Joined: Fri Mar 30, 2018 2:28 am

Re: OSPF via GRE/IPSec

Wed Apr 21, 2021 6:00 pm

Mikrotik does not log l2mtu misconfiguration when type is set to point to point.

Is point to point default on the other router? I did not see you setting type on it.

Who is online

Users browsing this forum: No registered users and 7 guests