Community discussions

MikroTik App
 
AndreyRyzhov
just joined
Topic Author
Posts: 2
Joined: Tue May 11, 2021 2:03 pm

OSPF with FRR Zebra

Tue May 11, 2021 2:58 pm

Hi everyone!
I`m stucked with a problem...
I got a RB952 Hap ACLite router used as external L2TP central point with Globally routed ISP IP Address. It uses plain L2TP with PPP accounts for users, no IPSec or any other security algos used.
Then, I got RB3011 connected as a client. It lies behind NAT`s, that`s the reason why I`m using L2TP rather all of those GRE or PPTP.
Finally, I got 2 Linux gateways as L2TP Clients, they also connected to my Hap ACLite.
Problem is, that i got OSPF configured between them, so OSPF between Mikrotiks works excellent, but that freakin FRR, just don`t want working as needed.
I`m attach Mikrotik OSPF routes screenshot. I think the issue is in missing gateway on 192.168.54.0/24 subnet which is not working as expected.
More than that, when I`m tracing IPs from 192.168.54.0/24 subnet, Mikrotik try to find it via ISP provided IP address, not the L2TP link.
And this subnet route didn`t appear in main routing table.
I wonder where is the issue, is it in Mikrotik side or on FRR side...


Question solved by switching on ROS7.
Last edited by AndreyRyzhov on Wed May 12, 2021 10:03 am, edited 1 time in total.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6252
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: OSPF with FRR Zebra

Wed May 12, 2021 9:07 am

OSPF in ROS v6 does not support unnumbered interfaces. LSAs received from such routers will show up without gateway.

Feature to support such setups is added in ROS v7.
 
AndreyRyzhov
just joined
Topic Author
Posts: 2
Joined: Tue May 11, 2021 2:03 pm

Re: OSPF with FRR Zebra

Wed May 12, 2021 10:02 am

Thanks, that make it work!
I spent 2 days wondering, what can it be...

But theres a little misundestood here...
Linux machines got their /32 addresses and didnt worked with ROS6
But other Mikrotik (3011) also got his /32 address and... routes from him appeared with their gateway.
Question is.. why?

Now, I switched to ROS7.1b5 and my OSPF config just... erased. Cool!
So I created a new config and it seems to works fine.
I`m wondering is there any walkaround how to use L2TP tunnels (maybe not with 32 bit mask) and still be able to use OSPF?
OpenVPN, PPTP or GRE not in count, they aren`t applicable...
I just didnt find solution, how to propagate not 32 bit mask. I like to propogate /25...
But seems like we got PPP connection types, I think it`s not possible...

Who is online

Users browsing this forum: No registered users and 14 guests