Community discussions

MikroTik App
 
DBob
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 81
Joined: Fri Jun 10, 2011 4:13 pm

IGMP-proxy & CSR326

Wed Jun 23, 2021 7:49 pm

Hi,

I'm having some weird and frustrating issues with my IGMP setup.
/routing igmp-proxy interface
add interface=STB-SOURCE
add interface=CRS326
add disabled=yes interface=WIFIMESH
add alternative-subnets=10.0.0.0/8,192.168.0.0/16 interface=GPON upstream=yes
Due to some limitation, there are several daisy-chained switches, which is fine by me.
However, it seems to be, no IGMP / multicast packets are going through on the CRS326-24G-2S+, but everything works fine on the other interface (named, STB-SOURCE)

The CRS326 has been reseted since, moved to SwOS and back to RouterOS, nothing helped.
All devices are updated to the latest stable branch, including firmware upgrades.

Even more weird, if I patch the UTP from port 'STB-SOURCE' to the 'CRS326' port, bypassing the CRS, suddenly every multicast starts to work.

Export of the CRS is the following:
/interface bridge
add name=BRIDGE
/interface ethernet
set [ find default-name=ether10 ] comment=ether10
set [ find default-name=ether12 ] comment=ether12
set [ find default-name=ether14 ] comment=ether14
set [ find default-name=ether16 ] comment=ether16
set [ find default-name=ether9 ] comment=ether09 
set [ find default-name=ether11 ] comment=ether11 
set [ find default-name=ether13 ] comment=ether13 
set [ find default-name=ether15 ] comment=ether15 
set [ find default-name=ether1 ] arp=proxy-arp comment=ether01 name=UPLINK
set [ find default-name=ether3 ] comment=ether03 disabled=yes name=UPLINK2
set [ find default-name=ether2 ] comment=ether02
set [ find default-name=ether4 ] comment=ether04
set [ find default-name=ether5 ] comment=ether05
set [ find default-name=ether6 ] comment=ether06
set [ find default-name=ether7 ] comment=ether07
set [ find default-name=ether8 ] comment=ether08
set [ find default-name=ether17 ] comment=ether17
set [ find default-name=ether18 ] comment=ether18
set [ find default-name=ether19 ] comment=ether19
set [ find default-name=ether20 ] comment=ether20
set [ find default-name=ether21 ] comment=ether21
set [ find default-name=ether22 ] comment=ether22
set [ find default-name=ether23 ] comment=ether23
set [ find default-name=ether24 ] comment=ether24
set [ find default-name=sfp-sfpplus1 ] comment=ether25
set [ find default-name=sfp-sfpplus2 ] comment=ether26
/interface ethernet switch
set 0 name=SWITCH
/port
set 0 baud-rate=9600 name=RS232
/user group
set full policy=local,telnet,ssh,ftp,reboot,read,write,policy,test,winbox,password,web,sniff,sensitive,api,romon,dude,tik
/interface bridge port
add bridge=BRIDGE fast-leave=yes interface=UPLINK multicast-router=permanent priority=0x10
add bridge=BRIDGE fast-leave=yes interface=ether18
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/ip settings
set accept-redirects=yes accept-source-route=yes rp-filter=loose tcp-syncookies=yes
/interface bridge vlan
add bridge=BRIDGE disabled=yes tagged=*1B untagged=ether18,ether20,ether22,ether24 vlan-ids=150
/ip address
add address=192.168.1.2/24 interface=UPLINK network=192.168.1.0
/ip dns
set servers=192.168.1.1
/ip firewall service-port
set ftp disabled=yes
set tftp disabled=yes
set irc disabled=yes
set h323 disabled=yes
set sip disabled=yes
set pptp disabled=yes
set udplite disabled=yes
set dccp disabled=yes
set sctp disabled=yes
/ip route
add distance=1 gateway=192.168.1.1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
As you see, nothing fancy (yet), as I've still kept the configuration quite simple to eliminate potential problems. But no luck.

Any idea? ...
 
DBob
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 81
Joined: Fri Jun 10, 2011 4:13 pm

Re: IGMP-proxy & CSR326

Fri Jun 25, 2021 5:08 pm

Also, the summa traffic doesn't make sense.
The interface BRIDGE has to physical ports added, eth18 and eth1 (UPLINK). HW Offload is working, basically the two ports are switched together, and that's it.
Képernyőkép 2021-06-25 160413.png
Képernyőkép 2021-06-25 160316.png
Képernyőkép 2021-06-25 160237.png
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: No registered users and 9 guests