Community discussions

MikroTik App
 
joegoldman
Long time Member
Long time Member
Topic Author
Posts: 654
Joined: Mon May 27, 2013 2:05 am

OSPF Out Filter

Tue Sep 14, 2021 12:18 am

Hi forum,

I have a router that gets a connected route via ppp which is pretty standard. The issue is its redistributing that route (as connected route so lower cost) to other peers - its just a router ID so it does not affect customer traffic but causes weird issues and traceroutes when we monitor by that IP.

The obvious solution is to try and block it redistributing that route in filters but for the life of me I can't get it to stop advertising it. This is the 2 filters im trying to use (one more specific than the other) but neither seem to be working to filter this route out:
/routing filter
add action=discard chain=ospf-out-new prefix=1.2.3.4 protocol=connect
add action=discard chain=ospf-out-new prefix=1.2.3.4 prefix-length=32
The instance definitely showing using the custom out filter (using standard ospf-out didn't work either, but this forces it to show in the config export):
/routing ospf instance
set [ find default=yes ] out-filter=ospf-out-new redistribute-connected=as-type-1 redistribute-other-ospf=as-type-1 redistribute-static=as-type-1 router-id=xx.xx.xx.xx
I'm just at a loss on how to have this router NOT redistribute the PPP connected route.

Thanks.
 
User avatar
nichky
Forum Veteran
Forum Veteran
Posts: 773
Joined: Tue Jun 23, 2015 2:35 pm

Re: OSPF Out Filter

Tue Sep 14, 2021 2:11 am

is that on backbone area?
As far as i know filters doesn't work on that area
If both SSIDs are good quality signal, most modern devices choose 5GHz for the speed.
viewtopic.php?f=7&t=176537


!) Safe Mode is your friend;
 
joegoldman
Long time Member
Long time Member
Topic Author
Posts: 654
Joined: Mon May 27, 2013 2:05 am

Re: OSPF Out Filter

Tue Sep 14, 2021 2:22 am

is that on backbone area?
As far as i know filters doesn't work on that area
Yes it all runs on a single area.

Why wouldn't filters work on backbone thats weird - i use ospf-in extensibly to re-write the pref-source without issue - do you have source on this? I can't find it in the wiki.
 
User avatar
nichky
Forum Veteran
Forum Veteran
Posts: 773
Joined: Tue Jun 23, 2015 2:35 pm

Re: OSPF Out Filter

Tue Sep 14, 2021 2:32 am

that is from my experience,
maye Guru will say something different than i did above
If both SSIDs are good quality signal, most modern devices choose 5GHz for the speed.
viewtopic.php?f=7&t=176537


!) Safe Mode is your friend;
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6334
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: OSPF Out Filter

Tue Sep 14, 2021 10:03 am

Not enough information. What type of LSAs you are trying to filter? RouterOS allows filtering only external
 
millenium7
Member
Member
Posts: 374
Joined: Wed Mar 16, 2016 6:12 am

Re: OSPF Out Filter

Wed Sep 15, 2021 7:19 am

OSPF has many frustrating issues, this is one of them. All routers in an area need to agree on the routing table, this means you can't filter rules to another router in the same area. The rule is there for a reason but unfortunately it's just not suitable in many modern dynamically expanding networks. The only real IGP protocol MikroTik supports is OSPF so we're stuck with it until they implement IS-IS, EIGRP or another routing protocol gets developed and adopted

Your only solution is either BGP, or if viable and your network design permits, then put those routers into another area. The latter solution boxes you in and often creates issues down the track. However you at least don't need to have unique area numbers. You can have as many 'area1' routers as you want, they don't need to be joined to each other and they'll still be able to route as expected (you just can't expand beyond that area, as all area's need to connect to the backbone, so you can't do an Area0->Area1->Area2 design)
 
User avatar
nichky
Forum Veteran
Forum Veteran
Posts: 773
Joined: Tue Jun 23, 2015 2:35 pm

Re: OSPF Out Filter

Wed Sep 15, 2021 9:21 am

read above what mrz said, he gave you the answer.
He pointed out on backbone are.
If you want to filter other LSAs , than you need to use none-backbone area
If both SSIDs are good quality signal, most modern devices choose 5GHz for the speed.
viewtopic.php?f=7&t=176537


!) Safe Mode is your friend;

Who is online

Users browsing this forum: herdins and 10 guests