Community discussions

 
rado3105
Member
Member
Topic Author
Posts: 480
Joined: Sat Jan 12, 2008 11:45 pm

What is ideal MTU for gre tunnel

Fri Oct 16, 2015 11:25 pm

Using interface/gre I created unsecured tunnel (point to point). I would like to ask, if it is any recommended MTU to be set? or it is just good to leave it default?
 
w0lt
Member
Member
Posts: 484
Joined: Wed Apr 02, 2008 2:12 pm
Location: Minnesota USA

Re: What is ideal MTU for gre tunnel

Sat Oct 17, 2015 12:45 am

Using interface/gre I created unsecured tunnel (point to point). I would like to ask, if it is any recommended MTU to be set? or it is just good to leave it default?
Check the Tx Drops after you set it at default. It also might depend on the MTU's of the interfaces on each end. As an example, setting a GRE tunnel, over the internet, and using IPSec and a PPPoE connection on one end drove it to 1406 but using a cable modem on the other end drove it to 1426.
As it still kept dropping packets, even when I set the cable modem GRE to 1406, so I set them both to 1370.
Seems very stable now. Your experience might vary, but there you go.

-tp
MTCNA - 2011

" The Bitterness of Poor Quality Remains Long After the Sweetness of Low Price is Forgotten "

Image
 
rado3105
Member
Member
Topic Author
Posts: 480
Joined: Sat Jan 12, 2008 11:45 pm

Re: What is ideal MTU for gre tunnel

Sat Oct 17, 2015 1:20 am

it is set to 1500, rx, tx drops: 0
 
User avatar
TheLimey
just joined
Posts: 3
Joined: Sat Dec 06, 2014 12:47 am

Re: What is ideal MTU for gre tunnel

Sat Mar 17, 2018 7:18 pm

I know this is a very old thread, but it seems like a good place to share my experience.

I just spent about 15 hours trying to work out why Windows remote desktop and domain authentication stuff wouldn't work across a client's inter site VPN when I changed it from pure IPsec to GRE over IPsec (an attempt to fix RDP disconnects). Two of the four computers worked after some poking about, but the the other two would always hang while trying to connect, or fail authentication. Pinging the server was fine though.

Eventually it occurred to me it may be related to the MTU. I lowered the Windows ethernet interface MTU to 1300, which fixed the issues on that computer.

Not wanting to have to change the MTU for all current and future computers in this location, I tried changing the MTU in the GRE interface on both ends of the VPN connection; I had left it blank when I created them.

Setting the MTU to 1500 fixed it.

I hope this helps someone =)

Who is online

Users browsing this forum: No registered users and 4 guests