Community discussions

MikroTik App
 
earcaesar1
just joined
Topic Author
Posts: 14
Joined: Fri Jun 26, 2015 7:59 pm

OSPF Route Error > Discarding Packet locally originated

Thu Dec 03, 2015 3:57 pm

Hoping to get some help and insite as to what is going on. I believe I understand what is happening and why the error is happening but I don't know how to resolve the issue.

Was looking at my logs recently and saw this error happening a bunch.

07:45:27 route,ospf,error Discarding packet: locally originated
07:45:27 route,ospf,error src address=172.17.0.1
07:45:27 route,ospf,error Discarding packet: locally originated
07:45:27 route,ospf,error src address=172.17.0.1
07:45:27 route,ospf,error Discarding packet: locally originated
07:45:27 route,ospf,error src address=172.17.0.1
07:45:27 route,ospf,error Discarding packet: locally originated
07:45:27 route,ospf,error src address=172.17.0.1
07:45:27 route,ospf,error Discarding packet: locally originated
07:45:27 route,ospf,error src address=172.17.0.1
07:45:27 route,ospf,error Discarding packet: locally originated
07:45:27 route,ospf,error src address=172.17.0.1
07:45:27 route,ospf,error Discarding packet: locally originated
07:45:27 route,ospf,error src address=172.17.0.1
07:45:27 route,ospf,error Discarding packet: locally originated
07:45:27 route,ospf,error src address=172.17.0.1
07:45:27 route,ospf,error Discarding packet: locally originated
07:45:27 route,ospf,error src address=172.17.0.1
07:45:27 route,ospf,error Discarding packet: locally originated
07:45:27 route,ospf,error src address=172.17.0.1
07:45:27 route,ospf,error Discarding packet: locally originated
07:45:27 route,ospf,error src address=172.17.0.1
07:45:27 route,ospf,error Discarding packet: locally originated
07:45:27 route,ospf,error src address=172.17.0.1
07:45:27 route,ospf,error Discarding packet: locally originated
07:45:27 route,ospf,error src address=172.17.0.1
07:45:27 route,ospf,error Discarding packet: locally originated
07:45:27 route,ospf,error src address=172.17.0.1
07:45:27 route,ospf,error Discarding packet: locally originated
07:45:27 route,ospf,error src address=172.17.0.1
07:45:27 route,ospf,error Discarding packet: locally originated
07:45:27 route,ospf,error src address=172.17.0.1
07:45:27 route,ospf,error Discarding packet: locally originated
07:45:27 route,ospf,error src address=172.17.0.1
07:45:27 route,ospf,error Discarding packet: locally originated
07:45:27 route,ospf,error src address=172.17.0.1
07:45:27 route,ospf,error Discarding packet: locally originated
07:45:27 route,ospf,error src address=172.17.0.1

I believe it is due to when I am creating my PPP Secrets I am using the same local address. Everything that I have read online for help on creating a PPTP tunnel seems to say to make the local address the same. Everything works the way that I want it to work, but my logs are getting flooded by this error. I think that if I were to make the local address unique for each one I will be able to resolve the error.

This is a small portion of my PPTP server file.

# dec/03/2015 07:31:36 by RouterOS 6.33.2
# software id = 6B63-Q6TR
#
/interface ethernet
set [ find default-name=ether2 ] master-port=ether1
set [ find default-name=ether3 ] master-port=ether1
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=aes-128-cbc
add enc-algorithms=3des name=SbocaCalltek pfs-group=none
/ip pool
add name=pool1 ranges=10.255.252.3-10.255.255.254
/ip dhcp-server
add address-pool=pool1 disabled=no interface=ether1 name=server1
/ppp profile
set *FFFFFFFE dns-server=8.8.8.8
/routing ospf area
add area-id=10.0.0.0 name=VPN

/routing ospf instance
set [ find default=yes ] router-id=10.255.0.1
/tool user-manager customer
set admin access=\
own-routers,own-users,own-profiles,own-limits,config-payment-gw
/interface l2tp-server server
set enabled=yes
/interface pptp-server server
set enabled=yes
/interface sstp-server server
set enabled=yes
/ip address
add address=
add address=10.255.0.1/16 disabled=yes interface=ether1 network=10.255.0.0
add address=172.17.0.1/16 interface=ether1 network=172.17.0.0
/ip dhcp-server network
add address=10.255.0.0/16 dns-server=10.255.0.1 gateway=10.255.0.1
/ip dns
set allow-remote-requests=yes servers=75.75.75.75,75.75.76.76
/ip firewall filter
add chain=input protocol=icmp
add chain=input dst-port=8291 protocol=tcp
add chain=input dst-port=8010 protocol=tcp
add chain=input dst-port=8728 protocol=tcp
add chain=input dst-port=443 protocol=tcp
add chain=input dst-port=1723 protocol=tcp
add chain=input dst-port=500 protocol=udp
add chain=input connection-state=established,related
add action=drop chain=input in-interface=ether8
add chain=forward connection-state=established,related
add action=drop chain=forward connection-state=invalid in-interface=ether8
add chain=input disabled=yes dst-port=500 protocol=udp
add chain=input disabled=yes dst-port=1701 protocol=udp
add action=log chain=input disabled=yes log-prefix=OSPF-IN-LinkLocal \
protocol=ospf src-address=172.17.0.1
add action=drop chain=input disabled=yes protocol=ospf src-address=172.17.0.1
/ip firewall nat
add chain=srcnat dst-address=192.168.150.0/24 src-address=172.17.0.0/16
add action=masquerade chain=srcnat out-interface=ether8
add action=masquerade chain=srcnat out-interface=ether8 src-address=\
172.17.0.0/16
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www port=8010
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/ppp secret
add local-address=172.17.0.1 name=Site1 \
password= profile=default-encryption remote-address=172.17.0.4 \
service=sstp
add local-address=172.17.0.1 name=Site2 \
password= profile=default-encryption remote-address=172.17.0.5 \
service=sstp
add local-address=172.17.0.1 name=Site3 password=\
profile=default-encryption remote-address=172.17.0.7 service=sstp
add local-address=172.17.0.1 name=Site4 password=\
profile=default-encryption remote-address=172.17.0.6 service=sstp

/routing ospf network
add area=VPN network=172.17.0.0/16
add area=VPN network=10.0.0.0/8
/system clock
set time-zone-name=America/Chicago
/system identity
set name="VPN Host"
/system routerboard settings
set cpu-frequency=1200MHz memory-frequency=1066DDR
/tool romon port
add
/tool user-manager database
set db-path=user-manager

My goal is to have access to my site LAN's and my Sites remote addresses.
My LAN side addresses are as follows:
Site1 = 10.0.4.1/24
Site2 = 10.0.5.1/24
Site3 = 10.0.7.1/24
Site4 = 10.0.6.1/24
VPN Server = 10.255.0.1/16 (I have tried this recently)

When I changed the local address from 172.17.0.1 to a unique ip address in my vpn server example would be 10.255.0.4 or 10.255.0.5 and I have the sites reconnect I am able to ping and get access to the site via the new 10.255.0.4 IP address, but the remote address of 172.17.0.4 is no longer active.

Suggestions or ideas would be helpful on my issue.
 
nelsontheis
just joined
Posts: 2
Joined: Tue Aug 06, 2013 3:43 pm
Location: Venezuela
Contact:

Re: OSPF Route Error > Discarding Packet locally originated

Thu Aug 25, 2016 5:48 am

I have the same problem, How can i resolve this error?
I reviewed the neighbor, ( Full state,) but the console show the error

Thank you
Nelson Lopez - MTCNA/MTCTCE/MTCRE/MTCWE/TRAINER/CCNA /MCSE / CCNA SECURITY/
 
earcaesar1
just joined
Topic Author
Posts: 14
Joined: Fri Jun 26, 2015 7:59 pm

Re: OSPF Route Error > Discarding Packet locally originated

Fri Aug 26, 2016 3:23 pm

I Still have not resolved the issue. I am not sure what to do. If you get any feedback let me know.

Thanks
 
letabawireless
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Thu Jul 26, 2012 5:11 pm

Re: OSPF Route Error > Discarding Packet locally originated

Sun Oct 30, 2016 4:08 pm

Hi there - my two cents.

I started getting this error on a backhual link - I fixed it by turning the station into station-bridge. It has got to do with level 2 to some extent. Hope this helps someone

Who is online

Users browsing this forum: rahrouh and 15 guests