Community discussions

MikroTik App
 
src386
newbie
Topic Author
Posts: 27
Joined: Tue Dec 08, 2015 1:18 pm

VRRP failover isn't working

Tue Dec 08, 2015 6:46 pm

Hi everyone,
I'm using two RouterOS 6.33.2 x86 VM in Virtualbox.
Router1 is 172.16.42.10 on ether3, Router2 is 172.16.42.20 on ether3. Both are able to ping.
I added vrrp1 interface on both routers, same vrid (44) on ether3. My virtual IP is up on Routeur1 (highest priority), but when I disable ether3 on Router1, the virtual IP goes down, instead of "moving" to Router2.

Here is the configuration (without disabling ether3 on Router1) :

Routeur 1:
[admin@mikrotik1] > /interface vrrp print detail 
Flags: X - disabled, I - invalid, R - running, M - master, B - backup 
 0 I   name="vrrp1" mtu=1500 mac-address=00:00:5E:00:01:2C arp=enabled 
       interface=ether3 vrid=44 priority=101 interval=1s preemption-mode=yes 
       authentication=none password="" on-backup="" on-master="" version=3 
       v3-protocol=ipv4
[admin@mikrotik1] > /ip address print       
Flags: X - disabled, I - invalid, D - dynamic 
 #   ADDRESS            NETWORK         INTERFACE                                
 [...]                                  
 3   172.16.42.10/24    172.16.42.0     ether3                                   
 4 I 172.16.42.254/32   172.16.42.254   vrrp1
Routeur 2:
[admin@mikrotik2] > /interface vrrp print detail 
Flags: X - disabled, I - invalid, R - running, M - master, B - backup 
 0 I   name="vrrp1" mtu=1500 mac-address=00:00:5E:00:01:2C arp=enabled 
       interface=ether3 vrid=44 priority=100 interval=1s preemption-mode=yes 
       authentication=none password="" on-backup="" on-master="" version=3 
       v3-protocol=ipv4
[admin@mikrotik2] > /ip address print 
Flags: X - disabled, I - invalid, D - dynamic 
 #   ADDRESS            NETWORK         INTERFACE                               
[...]                                
 3   172.16.42.20/24    172.16.42.0     ether3                                  
 4 I 172.16.42.254/32   172.16.42.254   vrrp1
Everything seems okay, where is the problem ?

Thanks.
 
src386
newbie
Topic Author
Posts: 27
Joined: Tue Dec 08, 2015 1:18 pm

Re: VRRP failover isn't working

Thu Dec 10, 2015 12:11 pm

This problem seems to be related to Mikrotik x86 + Virtualbox.
Mikrotik x86 + Physical PC works.

Who is online

Users browsing this forum: allancesar and 2 guests