Community discussions

MikroTik App
 
stafross
just joined
Topic Author
Posts: 13
Joined: Tue May 09, 2006 7:04 pm

vrrp Virtual IP address not respondig

Thu Feb 04, 2016 3:04 pm

I have 2 instances of ROS v6.34.1 on CHR running on ESXi.

I have setup vrrp on both and fail-over works as expected

If I try to ping the virtual IP from the backup router it does not respond, neither can I connect to the virtual IP.

Anyone got any idea what can be wrong?
 
stafross
just joined
Topic Author
Posts: 13
Joined: Tue May 09, 2006 7:04 pm

Re: vrrp Virtual IP address not respondig

Fri Feb 12, 2016 2:47 pm

Hi

I have now tested this on ESXi and VirtualBox with a x86 and CHR (x86_64) image and in both these cases the virtual IP cant be pinged or connected to.

Below is the config script that I use on a clean install.

R1
/interface vrrp
add interface=ether2 name=vrrp1 priority=225
add interface=ether2 name=vrrp2 vrid=2
/ip address
add address=192.168.100.3/24 interface=ether2 network=192.168.100.0
add address=192.168.100.1 interface=vrrp1 network=192.168.100.1
add address=192.168.100.2 interface=vrrp2 network=192.168.100.2
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1
/system identity
set name=LB1
R2
/interface vrrp
add interface=ether2 name=vrrp1
add interface=ether2 name=vrrp2 vrid=2 priority=225
/ip address
add address=192.168.100.4/24 interface=ether2 network=192.168.100.0
add address=192.168.100.1 interface=vrrp1 network=192.168.100.1
add address=192.168.100.2 interface=vrrp2 network=192.168.100.2
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1
/system identity
set name=LB2
I need to get this working else I need to look at using another system.
 
User avatar
ZeroByte
Forum Guru
Forum Guru
Posts: 4051
Joined: Wed May 11, 2011 6:08 pm

Re: vrrp Virtual IP address not respondig

Fri Feb 12, 2016 5:53 pm

Why two vrrp interfaces?
When given a spoon,
you should not cling to your fork.
The soup will get cold.
 
stafross
just joined
Topic Author
Posts: 13
Joined: Tue May 09, 2006 7:04 pm

Re: vrrp Virtual IP address not respondig

Mon Feb 15, 2016 9:05 am

This is for load balancing with fail-over.
 
telepro
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Sun Apr 03, 2011 7:50 pm

Re: vrrp Virtual IP address not respondig

Fri Sep 11, 2020 10:51 pm

Was a work-around found to get the virtual IP address to respond to a ping request?

Who is online

Users browsing this forum: No registered users and 11 guests