Community discussions

 
rprmac
just joined
Topic Author
Posts: 1
Joined: Tue Feb 23, 2016 11:46 am

Redirect port 80 for external web administration

Mon Feb 29, 2016 1:16 pm

Hi,

I got a Mikrotik RB2011UiAS-2HnD-IN a week ago.

Now I want to configure this router.

First, the router has 192.168.1.1 as a internal IP.

I want to change the web administration port 80 by port 9000 in order to access from internet.

and I want redirect the external port 80 to an internal port 80 of my web server with IP 192.168.1.50.

Anyone can help me?

Thanks.
Robert.
 
hasanakgoz
newbie
Posts: 32
Joined: Sun Dec 29, 2013 2:56 pm
Location: Turkey
Contact:

Re: Redirect port 80 for external web administration

Mon Feb 29, 2016 1:46 pm

You should do the following to change the Web management port. / ip service set www port = 80 address = 0.0.0.0/24 disabled = no. You can do the NAT process in this way. /ip firewall add action=dst-nat chain=dstnat comment="Web Server" disabled=no dst-port=80 protocol=tcp to-addresses=192.168.1.50 to-ports=80
 
scampbell
Trainer
Trainer
Posts: 457
Joined: Thu Jun 22, 2006 5:20 am
Location: Wellington, NZ
Contact:

Re: Redirect port 80 for external web administration

Tue Mar 08, 2016 2:15 am

For port 80 traffic from anywhere
/ip firewall add action=dst-nat chain=dstnat comment="Web Server" disabled=no dst-port=80 protocol=tcp in-interface=ether1-gateway to-addresses=192.168.1.50

For remote router access via external Port 9000
/ip firewall add action=redirect chain=dstnat comment="Web Server" disabled=no dst-port=9000 protocol=tcp in-interface=ether1-gateway to-ports=80

Do not forget to allow through firewall for both input and forward chains TCP 80.
MTCNA, MTCWE, MTCRE, MTCTCE, MTCSE, MTCINE, Trainer
___________________
Mikrotik Distributor - New Zealand
http://www.campbell.co.nz

Who is online

Users browsing this forum: No registered users and 10 guests