Community discussions

MikroTik App
 
toddnat
just joined
Topic Author
Posts: 9
Joined: Thu May 12, 2011 5:37 am

BFD for iBGP peers

Sun Jul 24, 2016 1:58 am

Trying to establish BFD on an iBGP peer (client to a route reflector). I see the BFD packets leaving the client router, destine to my route reflector iBGP IP with UDP port 4784, but the source IP is using the interface on the originating router instead of the loopback IP. BFD in turn is not establishing on the peering. Is there a way to force the use of the loopback for iBGP BFD, much like setting the next-hop to "self" for the routes advertised?

Thank you.
 
toddnat
just joined
Topic Author
Posts: 9
Joined: Thu May 12, 2011 5:37 am

Re: BFD for iBGP peers

Sun Jul 24, 2016 2:17 am

Also, the update source is set to use the loopback, and I see the status of the peering using the local loopback peered to the route reflector loopback. iBGP peering works fine with BFD, but when I check BFD, I see an "unspecified" neighbor in BFD using the timing parameters set under the "all" interfaces in BFD, just the local IP used is the egress IP of the router.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1870
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: BFD for iBGP peers

Sun Jul 24, 2016 8:15 am

Hi Todd, 

Sorry to be the bearer of bad news, but BFD is broken in RouterOS v6.  I would avoid using it until RouterOS v7 is released.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
toddnat
just joined
Topic Author
Posts: 9
Joined: Thu May 12, 2011 5:37 am

Re: BFD for iBGP peers

Sun Jul 24, 2016 5:07 pm

BFD altogether, or just BFD for BGP? I have BFD used on all my point-to-point OSPF links, and it appears to be operating without issue.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1870
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: BFD for iBGP peers

Mon Jul 25, 2016 10:28 am

BFD altogether..

We had it running without issue for quite a while. But as our network grew we had increasing issues with OSPF and BGP flapping. We disabled BFD and it OSPF/BBGP have been stable since.

We logged a ticket with Mikrotik support and were told BFD was broken and would be fixed in v7.

It is a real shame as we would use BFD everywhere if it worked.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
toddnat
just joined
Topic Author
Posts: 9
Joined: Thu May 12, 2011 5:37 am

Re: BFD for iBGP peers

Tue Jul 26, 2016 6:37 pm

Thank you for the information. Hopefully v7 will have this addressed for all BFD use cases.
 
R4kk00n
just joined
Posts: 1
Joined: Wed Apr 13, 2011 12:18 pm

Re: BFD for iBGP peers

Sat Aug 20, 2016 2:54 pm

@toddnat, you can also try to use an ugly hack with source NAT'ting your outgoing BFD packets. It goes something like this (I'm writing from memory, so there might be errors):
/ip firewall nat
add chain=src-nat action=srcnat src-address-type=local protocol=udp port=4784 to-address={{ your loopback IP here }}
Seems to work in my case. If you have conntrack enabled, you'll have to reestablish peers for it to take effect.
 
User avatar
barts
just joined
Posts: 5
Joined: Fri May 24, 2019 6:57 am

Re: BFD for iBGP peers

Tue Dec 10, 2019 5:39 am

Tks @R4kk00n... been solved by following your tip:
@toddnat, you can also try to use an ugly hack with source NAT'ting your outgoing BFD packets. It goes something like this (I'm writing from memory, so there might be errors):
/ip firewall nat
add chain=src-nat action=srcnat src-address-type=local protocol=udp port=4784 to-address={{ your loopback IP here }}
Seems to work in my case. If you have conntrack enabled, you'll have to reestablish peers for it to take effect.
 
ashaw
just joined
Posts: 1
Joined: Fri Apr 03, 2020 3:32 pm

Re: BFD for iBGP peers

Fri Apr 03, 2020 3:42 pm

I have run into this issue as well, only I'm using IPv6 so I can't even do the workaround.

When is v7 coming out?

Who is online

Users browsing this forum: No registered users and 10 guests