Community discussions

MikroTik App
 
diegotormes
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 64
Joined: Wed Feb 15, 2006 11:45 pm

MPLS TE Broken since v6.35 (Fixed 6.38.1!!!)

Thu Dec 29, 2016 3:46 pm

We report to support this:

This is one of the networks I have this problem (the network below is actually in production). This issue we sent it to you a few months ago, and you suggested to update to 6.36. In this case the entire network have 6.37.1, but it's still present.
mpls-te.png
The supout files I attached belong to the three routers in the red circle. The file 12.rif belong to 172.27.10.12, the 9.rif was created on 172.27.10.9 and 1.rif is the rif of 172.27.10.1 which is our VPLS concentrator (in the map shows the IP 181.224.119.254).
The network is not using TE, except for the three routers mentioned. Both 172.27.10.9 and 172.27.10.12, have a VPLS to 172.27.10.1 using TE. The issue can be reproduced by rebooting 172.27.10.9, this makes the concentrator to remove all its dynamic routes. In addition to OSPF, I have BGP, and it comes down too. After a few seconds, the BGP session is established again, and the OSPF recovers too (although sometimes OSPF "hangs" and it's needed to disable and enable the OSPF instance to get access to the network).
But, if I reboot 172.27.10.12, nothing happens on the concentrator, I mean, the routes are not affected, but either can't see the VPLS to come down.
On the other hand, if I disable the TE on 172.27.10.9, when I reboot this device, nothing happens on 172.27.10.1, i.e., the issue is not present.
This behaviour is happening also in another city which has no connectivity with this one. We associate the issue with the TE, because is the only thing we disable to stop the problem. I showed you a sample, it happens also on 172.27.10.7, 172.27.10.8 for example.
Please, tell me if you need more info.
Best regards.


Your response was:

> > Hello,
> >
> > Problem is caused by route crash which happens because of TE tunnels.
> > We will try to fix this in one of the future versions, problem was introduced in v6.35
> >
> >
> > Best regards,
> > MikroTik.com

We try with 6.38.52rc with no luck,we ask to support again with no response...

The solution proposed by support is get back to 6.34x but our CCR say that it is impossible:
log.png
We have no TE running in 2 of our networks because of that....I hope mikrotik fix this in short, is a big bug and TE is really important thing in big networks!

Regards,
Diego.
You do not have the required permissions to view the files attached to this post.
 
diegotormes
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 64
Joined: Wed Feb 15, 2006 11:45 pm

Re: MPLS TE Broken since v6.35 (Fixed 6.38.1!!!)

Tue Jan 17, 2017 5:43 pm

Fixed in 6.38.1!
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8421
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: MPLS TE Broken since v6.35 (Fixed 6.38.1!!!)

Tue Jan 17, 2017 6:37 pm

The solution proposed by support is get back to 6.34x but our CCR say that it is impossible
just a notice: if you want to downgrade, simple reboot after uploading files won't help. you need to press 'Downgrade' button in Packages (or execute "/system package downgrade" in Terminal)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
diegotormes
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 64
Joined: Wed Feb 15, 2006 11:45 pm

Re: MPLS TE Broken since v6.35 (Fixed 6.38.1!!!)

Wed Jan 18, 2017 1:37 am

The solution proposed by support is get back to 6.34x but our CCR say that it is impossible
just a notice: if you want to downgrade, simple reboot after uploading files won't help. you need to press 'Downgrade' button in Packages (or execute "/system package downgrade" in Terminal)
yes, I know make a downgrade!

Take a look at the first red line in log image:

omitting package system-6.34.6: min RouterOS version is 6.35.2
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8421
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: MPLS TE Broken since v6.35 (Fixed 6.38.1!!!)

Wed Jan 18, 2017 3:18 pm

Huh, sorry, resized picture made the text hard to read, so I just looked at the numbers... =)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.

Who is online

Users browsing this forum: No registered users and 17 guests