Community discussions

 
interprime
just joined
Topic Author
Posts: 15
Joined: Wed Jun 08, 2011 1:08 pm

OSPFv3 - Static Routes

Tue Apr 25, 2017 2:52 pm

Hi everyone!

When I have static routes registered in my router, and I enabled the option "Redistribute Static Routes" in the instance of OSPFv3, and try to summarize them in the "Area Ranges" of Mikrotik, the summarization does not work.

/routing ospf-v3 area
add area-id=0.0.0.2 name=area2
/routing ospf-v3 instance
set [ find default=yes ] redistribute-static=as-type-1 router-id=10.0.2.1
/routing ospf-v3 area range
add area=area2 range=2001:db8::20/124
add area=area2 range=2001:db8:210::/45

/ipv6 route
add dst-address=2001:db8:214::/64 gateway=ether3
add dst-address=2001:db8:215::/64 gateway=ether3
add dst-address=2001:db8:216::/64 gateway=ether3

Another router im my network:

# DST-ADDRESS GATEWAY DISTANCE
12 ADo 2001:db8:210::/45 fe80::d6ca:6dff:fe53:... 110
13 ADo 2001:db8:214::/64 fe80::d6ca:6dff:fe53:... 110
14 ADo 2001:db8:215::/64 fe80::d6ca:6dff:fe53:... 110
15 ADo 2001:db8:216::/64 fe80::d6ca:6dff:fe53:... 110
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1053
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: OSPFv3 - Static Routes

Fri Apr 28, 2017 3:42 pm

What RouterOS version is this? Have you tried any others?
Global - MikroTik Support & Consulting - English | Francais | Español | Portuguese +1 855-645-7684
https://iparchitechs.com/services/mikro ... l-support/ mikrotiksupport@iparchitechs.com
 
interprime
just joined
Topic Author
Posts: 15
Joined: Wed Jun 08, 2011 1:08 pm

Re: OSPFv3 - Static Routes

Sat Apr 29, 2017 10:29 pm

Hi,

Maris answer me by email:

Hello,

These are assigned IPV6 prefixes for the client. Such routes are always static even in ipv4. You do not see ipv6 connected route because there isn't one. In ipv4 connected route is because ipv4 has assigned /32 address on interface.

Best regards,
Maris

--
MikroTik.com
 
idlemind
Forum Guru
Forum Guru
Posts: 1102
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: OSPFv3 - Static Routes

Mon May 01, 2017 7:21 am

viewtopic.php?f=14&t=121236#p596074

Covering the duplicate posting.

Who is online

Users browsing this forum: No registered users and 10 guests