Community discussions

 
grimster01a
just joined
Topic Author
Posts: 6
Joined: Fri Apr 24, 2015 7:36 pm

Assign Public IP across Private Network

Tue Jun 13, 2017 8:15 pm

Hello,

I am trying to configure one of my clients with a public IP that is reachable from the web. He is at a remote site on the LAN side of my Mikrotik router. He has a private ip currently. I have tried so many different NAT rules to accomplish this. I have is router bound to a private IP in the leases section by MAC.

this one allows him to appear public to the web from the private IP but it only works outgoing. Incoming traffic to the public ip still does not reach him. I could use some direction here please.

/ip firewall nat
add action=dst-nat chain=dstnat comment="test" disabled=no dst-address=<public IP> to-addresses=<private IP>
add action=src-nat chain=srcnat comment="test" disabled=no src-address=<private IP> to-addresses=<public IP>
 
Sob
Forum Guru
Forum Guru
Posts: 4783
Joined: Mon Apr 20, 2009 9:11 pm

Re: Assign Public IP across Private Network

Wed Jun 14, 2017 1:09 am

Does this dstnat rule have any hits? If not, there's some other dstnat rule before it that catches those packets first. If yes, it might be blocked by some rule in /ip firewall filter, forward chain.
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply.
 
grimster01a
just joined
Topic Author
Posts: 6
Joined: Fri Apr 24, 2015 7:36 pm

Re: Assign Public IP across Private Network

Wed Jun 14, 2017 1:34 am

Yes. 562.2KiB.
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1053
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: Assign Public IP across Private Network

Wed Jun 14, 2017 4:21 pm

Hello,

I am trying to configure one of my clients with a public IP that is reachable from the web. He is at a remote site on the LAN side of my Mikrotik router. He has a private ip currently. I have tried so many different NAT rules to accomplish this. I have is router bound to a private IP in the leases section by MAC.

this one allows him to appear public to the web from the private IP but it only works outgoing. Incoming traffic to the public ip still does not reach him. I could use some direction here please.

/ip firewall nat
add action=dst-nat chain=dstnat comment="test" disabled=no dst-address=<public IP> to-addresses=<private IP>
add action=src-nat chain=srcnat comment="test" disabled=no src-address=<private IP> to-addresses=<public IP>
You can always route the IP to him rather than use NAT if he is at a remote location that is routable. It doesn't matter if the IP addressing is private.
Global - MikroTik Support & Consulting - English | Francais | Español | Portuguese +1 855-645-7684
https://iparchitechs.com/services/mikro ... l-support/ mikrotiksupport@iparchitechs.com
 
User avatar
AlainCasault
Trainer
Trainer
Posts: 624
Joined: Fri Apr 30, 2010 3:25 pm
Location: Laval, QC, Canada
Contact:

Re: Assign Public IP across Private Network

Wed Jun 14, 2017 5:18 pm

Also make sure that you have a filter allowing forward traffic to your client.

Sent from Tapatalk
___________________________
Alain Casault, Eng.
If I helped you, let me know!
 
idlemind
Forum Guru
Forum Guru
Posts: 1102
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: Assign Public IP across Private Network

Mon Jun 26, 2017 2:57 am

You can bridge the public IP to him with EoIP if it is part of a subnet somewhere else. Alternatively, build a tunnel with a technology like GRE to the customer network and route the IP down to them.

Who is online

Users browsing this forum: No registered users and 7 guests