Community discussions

MikroTik App
 
cutedrummerboy
Member Candidate
Member Candidate
Topic Author
Posts: 137
Joined: Thu Nov 14, 2013 6:32 pm

noob bgp problem

Mon Sep 25, 2017 9:55 am

can any one help me with my BGP problem. i want to redistribute blackhole route from cymru. i am getting route from cymru but cant advertise to my other peer.

here is my bgp config
/routing bgp instance
set default disabled=yes
add as=65534 name=AS65534 router-id=x.x.x.x

/routing bgp peer
add in-filter=cymru-in instance=AS65534 multihop=yes name=EBGP-AS65332 \
    out-filter=cymru-out remote-address=z.z.z.z remote-as=65332
add instance=AS65534 multihop=yes name=EBGP-AS65515 remote-address=\
    y.y.y.y remote-as=65515

/routing filter
add action=accept bgp-communities=65332:888 chain=cymru-in set-type=blackhole
add action=discard chain=cymru-in
add action=discard chain=cymru-out
Device: RB2011UIAS-RM, RB750GL, CISCO SG300-28, UNIFI UAP-LR
 
User avatar
nichky
Long time Member
Long time Member
Posts: 607
Joined: Tue Jun 23, 2015 2:35 pm

Re: noob bgp problem

Mon Sep 25, 2017 1:12 pm

need more info
Nikola Suminoski
MikroTik Consultan
MTCRE l MTCWE

!) Safe Mode is your friend;
 
cutedrummerboy
Member Candidate
Member Candidate
Topic Author
Posts: 137
Joined: Thu Nov 14, 2013 6:32 pm

Re: noob bgp problem

Mon Sep 25, 2017 1:35 pm

need more info
i think i have already provided all info. if not then glad to provide rest. can you tell me what is the problem in my configuration.
Device: RB2011UIAS-RM, RB750GL, CISCO SG300-28, UNIFI UAP-LR
 
cutedrummerboy
Member Candidate
Member Candidate
Topic Author
Posts: 137
Joined: Thu Nov 14, 2013 6:32 pm

Re: noob bgp problem [Solved]

Tue Sep 26, 2017 11:28 am

after reading several post in this forum i finally found my solution.

thanks to this post viewtopic.php?t=105061
thanks to Zerobyte, whose reply in that post really help me to learn and solve this.

my config here.
/routing bgp instance
set default disabled=yes
add as=65534 name=AS65534 router-id=x.x.x.x

/routing bgp peer
add in-filter=AS65332-IN instance=AS65534 multihop=yes name=\
    EBGP-AS65332 out-filter=AS65332-OUT remote-address=z.z.z.z \
    remote-as=65332
add in-filter=DISCARD-ALL instance=AS65534 multihop=yes name=\
    EBGP-AS65515 out-filter=AS65515-OUT remote-address=y.y.y.y \
    remote-as=65515
	
/routing filter
add action=accept bgp-communities=65332:888 chain=cymru-in \
    set-bgp-communities=65534:888 set-type=blackhole
add action=discard chain=cymru-in
add action=discard chain=cymru-out
add action=accept bgp-communities=65534:888 chain=peer1-out
add action=discard chain=peer1-out
add action=discard chain=discard-all
Device: RB2011UIAS-RM, RB750GL, CISCO SG300-28, UNIFI UAP-LR

Who is online

Users browsing this forum: No registered users and 14 guests