Community discussions

MikroTik App
 
jkjkrules
just joined
Topic Author
Posts: 20
Joined: Thu Dec 03, 2015 8:21 am

eoip sharing subnet

Thu Feb 15, 2018 6:46 pm

I'm trying to set up eoip to share public ips from our main router so I don't have to subnet 35 times and lose ip addresses every time. I am wanting to send static customers over vlan2000 the regular customers are just nat. I also am running a bgp/ospf hybrid.

 
//router 1 edge
/interface eoip
add arp=proxy-arp loop-protect=on mac-address=02:37:13:5C:B5:24 name=eoip-tunnel1 remote-address=192.168.255.18 tunnel-id=1

/interface bridge
add fast-forward=no mtu=1500 name=Management protocol-mode=none
add arp=proxy-arp name=bridge1

/interface bridge port
add bridge=bridge1 interface=eoip-tunnel1
add bridge=bridge1 disabled=yes interface=sfp-sfpplus1

/ip address
add address=173.x.x.x/26 interface=sfp-sfpplus1 network=173.x.x.x
//sfp-sfpplus1 out to internet
add address=192.168.255.1 interface=Management network=192.168.255.1
add address=172.16.100.1/30 interface=ether2 network=172.16.100.0
//ether2 to router 2


//router 2
/interface eoip
add arp=proxy-arp !keepalive mac-address=02:BF:B3:CC:E2:3C name=eoip-tunnel1 remote-address=192.168.255.1 tunnel-id=1

/interface bridge
add name=Management protocol-mode=none
add name=bridge1 protocol-mode=none

/interface bridge port
add bridge=bridge1 interface=eoip-tunnel1
add bridge=bridge1 interface=vlan2000

/interface vlan
add arp=proxy-arp interface=ether2 name=vlan2000 vlan-id=2000 
//ether2 is customer port

/ip address
add address=192.168.255.18 interface=Management network=192.168.255.18
add address=172.16.100.2/30 comment="To Edge" interface=ether1 network=172.16.100.0
//to route 1 edge
add address=10.0.0.1/23 comment=office interface=ether2 network=10.0.0.0
 
jkjkrules
just joined
Topic Author
Posts: 20
Joined: Thu Dec 03, 2015 8:21 am

Re: eoip sharing subnet

Fri Feb 16, 2018 8:56 pm

bump
 
JimmyNyholm
Member Candidate
Member Candidate
Posts: 248
Joined: Mon Apr 25, 2016 2:16 am
Location: Sweden

Re: eoip sharing subnet

Sat Feb 17, 2018 2:19 pm

EOIP is ethernet like interface encapsulated over ip packet.

Ethernetlike makes it able to be part of bridge witch you seem to grasp but then you attach ip's to interfaces instead of the bridge?

Please make a drawing on what you are trying to do, then we are much more able to help you. Subject sugest L2 but you do config ip on physical interface instead of bridge.
Are you trying to expand an L2 segment to streatch ip's without subnetting or do you want a L3 way to do the same (ie proxy arp and /32 routing.
 
jkjkrules
just joined
Topic Author
Posts: 20
Joined: Thu Dec 03, 2015 8:21 am

Re: eoip sharing subnet

Mon Feb 19, 2018 4:21 pm

Basically just extending the l2 to use the public ips I had it working on a test setup but the test was setup a little different I think the problem is
/interface bridge port
add bridge=bridge1 interface=eoip-tunnel1
add bridge=bridge1 disabled=yes interface=sfp-sfpplus1
When I turn it on the whole network stops working I guess it tries to send everything thru the tunnel or something.
 
pe1chl
Forum Guru
Forum Guru
Posts: 10234
Joined: Mon Jun 08, 2015 12:09 pm

Re: eoip sharing subnet

Mon Feb 19, 2018 4:26 pm

Of course!
In such a setup you should NOT include the interface that transports the EoIP frames in the bridge where your EoIP endpoint is.
 
jkjkrules
just joined
Topic Author
Posts: 20
Joined: Thu Dec 03, 2015 8:21 am

Re: eoip sharing subnet

Tue Feb 20, 2018 12:55 am

Of course!
In such a setup you should NOT include the interface that transports the EoIP frames in the bridge where your EoIP endpoint is.
So no bridge then? I tired a bridge on the incoming port nothing. I tried adding vlan 2000 to the eoip port still nothing. I tried putting the vlan 2000 on the incoming port and a bunch of other things i'm pretty lost here.
 
JimmyNyholm
Member Candidate
Member Candidate
Posts: 248
Joined: Mon Apr 25, 2016 2:16 am
Location: Sweden

Re: eoip sharing subnet

Tue Feb 20, 2018 1:42 pm

The EOIP tunnel is an interface to RouterOS. This is your inside of tunnel and can be part of bridge.
the interface that holds the LocalIP that eoip binds to in the encapsulated iptraffic it generates should of course not be part of the same (or any bridge) this creates loops and defeats the purpose of havving to tunnel in the first place.
IE:
                        Bridge0                                                     Bridge0
                     I         I------1.2.3.4 Localip EOPIP Remote 5.6.7.8--------I          I
192.168.0.0/24----(eth3)(R1)(eth1)---1.2.3.4----internetrouters-------5.6.7.8---(eth1)(R2)(eht3)-------192.168.0.0/24

Bridge0 on R1 ports eth3 and eoip1
Bridge0 on R2 ports eth3 and eoip1

Bridge0 on both routers can off course have ip on the 192.168.0.0/24 network and route to and from that network but they ar in no way part of the L3 stuf that transport the eoip(IP) traffic this is routing from 1.2.3.4 <-> 5.6.7.8

A litter mor clear?

Who is online

Users browsing this forum: jaclaz and 21 guests