Community discussions

MUM Europe 2020
 
kalns
just joined
Topic Author
Posts: 2
Joined: Fri Mar 09, 2018 10:34 am

Problem with L2TP / IPSEC AND WINDOWS CLIENT

Fri Mar 09, 2018 11:04 am

I have routeros 6.41.2 and I am trying to set up l2tp / ipsec for windows client. Config seems to be correct but I cannot connect to it.
I managed to get it working with Android, but no luck with IOS11
routerboard was reset to default configuration after upgrade
Routerboard is rb751u-2hnd if that change something..
windows 10 error
connection to the remote computer could not be established. You might need to change network settings for this connection

LOG from mikrotik
Capture2.PNG
And here is my config, firewall ports are open.

ipsec peer

[admin@MikroTik-AP0] > /ip ipsec peer print
Flags: X - disabled, D - dynamic, R - responder
0 R address=0.0.0.0/0 auth-method=pre-shared-key secret="1234567890" generate-policy=port-strict policy-template-grou
exchange-mode=main send-initial-contact=no nat-traversal=yes proposal-check=obey hash-algorithm=sha1 enc-algorith
dh-group=modp1024 lifetime=1d dpd-interval=2m dpd-maximum-failures=5

ipsec policy

[admin@MikroTik-AP0] > /ip ipsec policy print
Flags: T - template, X - disabled, D - dynamic, I - invalid, A - active, * - default
0 T * group=default src-address=::/0 dst-address=::/0 protocol=all proposal=default template=yes

ipsec proposal
[admin@MikroTik-AP0] > /ip ipsec proposal print
Flags: X - disabled, * - default
0 * name="default" auth-algorithms=sha1 enc-algorithms=3des lifetime=30m pfs-group=modp1024

ppp profile

[admin@MikroTik-AP0] > /ip ipsec proposal print
Flags: X - disabled, * - default
0 * name="default" auth-algorithms=sha1 enc-algorithms=3des lifetime=30m pfs-group=modp1024

Does anybody has any suggestions ?
Thanks in advance.

EDIT
After some more experiments, I found that it works allso from windows7 machine, so it must be something with windows / ios proposals or something like that

EDIT2
After some fiddling with IOS settings managed to get it to work, had to chose L2TP insted of IPSEC..
Still no luck with windows 10
You do not have the required permissions to view the files attached to this post.
 
kalns
just joined
Topic Author
Posts: 2
Joined: Fri Mar 09, 2018 10:34 am

Re: Problem with L2TP / IPSEC AND WINDOWS CLIENT

Mon Mar 12, 2018 2:40 pm

It turns out that windows 10 was broken. I had to delete ALL WAN MINI PORTs in device manager and let windows reinstall them and now my vpn works fine.
 
User avatar
Joni
Frequent Visitor
Frequent Visitor
Posts: 79
Joined: Fri Mar 20, 2015 2:46 pm
Contact:

Re: Problem with L2TP / IPSEC AND WINDOWS CLIENT

Mon Jul 22, 2019 8:18 pm

It turns out that windows 10 was broken. I had to delete ALL WAN MINI PORTs in device manager and let windows reinstall them and now my vpn works fine.

This <3 What made it confusing was that the same bug (windows updates) was affecting multiple (all) computers.

(Remove in Windows / Device Manager / Network adapters)

Who is online

Users browsing this forum: No registered users and 4 guests