Community discussions

 
MrAcid
just joined
Topic Author
Posts: 1
Joined: Tue Aug 28, 2018 9:39 pm

Configure BGP to have multiple peers with the same IP in VLAN+VRF combo

Tue Aug 28, 2018 10:07 pm

Hi fellow MT's
I am having issues peering with a CIsco router over BGP.
The setup is as follows
The Cisco router has multiple VLANs, each VLAN is in it's own VRF and has the IP address of 10.99.99.1/30
I can't get my MT to peer multiple times with the same BGP peer address (10.99.99.1) in different VRFs.
I have tried to simulate this in GNS3 using two MT routers and I can't seem to get around a build-in peer address check, that I think is wrong.
I should be able to peer with the same IP multiple times as long as it is in different VRFs, right?
What am I doing wrong?
R-1 has VLAN 10 and VLAN 20 with IP address 10.99.99.1/30 and
R-2 has VLAN 10 and VLAN 20 with IP address 10.99.99.2/30
Ignore the 1.1.1.0/24 addresses as these are used for the firefox web gui.
Setup.png
1.png
2.png
3.png
4.png

R-1 config:
[admin@MikroTik] > export
# aug/28/2018 19:02:28 by RouterOS 6.42.5
# software id =
#
#
#
/interface bridge
add fast-forward=no name=bridge1
/interface vlan
add interface=bridge1 name=vlan10 vlan-id=10
add interface=bridge1 name=vlan20 vlan-id=20
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/routing bgp instance
add as=1 client-to-client-reflection=no name=bgp1 router-id=1.1.1.1 \
routing-table=vrf10
add as=1 client-to-client-reflection=no name=bgp2 router-id=1.1.1.2 \
routing-table=vrf20
/interface bridge port
add bridge=bridge1 interface=ether1
/ip address
add address=1.1.1.1/24 interface=ether10 network=1.1.1.0
add address=10.99.99.1/30 interface=vlan10 network=10.99.99.0
add address=10.99.99.1/30 interface=vlan20 network=10.99.99.0
/ip dhcp-client
# DHCP client can not run on slave interface!
add disabled=no interface=ether1
/ip route vrf
add export-route-targets=10:10 import-route-targets=10:10 interfaces=vlan10 \
route-distinguisher=10:10 routing-mark=vrf10
add export-route-targets=20:20 import-route-targets=20:20 interfaces=vlan20 \
route-distinguisher=20:20 routing-mark=vrf20
/routing bgp peer
add instance=bgp1 name=peer1 remote-address=10.99.99.2 remote-as=2 ttl=\
default
[admin@MikroTik] >

R-2 config:
[admin@MikroTik] > export
# aug/28/2018 19:03:57 by RouterOS 6.42.5
# software id =
#
#
#
/interface bridge
add fast-forward=no name=bridge1
/interface vlan
add interface=bridge1 name=vlan10 vlan-id=10
add interface=bridge1 name=vlan20 vlan-id=20
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge port
add bridge=bridge1 interface=ether1
/ip address
add address=1.1.1.2/24 interface=ether10 network=1.1.1.0
add address=10.99.99.2/30 interface=vlan10 network=10.99.99.0
add address=10.99.99.2/30 interface=vlan20 network=10.99.99.0
/ip dhcp-client
# DHCP client can not run on slave interface!
add disabled=no interface=ether1
/ip route vrf
add export-route-targets=10:10 import-route-targets=10:10 interfaces=vlan10 \
route-distinguisher=10:10 routing-mark=vrf10
add export-route-targets=20:20 import-route-targets=20:20 interfaces=vlan20 \
route-distinguisher=20:20 routing-mark=vrf20
[admin@MikroTik] >
You do not have the required permissions to view the files attached to this post.
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1053
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: Configure BGP to have multiple peers with the same IP in VLAN+VRF combo  [SOLVED]

Wed Aug 29, 2018 6:19 pm

In MikroTik, you cannot duplicate the transit IP or subnet inside a VRF the same way you can in Cisco.

Duplicated prefixes inside of a BGP route are fine, but the subnets used for peering or an IGP must be discrete and separate.

This is a limitation of the 6.x kernel from what I've been told.
Global - MikroTik Support & Consulting - English | Francais | Español | Portuguese +1 855-645-7684
https://iparchitechs.com/services/mikro ... l-support/ mikrotiksupport@iparchitechs.com

Who is online

Users browsing this forum: No registered users and 8 guests