Community discussions

 
wearfear
just joined
Topic Author
Posts: 6
Joined: Wed Aug 29, 2018 3:09 pm

Different vrfs Same BGP Peer IP.

Wed Aug 29, 2018 3:12 pm

Hi all.

I'm curious if anyone has a solution for this.

I'm trying to peer to the same BGP Peer IP in different VRFS. But i'm getting the error "failure: already exists" even though the BGP Instance is in different VRFS.

Or maybe someone has a work around ?
Sample config
---------------------------------

/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/routing bgp instance
set default routing-table=ether1
add as=1 name=ether1 router-id=4.4.4.4 routing-table=ether1
add as=1 name=ether8 router-id=3.3.3.3 routing-table=ether8
/ip address
add address=10.0.0.2/24 interface=ether8 network=10.0.0.0
add address=10.0.0.2/24 interface=ether1 network=10.0.0.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1
/ip route vrf
add export-route-targets=65000:1 import-route-targets=65000:1 interfaces=ether8 route-distinguisher=65000:1 \
routing-mark=ether8
add export-route-targets=65000:2 import-route-targets=65000:2 interfaces=ether1 route-distinguisher=65000:2 \
routing-mark=ether1
/routing bgp peer
add instance=ether1 name=peer1 remote-address=10.0.0.1 remote-as=1
[admin@MikroTik] > routing bgp peer add instance=ether8 name=peer2 remote-address=10.0.0.1 remote-as=2
failure: already exists
[admin@MikroTik] >
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1053
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: Different vrfs Same BGP Peer IP.

Wed Aug 29, 2018 6:21 pm

Short answer is no, it's not possible...please see my reply in this thread.

viewtopic.php?f=14&t=138551
Global - MikroTik Support & Consulting - English | Francais | Español | Portuguese +1 855-645-7684
https://iparchitechs.com/services/mikro ... l-support/ mikrotiksupport@iparchitechs.com

Who is online

Users browsing this forum: No registered users and 10 guests