Community discussions

MikroTik App
 
Munderwoods
just joined
Topic Author
Posts: 2
Joined: Thu Sep 20, 2018 12:12 am

Port forwarding for Ark: Survival evolved

Thu Sep 20, 2018 12:35 am

I found two other threads on a similar topic, and here is the most useful one:

viewtopic.php?f=14&t=122590&p=603013&hilit=ark#p603013

I did a factory reset on my router and now can't for the life of me figure out what it is I'm doing wrong here. I'm just trying to run one server so I'm hoping you guys will be able to point out what I'm doing wrong fairly easily. I'm not super well versed on this kind of thing.
add action=netmap chain=dstnat comment="Ark" dst-port=27016 protocol=udp to-addresses=192.168.88.20 to-ports=27016
add action=netmap chain=dstnat comment="Ark" dst-port=27016 protocol=tcp to-addresses=192.168.88.20 to-ports=27016
add action=netmap chain=dstnat comment="Ark" dst-port=27015 protocol=udp to-addresses=192.168.88.20 to-ports=27015
add action=netmap chain=dstnat comment="Ark" dst-port=27015 protocol=tcp to-addresses=192.168.88.20 to-ports=27015
add action=netmap chain=dstnat comment="Ark" dst-port=7777 protocol=udp to-addresses=192.168.88.20 to-ports=7777
add action=netmap chain=dstnat comment="Ark" dst-port=7777 protocol=tcp to-addresses=192.168.88.20 to-ports=7777
Any ideas? Thanks very much, Matt
 
storp
Frequent Visitor
Frequent Visitor
Posts: 54
Joined: Tue Nov 24, 2015 2:53 pm

Re: Port forwarding for Ark: Survival evolved

Sun Sep 23, 2018 4:12 pm

It looks like you are using a internal ip range so you need to use dst-nat. Also be sure to have a rule for masquerading all out-going traffic. So by using your config it could be like:

chain=srcnat action=masquerade out-interface=replace with your external facing interface log=no log-prefix=""
chain=dstnat action=dst-nat to-addresses=192.168.88.20 protocol=udp in-interface=replace with your external facing interface dst-port=27016 to-ports=27016 comment="Ark"
...
 
Munderwoods
just joined
Topic Author
Posts: 2
Joined: Thu Sep 20, 2018 12:12 am

Re: Port forwarding for Ark: Survival evolved

Tue Sep 25, 2018 4:34 am

It looks like you are using a internal ip range so you need to use dst-nat. Also be sure to have a rule for masquerading all out-going traffic. So by using your config it could be like:

chain=srcnat action=masquerade out-interface=replace with your external facing interface log=no log-prefix=""
chain=dstnat action=dst-nat to-addresses=192.168.88.20 protocol=udp in-interface=replace with your external facing interface dst-port=27016 to-ports=27016 comment="Ark"
...
Thanks very much for your reply, storp.

I have a quick question since I'm pretty new to this stuff. What would my external facing interface be exactly? I'm operating over ethernet exclusively, but why is ether-2 listed as 'master'? Am I misunderstanding the interface option? It looks like I can't make a rule for the 'master'. Anyway, can I use 'all-ethernet' as a wildcard? Thanks again, Matt

Edit: Also, should I be using an internal ip range? And I thought I was using dst-nat. Am I wrong?

Who is online

Users browsing this forum: No registered users and 11 guests