Community discussions

 
User avatar
oscarc
just joined
Topic Author
Posts: 6
Joined: Mon Apr 27, 2015 7:55 pm
Location: Barcelona
Contact:

OSPFv3 and LSA 7

Tue Feb 12, 2019 6:33 pm

Hello,

I have a CCR1009 with V6.43.11 into NSSA AREA 30 with different routes of PPPOE sessions in IPV6. The routes appears in the routing table and they are reachable from the 1009 itself but they are not announced properly to the rest of routers in AREA 30 and the ABRs and then, they can not be reachable. I can see it in the LSA in OSPFv3 without gateway. I think that I'm missing something to configure into OSPFv3 configuration but I'm not able to find it out.
The IPV6 pool is assigned by radius, but I also configured a L2TP tunnel assigning the pool by a profile and it happens exactly the same, so I guess is not a problem of radius pool assignment.

Routing table in CCR1009:
28 ADS 2a00:XX:ca5a:100::/64 fe80::f%<pppoe-oscarn... 1

OSPFv3 LSA in CCR1009:
instance=3333 area=area30 type=type-7 id=0.0.0.1 originator=10.0.0.40 sequence-number=0x80000122 age=1399 checksum=0x1DDF options="" body=
forwarding-address=::
prefix=2a00:XX:ca5a:100::/64 options=00000000
referenced-LS-type=0
referenced-LS-ID=0
metric=20
route-tag=0x0
type1

OSPFv3 interfaces:
[admin@rt-ch-03] > routing ospf-v3 interface print
Flags: X - disabled, I - inactive, D - dynamic, P - passive
# INTERFACE AREA COST PRIORITY NETWORK-TYPE
0 vlan30 area30 10 1 default
1 <XXXXXXXXXXXXX> area30 10 1 default
2 <pppoe-oscarneba2@voztele> area30 10 1 default

OSPFv3 config:

/ipv6 pool
add name=pool-CA5A-100 prefix=2a00:XX:ca5a:100::/64 prefix-length=64

/routing ospf-v3 area
set [ find default=yes ] disabled=yes
/routing ospf-v3 instance
set [ find default=yes ] disabled=yes
add comment="OSPF area 30" metric-bgp=20 metric-other-ospf=20 name=3333 \
redistribute-connected=as-type-1 redistribute-other-ospf=as-type-1 \
redistribute-static=as-type-1 router-id=10.0.0.40
/routing ospf-v3 area
add area-id=0.0.0.30 default-cost=1 inject-summary-lsas=yes instance=3333 \
name=area30 translator-role=translate-never type=nssa

/ipv6 address
add address=2a00:XX:0:10a::b/128 advertise=no comment="Loopback 6 - IPV6" \
interface=Loopback6
add address=2a00:XX:0:103::9 advertise=no comment="AREA 30 - OSPF - VLAN 30" \
interface=vlan30

Neighbor router of AREA 30 can see the OSPF session established
/routing ospf-v3 ospf-router> print
# AREA ROUTER-ID STATE GATEWAY COST
3 area30 10.0.0.40 intra-area fe80::6e3b:6bff:fee4:8102 10

LSA on neighbor router
instance=3333 area=area30 type=type-7 id=0.0.0.4 originator=10.0.0.40
sequence-number=0x80000105 age=1035 checksum=0x4ACB options="" body=
forwarding-address=::
prefix=2a00:XX:ca5a:100::/64 options=00000000
referenced-LS-type=0
referenced-LS-ID=0
metric=20
route-tag=0x0
type1

As I said, I don't know if I missed something to configure in order to announce properly the static routes. I supposed I should have anything special to announce static routes, as far as I know, there is no filters in OSPFv3.

Thanks
Let the wind blow back your hair

Who is online

Users browsing this forum: No registered users and 12 guests