Community discussions

 
doush
Long time Member
Long time Member
Topic Author
Posts: 621
Joined: Thu Jun 04, 2009 3:11 pm

OSPF Redistribute Problem

Sat Feb 16, 2019 1:09 pm

R2 <----> R1 <----> R3
[adm@R1] /routing ospf instance> pr
Flags: X - disabled, * - default 
 0  * name="default" router-id=172.16.25.78 distribute-default=never redistribute-connected=no 
      redistribute-static=no redistribute-rip=no redistribute-bgp=no redistribute-other-ospf=no 
      metric-default=1 metric-connected=20 metric-static=20 metric-rip=20 metric-bgp=20 
      metric-other-ospf=auto in-filter=ospf-in out-filter=ospf-out

I am struggling with the above now. On R1, although redistribute connected, static routes etc.. are all set to no, I still see the full routing table on R2 and R3
Why does R1 keep sending all the routes to other Routers (R2 and R3) when everything is set to NO ?

I dont need the full routing table on R2 and R3 since they only have a single uplink which is R1.
 
User avatar
Murmaider
Member Candidate
Member Candidate
Posts: 121
Joined: Fri Oct 30, 2015 10:10 am

Re: OSPF Redistribute Problem

Sun Feb 17, 2019 10:02 am

not sure why it would do that, but you could use the ospf-out route filter and create a default discard rule so it doesn't advertise any routes.
 
doush
Long time Member
Long time Member
Topic Author
Posts: 621
Joined: Thu Jun 04, 2009 3:11 pm

Re: OSPF Redistribute Problem

Mon Feb 18, 2019 11:26 am

Actually I dont want to play with the filters now since the OSPF instance parameters should take care of this.
Could anyone please try the simple scenario above and check whether if no matter how the instance is configured, it always distrubutes the routes or not ?

Version is 6.43.4 on CCR1072
 
NanaK
just joined
Posts: 4
Joined: Mon Feb 18, 2019 8:53 am

Re: OSPF Redistribute Problem

Mon Feb 18, 2019 11:40 am

R2 <----> R1 <----> R3
[adm@R1] /routing ospf instance> pr
Flags: X - disabled, * - default 
 0  * name="default" router-id=172.16.25.78 distribute-default=never redistribute-connected=no 
      redistribute-static=no redistribute-rip=no redistribute-bgp=no redistribute-other-ospf=no 
      metric-default=1 metric-connected=20 metric-static=20 metric-rip=20 metric-bgp=20 
      metric-other-ospf=auto in-filter=ospf-in out-filter=ospf-out

I am struggling with the above now. On R1, although redistribute connected, static routes etc.. are all set to no, I still see the full routing table on R2 and R3
Why does R1 keep sending all the routes to other Routers (R2 and R3) when everything is set to NO ?

I dont need the full routing table on R2 and R3 since they only have a single uplink which is R1.

It would have been great if you included /routing ospf export of R2 and R3 -
 
doush
Long time Member
Long time Member
Topic Author
Posts: 621
Joined: Thu Jun 04, 2009 3:11 pm

Re: OSPF Redistribute Problem

Mon Feb 18, 2019 4:05 pm

[admins@R2] > rout ospf exp
/routing ospf instance
set [ find default=yes ] redistribute-connected=as-type-2 \
    redistribute-other-ospf=as-type-2 redistribute-static=as-type-2 router-id=\
    192.168.254.100
/routing ospf interface
add interface=ether1 network-type=broadcast
/routing ospf network
add area=backbone network=172.16.100.0/24
Same with R3. Simple setup 1 backbone area 3 routers.
 
doush
Long time Member
Long time Member
Topic Author
Posts: 621
Joined: Thu Jun 04, 2009 3:11 pm

Re: OSPF Redistribute Problem

Wed Feb 20, 2019 9:15 am

Anyone ?
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: OSPF Redistribute Problem

Wed Feb 20, 2019 11:56 am

What is considered by "full routing table"? If you are talking about inter/intra area routes learned from other OSPF neighbors then those will always be installed in routing table for all routers in the same area.
 
doush
Long time Member
Long time Member
Topic Author
Posts: 621
Joined: Thu Jun 04, 2009 3:11 pm

Re: OSPF Redistribute Problem

Wed Feb 20, 2019 3:21 pm

there is only one backbone area. And R1 is the gateway of all other routers (r2 and r3).
I dont want R1 to distrubute any routes to R2 and R3 because in any case their gateway is R1.
How to stop R1 announcing all of its routes to other routers ?
I thought ospf-instance paramaters were supposed to do this.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: OSPF Redistribute Problem

Wed Feb 20, 2019 4:13 pm

What is the config on R1?
 
doush
Long time Member
Long time Member
Topic Author
Posts: 621
Joined: Thu Jun 04, 2009 3:11 pm

Re: OSPF Redistribute Problem

Fri Feb 22, 2019 1:36 pm

[admin@R1] /routing ospf instance> pr
Flags: X - disabled, * - default 
 0  * name="default" router-id=172.16.2.2 distribute-default=never redistribute-connected=no redistribute-static=no redistribute-rip=no 
      redistribute-bgp=no redistribute-other-ospf=no metric-default=1 metric-connected=20 metric-static=20 metric-rip=20 metric-bgp=20 
      metric-other-ospf=auto in-filter=ospf-in out-filter=ospf-out

[admin@R1] /routing ospf network> pr
Flags: X - disabled, I - invalid 
 #   NETWORK            AREA                                                                                                                   
 0   172.16.100.0/24       backbone   
 ... etc
[admin@R2] /routing ospf instance> pr
Flags: X - disabled, * - default 
 0  * name="default" router-id=192.168.254.100 distribute-default=never 
      redistribute-connected=as-type-2 redistribute-static=as-type-2 
      redistribute-rip=no redistribute-bgp=no redistribute-other-ospf=as-type-2 
      metric-default=1 metric-connected=20 metric-static=20 metric-rip=20 
      metric-bgp=auto metric-other-ospf=auto in-filter=ospf-in 
      out-filter=ospf-out 
[admins@R2] /routing ospf network> pr
Flags: X - disabled, I - invalid
# NETWORK AREA
0 172.16.100.0/24 backbone
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: OSPF Redistribute Problem

Fri Feb 22, 2019 1:51 pm

[admin@R1] /routing ospf network> pr
Flags: X - disabled, I - invalid
# NETWORK AREA
0 172.16.100.0/24 backbone
... etc
Every added OSPF network that match IP address, will be advertised to neighbours. So if you do not want area routes received on other neighbors, then put those neighbors in stub area.
 
doush
Long time Member
Long time Member
Topic Author
Posts: 621
Joined: Thu Jun 04, 2009 3:11 pm

Re: OSPF Redistribute Problem

Fri Feb 22, 2019 3:09 pm

Thanks for your answer mrz.
Actually what I want to accomplish is not to distrubute the routes from R1 in the first place to minimize the multicast traffic on the wireless links.
I think what you are suggesting is filtering them on the R2 and R3 (on the receive side) so again R1 will distrubute them over the wireless link but will be neglected on R2 and R3.
Cant we do just the opposite and make R1 to stop announcing any routes at all ?
 
doush
Long time Member
Long time Member
Topic Author
Posts: 621
Joined: Thu Jun 04, 2009 3:11 pm

Re: OSPF Redistribute Problem

Sun Feb 24, 2019 8:59 am

Taking a networks into stub area stops advertisements on both ends.
Is there a way to stop R1 announcing its area routes to R2 and R3 ?
 
christopherh
newbie
Posts: 29
Joined: Sun Feb 24, 2019 7:43 am
Location: Sydney, Australia

Re: OSPF Redistribute Problem

Sun Feb 24, 2019 9:13 am

Is there any particular requirement to use OSPF, instead of BGP? I find BGP is easier to configure, and the route filters work without troubles.
 
vasilaos
Frequent Visitor
Frequent Visitor
Posts: 91
Joined: Tue Aug 04, 2009 9:50 am

Re: OSPF Redistribute Problem

Sun Feb 24, 2019 10:39 am

The router R1 will distribute all routes learned from routers of the same area by default. That is what OSPF is about. The redistribute-other-ospf=no is if you want to distribute or not routes of other areas. So you have to specify ospf-out filter to discart those routes in R1 in order to not distribute the routes or you have to use stub area.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: OSPF Redistribute Problem

Mon Feb 25, 2019 10:31 am

The redistribute-other-ospf=no is if you want to distribute or not routes of other areas.
Not correct, it is used to redistribute routes from one OSPF instance to another.
 
doush
Long time Member
Long time Member
Topic Author
Posts: 621
Joined: Thu Jun 04, 2009 3:11 pm

Re: OSPF Redistribute Problem

Tue Feb 26, 2019 2:20 pm

I think there shoud be a way to do it.
OSPF-OUT filter on R1 also doesnt stop R1 announcing its routes to R2 and R3 ?
Is this also an expected behavior ?
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5934
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: OSPF Redistribute Problem

Tue Feb 26, 2019 2:47 pm

You can discard only external OSPF routes with routing filters. Everything you add to ospf networks will not be "external".
 
doush
Long time Member
Long time Member
Topic Author
Posts: 621
Joined: Thu Jun 04, 2009 3:11 pm

Re: OSPF Redistribute Problem

Thu Feb 28, 2019 11:09 pm

My main concern was reducing multicast traffic on the links between R1 and R2,R3.
As far as I understand, it cant be done. Inner-area routes can not be filtered etc..

So what is the solution ?
Should I switch to BGP or is there any other way I can try to reduce the multicast traffic in the network using OSPF ?

Who is online

Users browsing this forum: Google [Bot] and 2 guests