Community discussions

MikroTik App
 
shanecaznet
just joined
Topic Author
Posts: 15
Joined: Thu Jul 13, 2017 10:52 am

BFD shows as down, not transmitting

Tue Mar 26, 2019 3:14 pm

Hi All

Just implementing BFD on two seperate connections between two routers. One works fine, however, the other doesn't seem to be even attempting to send Control packets. On both routers the second interface is shows a Transmit Packet count of 0:
[admin@router1] > routing bfd neighbor pr detail 
Flags: U - up 
 0 U interface=vl3104 - EDPK IX AU VLL address=103.xxx.yyy.29 protocols=bgp multihop=no state=up state-changes=2 uptime=5h1
     required-min-rx=0.2s remote-min-rx=0.2s multiplier=5 hold-time=1s packets-rx=115531 packets-tx=115582 

 1   interface=sfp2 - EDPK address=103.xxx.yyy.21 protocols=bgp multihop=no state=down state-changes=0 desired-tx-interval=
     multiplier=5 hold-time=0s packets-rx=0 packets-tx=0 
Both BGP sessions are established and you can ping the IP on both interfaces from both sides.

I've checked firewalls, all traffic is allowed from both sides, however since it doesn't even seem to be trying to TX I don't think its firewall related.

Any ideas?
 
TheCiscoGuy
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Fri Jun 22, 2018 8:32 am

Re: BFD shows as down, not transmitting

Wed Apr 10, 2019 12:28 am

Can you check to ensure there is an ARP and route entry for 103.xxx.yyy.21
Network Solutions Engineer and Trainer
Cisco | Juniper | Mikrotik | Ubiquiti
 
shanecaznet
just joined
Topic Author
Posts: 15
Joined: Thu Jul 13, 2017 10:52 am

Re: BFD shows as down, not transmitting

Tue Apr 16, 2019 3:17 pm

ARP entries were normal and traffic was passing over the link between the IPs.

I managed to fix this by ensuring the ALL interface was enabled and that the individual interfaces were explicitly specified for BFD.

Who is online

Users browsing this forum: No registered users and 10 guests