Community discussions

MikroTik App
 
bcooker
just joined
Topic Author
Posts: 1
Joined: Fri Mar 29, 2019 1:20 pm

VLR and MP-BGP

Fri Mar 29, 2019 1:24 pm

Hi All,

I'm new to the Mikrotik world but enjoying the products. Can someone please help me out? I'm trying to see if the following configuration from a Cisco config would translate into MikroTik language. I have a Mikrotik CRS125-24G-1S-2HnD-IN. We are trying to connect an Ethernet point to point ExpressRoute to Azure. Thank you in advance.

#######
### Primary Router
#######

# Define VRF
ip vrf 10
rd 65022:10

# Define Private ER Interface
interface TenGigabitEthernet0/0/0.100
description Customer 10 Private Peering to Azure
encapsulation dot1Q 21 second-dot1q 100
ip vrf forwarding 10
ip address 192.168.10.17 255.255.255.252
no shutdown

# Define Interface to Switch
interface TenGigabitEthernet1/1/1.10
description Customer 10 to Switch
encapsulation dot1Q 10
ip vrf forwarding 10
ip address 10.9.10.1 255.255.255.0
no shutdown

# Define BGP Address Family
router bgp 65022
address-family ipv4 vrf 14
neighbor 192.168.14.18 remote-as 12076
neighbor 192.168.14.18 activate
neighbor 192.168.14.18 next-hop-self
neighbor 192.168.14.18 soft-reconfiguration inbound
exit-address-family

#######
### Secondary Router
#######

# Define VRF
ip vrf 10
rd 65022:10

# Define Private ER Interface
interface TenGigabitEthernet0/0/0.100
description Customer 10 Private Peering to Azure
encapsulation dot1Q 21 second-dot1q 100
ip vrf forwarding 10
ip address 192.168.10.21 255.255.255.252
no shutdown

# Define Interface to Switch
interface TenGigabitEthernet1/1/1.10
description Customer 10 to Switch
encapsulation dot1Q 10
ip vrf forwarding 10
ip address 10.9.10.2 255.255.255.0
no shutdown

# Define BGP Address Family
router bgp 65022
address-family ipv4 vrf 14
neighbor 192.168.14.22 remote-as 12076
neighbor 192.168.14.22 activate
neighbor 192.168.14.22 next-hop-self
neighbor 192.168.14.22 soft-reconfiguration inbound
exit-address-family


B
 
TheCiscoGuy
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Fri Jun 22, 2018 8:32 am

Re: VLR and MP-BGP

Wed Apr 10, 2019 12:24 am

Well, the mikrotik CRS can do all of those features, but please note that the CRS line is more a switch than a router, when configured for routing a large performance drop will be taken. I would recommend looking at the manual though and if you need the performance (10GE and beyond) look at the CCR platforms for routing.

The RouterOS Manual is here: https://wiki.mikrotik.com/wiki/Manual:TOC
Network Solutions Engineer and Trainer
Cisco | Juniper | Mikrotik | Ubiquiti

Who is online

Users browsing this forum: No registered users and 16 guests