Community discussions

 
Dude2048
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 93
Joined: Thu Sep 01, 2016 4:04 pm

Multicast

Thu Jun 20, 2019 3:25 pm

I tried to create a test multicast network. Example is below. When I start an RTP stream on the VLC server I can pick it up localy. So that is running The stream uses an address of 224.0.1.1. However the client won't connect to the stream on the server. When I setup a simple bridge with two ports in it, the stream will run, obviously. There is something with the layer 3 config, I think...

I read the Wiki on the site, viewed MUM demo's and so on. Is there anyone who can help me to get a bit further.



Tekening1.jpg
RB1100
/ip address
add address=192.168.1.254/24 interface=ether1 network=192.168.1.0
add address=192.168.6.254/24 interface=ether6 network=192.168.6.0

/ip route
add distance=1 dst-address=192.168.2.0/24 gateway=192.168.6.1

/routing pim interface
add alternative-subnets=192.168.2.0/24,192.168.6.0/24

/routing pim rp
add address=192.168.6.254

CCR
/ip address
add address=192.168.2.254/24 interface=ether2 network=192.168.2.0
add address=192.168.6.1/24 interface=ether6 network=192.168.6.0

/ip route
add distance=1 dst-address=192.168.1.0/24 gateway=192.168.6.254

/routing pim interface
add alternative-subnets=192.168.2.0/24,192.168.6.0/24

/routing pim rp
add address=192.168.6.254
You do not have the required permissions to view the files attached to this post.
 
Dude2048
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 93
Joined: Thu Sep 01, 2016 4:04 pm

Re: Multicast

Sun Jun 23, 2019 11:06 am

Bump
 
Prewest
just joined
Posts: 16
Joined: Tue Oct 20, 2009 3:35 pm

Re: Multicast

Sun Jun 23, 2019 11:19 am

I`m missing the forward rule in the firewall, I don`t know the command out of my head but it should be

Firewall -> add rule -> forward -> DST-Adress = 224.0.0.0/4 -> -> in interface / out interface -> action accept or passthrough..
 
Dude2048
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 93
Joined: Thu Sep 01, 2016 4:04 pm

Re: Multicast

Sun Jun 23, 2019 1:10 pm

There are no firewall rules what so ever. The only config on the routers is that what you see.

But thank you vert much for thinking about it
 
kakaxa
just joined
Posts: 15
Joined: Thu Feb 01, 2018 5:46 am

Re: Multicast

Sun Jun 23, 2019 7:01 pm

try
Last edited by kakaxa on Thu Jun 27, 2019 5:23 am, edited 3 times in total.
 
Chiverel
newbie
Posts: 40
Joined: Fri Jan 12, 2018 7:28 pm

Re: Multicast  [SOLVED]

Mon Jun 24, 2019 10:39 am

There's a chance that you have packets with TTL=1. If you have them, you can increase TTL using mangle.

I recall it was explicitly mentioned for VLC when tried to configure my setup.

Check this example as well, it has nearly yours case.
 
Dude2048
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 93
Joined: Thu Sep 01, 2016 4:04 pm

Re: Multicast

Mon Jun 24, 2019 11:57 am

Thanks, I will test the solitions in a day or two and let know if it is resolved.
 
Dude2048
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 93
Joined: Thu Sep 01, 2016 4:04 pm

Re: Multicast

Mon Jun 24, 2019 9:01 pm

Thanks TTL it is!!!!
 
pe1chl
Forum Guru
Forum Guru
Posts: 5923
Joined: Mon Jun 08, 2015 12:09 pm

Re: Multicast

Mon Jun 24, 2019 10:43 pm

Is it not possible to configure the TTL in VLC?
 
Dude2048
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 93
Joined: Thu Sep 01, 2016 4:04 pm

Re: Multicast

Tue Jun 25, 2019 9:30 am

From what I have read, no. There is something in VLC that is preventing that.

Who is online

Users browsing this forum: No registered users and 10 guests