Community discussions

 
agilbett
just joined
Topic Author
Posts: 1
Joined: Mon Feb 23, 2015 12:58 pm

BGP VPLS mesh demo in GNS3

Sun Jun 23, 2019 11:33 am

Hi Guys,

I have setup a MPLS test bed in GNS3 using CHR's. I have been trying to get a bgp signaled VPLS to work... but I am not getting a full mesh of connectivity. I am trying to create a mesh between PE1, PE2 and PE3. I can see all of the VPLS's up but the mesh between PE1 and PE2 does not seem to work. I am unable to ping between CE1 and CE2 which is supposed to be a layer 2 full mesh network.

We are using OSPF as the underlying routing layer with LDP and BGP VPLS.

This is intended to be a bit of a demo that others can copy as well.

Diagram
Image

Configs as below:
P1
/interface bridge
add name=lobridge
/interface ethernet
set [ find default-name=ether1 ] disable-running-check=no
set [ find default-name=ether2 ] disable-running-check=no
set [ find default-name=ether3 ] disable-running-check=no
set [ find default-name=ether4 ] disable-running-check=no
set [ find default-name=ether5 ] disable-running-check=no
set [ find default-name=ether6 ] disable-running-check=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/routing ospf instance
set [ find default=yes ] redistribute-connected=as-type-1 router-id=10.255.255.1
/ip address
add address=10.255.255.1 interface=lobridge network=10.255.255.1
add address=10.0.255.1/30 interface=ether1 network=10.0.255.0
add address=10.0.255.5/30 interface=ether2 network=10.0.255.4
add address=10.1.0.254/24 interface=ether3 network=10.1.0.0
/mpls ldp
set enabled=yes lsr-id=10.255.255.1 transport-address=10.255.255.1
/mpls ldp interface
add interface=ether1
add interface=ether2
add interface=ether3
/routing bgp peer
add address-families=l2vpn name=peer1 remote-address=10.255.255.2 remote-as=65530 route-reflect=yes update-source=lobridge
add address-families=l2vpn name=peer2 remote-address=10.255.255.3 remote-as=65530 route-reflect=yes update-source=lobridge
add address-families=l2vpn name=peer3 remote-address=10.255.255.4 remote-as=65530 route-reflect=yes update-source=lobridge
add address-families=l2vpn name=peer4 remote-address=10.255.255.5 remote-as=65530 route-reflect=yes update-source=lobridge
add address-families=l2vpn name=peer5 remote-address=10.255.255.6 remote-as=65530 route-reflect=yes update-source=lobridge
/routing ospf network
add area=backbone network=10.0.255.0/30
add area=backbone network=10.0.255.4/30
add area=backbone network=10.1.0.0/24
/system identity
set name=P1
P2
/interface bridge
add name=lobridge
/interface ethernet
set [ find default-name=ether1 ] disable-running-check=no
set [ find default-name=ether2 ] disable-running-check=no
set [ find default-name=ether3 ] disable-running-check=no
set [ find default-name=ether4 ] disable-running-check=no
set [ find default-name=ether5 ] disable-running-check=no
set [ find default-name=ether6 ] disable-running-check=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/routing ospf instance
set [ find default=yes ] redistribute-connected=as-type-1 router-id=10.255.255.2
/ip address
add address=10.255.255.2 interface=lobridge network=10.255.255.2
add address=10.0.255.6/30 interface=ether1 network=10.0.255.4
add address=10.0.255.9/30 interface=ether2 network=10.0.255.8
add address=10.2.0.254/24 interface=ether3 network=10.2.0.0
/mpls ldp
set enabled=yes lsr-id=10.255.255.2 transport-address=10.255.255.2
/mpls ldp interface
add interface=ether1
add interface=ether2
add interface=ether3
/routing bgp peer
add address-families=l2vpn name=peer1 remote-address=10.255.255.1 remote-as=65530 route-reflect=yes update-source=lobridge
/routing ospf network
add area=backbone network=10.0.255.8/30
add area=backbone network=10.0.255.4/30
add area=backbone network=10.2.0.0/24
/system identity
set name=P2
P3
/interface bridge
add name=lobridge
/interface ethernet
set [ find default-name=ether1 ] disable-running-check=no
set [ find default-name=ether2 ] disable-running-check=no
set [ find default-name=ether3 ] disable-running-check=no
set [ find default-name=ether4 ] disable-running-check=no
set [ find default-name=ether5 ] disable-running-check=no
set [ find default-name=ether6 ] disable-running-check=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/routing ospf instance
set [ find default=yes ] redistribute-connected=as-type-1 router-id=10.255.255.3
/ip address
add address=10.255.255.3 interface=lobridge network=10.255.255.3
add address=10.0.255.10/30 interface=ether1 network=10.0.255.8
add address=10.0.255.2/30 interface=ether2 network=10.0.255.0
add address=10.3.0.254/24 interface=ether3 network=10.3.0.0
/mpls ldp
set enabled=yes lsr-id=10.255.255.3 transport-address=10.255.255.3
/mpls ldp interface
add interface=ether1
add interface=ether2
add interface=ether3
/routing bgp peer
add address-families=l2vpn name=peer1 remote-address=10.255.255.1 remote-as=65530 route-reflect=yes update-source=lobridge
/routing ospf network
add area=backbone network=10.0.255.0/30
add area=backbone network=10.0.255.8/30
add area=backbone network=10.3.0.0/24
/system identity
set name=P3
PE1
/interface bridge
add name=B
add name=lobridge
/interface ethernet
set [ find default-name=ether1 ] disable-running-check=no
set [ find default-name=ether2 ] disable-running-check=no
set [ find default-name=ether3 ] disable-running-check=no
set [ find default-name=ether4 ] disable-running-check=no
set [ find default-name=ether5 ] disable-running-check=no
set [ find default-name=ether6 ] disable-running-check=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/routing ospf instance
set [ find default=yes ] redistribute-connected=as-type-1 router-id=10.255.255.4
/interface bridge port
add bridge=B interface=ether6
/interface vpls bgp-vpls
add bridge=B bridge-horizon=1 export-route-targets=1:1 import-route-targets=1:1 name=bgp-vpls1 route-distinguisher=1:1 site-id=3
/ip address
add address=10.255.255.4 interface=lobridge network=10.255.255.4
add address=10.1.0.1/24 interface=ether1 network=10.1.0.0
/mpls ldp
set enabled=yes lsr-id=10.255.255.4 transport-address=10.255.255.4
/mpls ldp interface
add interface=ether1
/routing bgp peer
add address-families=l2vpn name=peer1 remote-address=10.255.255.1 remote-as=65530 route-reflect=yes update-source=lobridge
/routing ospf network
add area=backbone network=10.1.0.0/24
/system identity
set name=PE1
PE2
/interface bridge
add name=B
add name=lobridge
/interface ethernet
set [ find default-name=ether1 ] disable-running-check=no
set [ find default-name=ether2 ] disable-running-check=no
set [ find default-name=ether3 ] disable-running-check=no
set [ find default-name=ether4 ] disable-running-check=no
set [ find default-name=ether5 ] disable-running-check=no
set [ find default-name=ether6 ] disable-running-check=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/routing ospf instance
set [ find default=yes ] redistribute-connected=as-type-1 router-id=10.255.255.5
/interface bridge port
add bridge=B interface=ether6
/interface vpls bgp-vpls
add bridge=B bridge-horizon=1 export-route-targets=1:1 import-route-targets=1:1 name=bgp-vpls1 route-distinguisher=1:1 site-id=5
/ip address
add address=10.255.255.5 interface=lobridge network=10.255.255.5
add address=10.2.0.1/24 interface=ether1 network=10.2.0.0
/mpls ldp
set enabled=yes lsr-id=10.255.255.5 transport-address=10.255.255.5
/mpls ldp interface
add interface=ether1
/routing bgp peer
add address-families=l2vpn name=peer1 remote-address=10.255.255.1 remote-as=65530 route-reflect=yes update-source=lobridge
/routing ospf network
add area=backbone network=10.2.0.0/24
/system identity
set name=PE2
PE3
/interface bridge
add name=B
add name=lobridge
/interface ethernet
set [ find default-name=ether1 ] disable-running-check=no
set [ find default-name=ether2 ] disable-running-check=no
set [ find default-name=ether3 ] disable-running-check=no
set [ find default-name=ether4 ] disable-running-check=no
set [ find default-name=ether5 ] disable-running-check=no
set [ find default-name=ether6 ] disable-running-check=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/routing ospf instance
set [ find default=yes ] redistribute-connected=as-type-1 router-id=10.255.255.6
/interface bridge port
add bridge=B interface=ether6
/interface vpls bgp-vpls
add bridge=B bridge-horizon=1 export-route-targets=1:1 import-route-targets=1:1 name=bgp-vpls1 route-distinguisher=1:1 site-id=6
/ip address
add address=10.255.255.6 interface=lobridge network=10.255.255.6
add address=10.3.0.1/24 interface=ether1 network=10.3.0.0
/mpls ldp
set enabled=yes lsr-id=10.255.255.6 transport-address=10.255.255.6
/mpls ldp interface
add interface=ether1
/routing bgp peer
add address-families=l2vpn name=peer1 remote-address=10.255.255.1 remote-as=65530 route-reflect=yes update-source=lobridge
/routing ospf network
add area=backbone network=10.3.0.0/24
/system identity
set name=PE3
CE1
/interface ethernet
set [ find default-name=ether1 ] disable-running-check=no
set [ find default-name=ether2 ] disable-running-check=no
set [ find default-name=ether3 ] disable-running-check=no
set [ find default-name=ether4 ] disable-running-check=no
set [ find default-name=ether5 ] disable-running-check=no
set [ find default-name=ether6 ] disable-running-check=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip address
add address=192.168.1.1/24 interface=ether1 network=192.168.1.0
/system identity
set name=CE1
CE2
/interface ethernet
set [ find default-name=ether1 ] disable-running-check=no
set [ find default-name=ether2 ] disable-running-check=no
set [ find default-name=ether3 ] disable-running-check=no
set [ find default-name=ether4 ] disable-running-check=no
set [ find default-name=ether5 ] disable-running-check=no
set [ find default-name=ether6 ] disable-running-check=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip address
add address=192.168.1.2/24 interface=ether1 network=192.168.1.0
/system identity
set name=CE2
CE3
/interface ethernet
set [ find default-name=ether1 ] disable-running-check=no
set [ find default-name=ether2 ] disable-running-check=no
set [ find default-name=ether3 ] disable-running-check=no
set [ find default-name=ether4 ] disable-running-check=no
set [ find default-name=ether5 ] disable-running-check=no
set [ find default-name=ether6 ] disable-running-check=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip address
add address=192.168.1.3/24 interface=ether1 network=192.168.1.0
/system identity
set name=CE3

Who is online

Users browsing this forum: No registered users and 7 guests