Community discussions

 
bgpro
just joined
Topic Author
Posts: 4
Joined: Mon Jul 15, 2019 12:57 am

PPPoE over VPLS Tunnel - Client Ping mac server pppoe but it does not connect

Mon Jul 15, 2019 3:23 am

Hi, we have a bridge network with wds and we are making some changes.
I thought a little bit how to leave the customers we have today without needing physical changes, but at the same time improving the network.
I then made an OSPF + MPLS routing between 3 mikrotik routers.
R1 OSPF, MPLS and VPLS
R1 (pppoe-server in bridge vpls tunel with R3)
R1 loopback = 10.1.1.1/32
R1 ether2 = 10.0.0.1/30
R2 - OSPF, MPLS ok
R2 loopback = 10.1.1.2/32
R2 ether1 = 10.0.0.2 / 30
R2 ether2 = 10.0.0.5/30
R3 loopback = 10.1.1.3/32
R3 ether1 = 10.0.0.6/30
R3 - bridge VPLS tunel and ehter2
Running bandwidth testing between R3 and R1 or vice versa through the VPLS tunel interface everything works normally.

If you add a pppoe-client to R3 and use the Bridge interface (vlps + ether2) it authenticates to R1 and everything is OK.

If you connect another Mikrotik on ether2 (tunel vpls + ether2) from R3 the router ping the interface (ether1 mac ) of R1 but does not authenticate.
Could you give me some help on this?
 
User avatar
Anumrak
Forum Veteran
Forum Veteran
Posts: 979
Joined: Fri Jul 28, 2017 2:53 pm

Re: PPPoE over VPLS Tunnel - Client Ping mac server pppoe but it does not connect

Mon Jul 15, 2019 4:25 pm

When you do ping, its travel via IP protocols with ospf support. Try to look at your mpls LSP to your pppoe server.
 
bgpro
just joined
Topic Author
Posts: 4
Joined: Mon Jul 15, 2019 12:57 am

Re: PPPoE over VPLS Tunnel - Client Ping mac server pppoe but it does not connect

Mon Jul 15, 2019 11:57 pm

When you do ping, its travel via IP protocols with ospf support. Try to look at your mpls LSP to your pppoe server.
Dont work.

In R3 adding an IP and pinged to R1.
But if I add this ip on the client that is on the R3 bridge I can not ping.
 
mducharme
Trainer
Trainer
Posts: 791
Joined: Tue Jul 19, 2016 6:45 pm

Re: PPPoE over VPLS Tunnel - Client Ping mac server pppoe but it does not connect

Tue Jul 16, 2019 12:39 am

When you do ping, its travel via IP protocols with ospf support. Try to look at your mpls LSP to your pppoe server.
Dont work.

In R3 adding an IP and pinged to R1.
But if I add this ip on the client that is on the R3 bridge I can not ping.
You'll have to share more of your config to get proper assistance. I don't see any reason in what you have shared that would indicate why it is not working. We use this type of config in production successfully. Do you see any PPPoE auth attempts in the logs on R1?
 
bgpro
just joined
Topic Author
Posts: 4
Joined: Mon Jul 15, 2019 12:57 am

Re: PPPoE over VPLS Tunnel - Client Ping mac server pppoe but it does not connect

Tue Jul 16, 2019 1:05 am

OSPF R1:

/routing ospf instance
set [ find default=yes ] disabled=no distribute-default=always-as-type-1 in-filter=ospf-in metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=auto \
    metric-rip=20 metric-static=20 name=ROUTER1 out-filter=ospf-out redistribute-bgp=no redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no \
    redistribute-static=no router-id=10.1.1.1
/routing ospf area
set [ find default=yes ] area-id=0.0.0.0 disabled=no instance=ROUTER1 name=backbone type=default
/routing ospf network
add area=backbone disabled=no network=10.1.1.1/32
add area=backbone disabled=no network=10.0.0.0/30
add area=backbone disabled=no network=10.0.0.4/30
add area=backbone disabled=no network=10.0.0.8/30
add area=backbone disabled=yes network=10.25.25.0/30
add area=backbone disabled=yes network=10.3.3.0/30

MPLS R1: 

mpls
set dynamic-label-range=16-1048575 propagate-ttl=yes
/mpls interface
set [ find default=yes ] disabled=no interface=ether2 mpls-mtu=1540
/mpls ldp
set distribute-for-default-route=no enabled=yes hop-limit=255 loop-detect=no lsr-id=10.1.1.1 path-vector-limit=255 transport-address=10.1.1.1 use-explicit-null=no
/mpls ldp interface
add accept-dynamic-neighbors=yes disabled=no hello-interval=5s hold-time=15s interface=ether2 transport-address=0.0.0.0
add accept-dynamic-neighbors=yes disabled=no hello-interval=5s hold-time=15s interface=ether1 transport-address=0.0.0.0


OSPF R2:

routing ospf instance
set [ find default=yes ] disabled=no distribute-default=never in-filter=ospf-in \
    metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=auto \
    metric-rip=20 metric-static=20 name=ROTEADOR2 out-filter=ospf-out \
    redistribute-bgp=no redistribute-connected=no redistribute-other-ospf=no \
    redistribute-rip=no redistribute-static=no router-id=10.1.1.2
/routing ospf area
set [ find default=yes ] area-id=0.0.0.0 disabled=no instance=ROTEADOR2 name=\
    backbone type=default
/routing ospf network
add area=backbone disabled=no network=10.1.1.2/32
add area=backbone disabled=no network=10.0.0.0/30
add area=backbone disabled=no network=10.0.0.4/30
add area=backbone disabled=no network=10.0.0.8/30
add area=backbone disabled=no network=10.0.0.1/32
add area=backbone disabled=no network=10.0.0.3/32
add area=backbone disabled=no network=10.1.1.1/32
add area=backbone disabled=no network=10.1.1.3/32

MPLS R2:

/mpls
set dynamic-label-range=16-1048575 propagate-ttl=yes
/mpls interface
set [ find default=yes ] disabled=no interface=all mpls-mtu=1540
/mpls ldp
set distribute-for-default-route=no enabled=yes hop-limit=255 loop-detect=no \
    lsr-id=10.1.1.2 path-vector-limit=255 transport-address=10.1.1.2 \
    use-explicit-null=no
/mpls ldp interface
add accept-dynamic-neighbors=yes disabled=no hello-interval=5s hold-time=15s \
    interface=ether1 transport-address=0.0.0.0
add accept-dynamic-neighbors=yes disabled=no hello-interval=5s hold-time=15s \
    interface=ether2 transport-address=0.0.0.0
 
  OSPF R3
  
   /routing ospf instance
set [ find default=yes ] disabled=no distribute-default=never in-filter=ospf-in \
    metric-bgp=auto metric-connected=20 metric-default=1 metric-other-ospf=auto \
    metric-rip=20 metric-static=20 name=ROUTER3 out-filter=ospf-out \
    redistribute-bgp=no redistribute-connected=no redistribute-other-ospf=no \
    redistribute-rip=no redistribute-static=no router-id=10.1.1.3
/routing ospf area
set [ find default=yes ] area-id=0.0.0.0 disabled=no instance=ROUTER3 name=\
    backbone type=default
/routing ospf network
add area=backbone disabled=no network=10.0.0.4/30
add area=backbone disabled=no network=10.1.1.3/32
add area=backbone disabled=no network=10.0.0.8/30
add area=backbone disabled=no network=10.0.0.0/30
add area=backbone disabled=yes network=10.25.25.0/25
add area=backbone disabled=no network=10.1.1.4/32

MPLS R3:

/mpls
set dynamic-label-range=16-1048575 propagate-ttl=yes
/mpls interface
set [ find default=yes ] disabled=no interface=ether1 mpls-mtu=1540
/mpls ldp
set distribute-for-default-route=no enabled=yes hop-limit=255 loop-detect=no \
    lsr-id=10.1.1.3 path-vector-limit=255 transport-address=10.1.1.3 \
    use-explicit-null=no
/mpls ldp interface
add accept-dynamic-neighbors=yes disabled=no hello-interval=5s hold-time=15s \
    interface=ether1 transport-address=0.0.0.0
add accept-dynamic-neighbors=yes disabled=no hello-interval=5s hold-time=15s \
    interface=ether2 transport-address=0.0.0.0 
    
VPLS R1 and R3
/interface vpls
add advertised-l2mtu=1526 arp=enabled cisco-style=no cisco-style-id=0 disable-running-check=no disabled=no l2mtu=1526 mac-address=02:A9:E8:11:37:71 mtu=1526 name=\
    Virtual-to-routerC pw-type=raw-ethernet remote-peer=10.1.1.3 use-control-word=default vpls-id=10:0
add advertised-l2mtu=1500 arp=enabled cisco-style=no cisco-style-id=0 disable-running-check=no disabled=no l2mtu=1500 mac-address=02:F2:78:AC:ED:84 mtu=1500 name=\
    Virtual-torouterD pw-type=raw-ethernet remote-peer=10.1.1.4 use-control-word=default vpls-id=20:0

VPLS R3:
/interface vpls
add advertised-l2mtu=1526 arp=enabled cisco-style=no cisco-style-id=0 \
    disable-running-check=no disabled=no l2mtu=1526 mac-address=\
    02:37:8B:52:CF:0C mtu=1526 name=Virtual-link-to-routerA pw-type=\
    raw-ethernet remote-peer=10.1.1.1 use-control-word=default vpls-id=10:0


R1-10.0.0.1(ether2)------->10.0.0.2(ether1)-R2-10.0.0.5(ether2)--------10.0.0.6(ether1)-R3
Loopback R1 = 10.1.1.1
Loopback R2 = 10.1.1.2
Loopback R3 = 10.1.1.3
 
bgpro
just joined
Topic Author
Posts: 4
Joined: Mon Jul 15, 2019 12:57 am

Re: PPPoE over VPLS Tunnel - Client Ping mac server pppoe but it does not connect

Tue Jul 16, 2019 1:06 am

When you do ping, its travel via IP protocols with ospf support. Try to look at your mpls LSP to your pppoe server.
Dont work.

In R3 adding an IP and pinged to R1.
But if I add this ip on the client that is on the R3 bridge I can not ping.
You'll have to share more of your config to get proper assistance. I don't see any reason in what you have shared that would indicate why it is not working. We use this type of config in production successfully. Do you see any PPPoE auth attempts in the logs on R1?
any more configuration?
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 985
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: PPPoE over VPLS Tunnel - Client Ping mac server pppoe but it does not connect

Tue Jul 16, 2019 4:54 pm

Be sure that you are explicitly defining LDP interfaces and setting the transport to the loopback address. In your configs, it doesn't appear to be set.

VPLS requires targeted LDP sessions and needs the transport IP explicitly set.
Global - MikroTik Support & Consulting - English | Francais | Español | Portuguese +1 855-645-7684
https://iparchitechs.com/services/mikro ... l-support/ mikrotiksupport@iparchitechs.com

Who is online

Users browsing this forum: No registered users and 4 guests