Community discussions

MikroTik App
 
jvolkhausen
just joined
Topic Author
Posts: 4
Joined: Fri Apr 26, 2019 8:44 am

BGP networks and advertisements

Wed Mar 25, 2020 10:00 am

Hello together,
i have a question on bgp. I have two locations and on each location i have a router (CCR1072-1G-8S+ / ROS 6.45.7) with two uplinks to the same (two) providers. I have my own AS with a /22 address range. At the moment the two uplinks are running and also the bgp session are up and running. My problem in detail is the following. I will announce to the two uplink providers each of my adress ranges (1x /22, 2x /23, and 4x /24) with different bgp-prepend values. I have configured the whole seven networks in routing bgp network on both routers and also have defined routing filters for each address range. When i now look at the output of routing bgp advertisements i see different address ranges on the two uplinks and also not all ranges announced like the following charts:
router 1:
PEER PREFIX NEXTHOP AS-PATH ORIGIN LOCAL-PREF
IPv4 ... 18x.xxx.x5.0/24 Provider1 igp
IPv4 ... 18x.xxx.x4.0/24 Provider1 igp
IPv4 ... 18x.xxx.x2.0/22 Provider1 igp
IPv4 ... 18x.xxx.x2.0/23 Provider1 igp
IPv4 ... 18x.xxx.x4.0/23 Provider1 igp
IPv6 ... 2axx:xxx0::/29 Provider1 igp
IPv4 ... 18x.xxx.x2.0/22 Provider2 igp
IPv4 ... 18x.xxx.x2.0/23 Provider2 igp

router 2:
PEER PREFIX NEXTHOP AS-PATH ORIGIN LOCAL-PREF
IPv4 ... 18x.xxx.x4.0/24 Provider1 igp
IPv4 ... 18x.xxx.x5.0/24 Provider1 igp
IPv4 ... 18x.xxx.x2.0/22 Provider1 igp
IPv4 ... 18x.xxx.x2.0/23 Provider1 igp
IPv4 ... 18x.xxx.x4.0/23 Provider1 igp
IPv4 ... 18x.xxx.x2.0/22 Provider2 igp
IPv4 ... 18x.xxx.x2.0/23 Provider2 igp

Can anyone give me a hitch why the behaviour is like that? I think i have two see all my address ranges on the two uplinks. Is there any solicitation on work?
I anyone need further information, just let me know.

Sincerely
jvolkhausen
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1183
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: BGP networks and advertisements

Wed Mar 25, 2020 4:53 pm

Does you upstream provider support BGP communities? If so, I'd use those instead of prepending which doesn't work as well anymore.

Can you post the config and routing table for each router?
Global - MikroTik Support & Consulting - English | Francais | Español | Portuguese +1 855-645-7684
https://iparchitechs.com/services/mikro ... l-support/ mikrotiksupport@iparchitechs.com
 
jvolkhausen
just joined
Topic Author
Posts: 4
Joined: Fri Apr 26, 2019 8:44 am

Re: BGP networks and advertisements

Mon Apr 06, 2020 12:14 pm

Hello IPANetEngineer,
sorry for the delay, i have no remind message received. But now here are the informations.
I have investigated the pssibilities with BGP Communities, and will switch to that in the future. But this is not a one hour job. So i will investigate the current problem further.

In the following the configuration of my two routers as well as the routing tables:
Router A Config
/routing bgp instance
set default disabled=yes
add as=20xxx0 name="AS2020 to ProvA XC5774 <-> sfp-sfpplus2" router-id=14x.xx.x.58
add as=20xxx0 name="AS2020 to ProvB XC6929 <-> sfp-sfpplus3" router-id=8x.xxx.xxx.154 routing-table=ProvB-XC6929
/routing ospf instance
set [ find default=yes ] distribute-default=always-as-type-1 name=cloud-service-ospf redistribute-bgp=as-type-1 redistribute-connected=as-type-1 redistribute-static=as-type-1 router-id=10.0.25.1
/routing bgp network
add network=2axx:xxx0::/29 synchronize=no
add network=1xx.xxx.x2.0/22 synchronize=no
add network=1xx.xxx.x2.0/23 synchronize=no
add network=1xx.xxx.x2.0/24 synchronize=no
add network=1xx.xxx.x3.0/24 synchronize=no
add network=1xx.xxx.x4.0/23 synchronize=no
add network=1xx.xxx.x4.0/24 synchronize=no
add network=1xx.xxx.x5.0/24 synchronize=no
/routing bgp peer
add in-filter=ProvA-XC5774-IPv4-IN instance="AS2020 to ProvA XC5774 <-> sfp-sfpplus2" name="IPv4 AS2020 to ProvA XC5774" out-filter=ProvA-XC5774-IPv4-OUT remote-address=14x.xx.x.57 remote-as=xx4 tcp-md5-key=xXxXxX
add address-families=ipv6 in-filter=ProvA-XC5774-IPv6-IN instance="AS2020 to ProvA XC5774 <-> sfp-sfpplus2" name="IPv6 AS2020 to ProvA XC5774" out-filter=ProvA-XC5774-IPv6-OUT remote-address=\
2xxx:xxx:xx:xx::xxx2:1 remote-as=xx4 tcp-md5-key=xXxXxX
add in-filter=ProvB-XC6929-IPv4-IN instance="AS2020 to ProvB XC6929 <-> sfp-sfpplus3" name="IPv4 AS2020 to ProvB XC6929" out-filter=ProvB-XC6929-IPv4-OUT remote-address=8x.xxx.xxx.153 remote-as=xxx0 tcp-md5-key=xXxXxX
add address-families=ipv6 in-filter=ProvB-XC6929-IPv6-IN instance="AS2020 to ProvB XC6929 <-> sfp-sfpplus3" name="IPv6 AS2020 to ProvB XC6929" out-filter=ProvB-XC6929-IPv6-OUT remote-address=20xx:xx:xxxx:xx07::1 \
remote-as=xxxx0 tcp-md5-key=xXxXxX
/routing filter
add action=accept address-family=ip chain=ProvA-XC5774-IPv4-IN prefix=0.0.0.0 prefix-length=0 protocol=bgp
add action=discard address-family=ip chain=ProvA-XC5774-IPv4-IN
add action=accept chain=ProvA-XC5774-IPv4-OUT prefix=1xx.xxx.x2.0 prefix-length=22 set-bgp-prepend=4
add action=accept chain=ProvA-XC5774-IPv4-OUT prefix=1xx.xxx.x2.0 prefix-length=23 set-bgp-prepend=8
add action=accept chain=ProvA-XC5774-IPv4-OUT disabled=yes prefix=1xx.xxx.x2.0 prefix-length=24 set-bgp-prepend=8
add action=accept chain=ProvA-XC5774-IPv4-OUT disabled=yes prefix=1xx.xxx.x3.0 prefix-length=24 set-bgp-prepend=8
add action=accept chain=ProvA-XC5774-IPv4-OUT prefix=1xx.xxx.x4.0 prefix-length=23 set-bgp-prepend=4
add action=accept chain=ProvA-XC5774-IPv4-OUT prefix=1xx.xxx.x4.0 prefix-length=24 set-bgp-prepend=4
add action=accept chain=ProvA-XC5774-IPv4-OUT prefix=1xx.xxx.x5.0 prefix-length=24 set-bgp-prepend=4
add action=discard address-family=ip chain=ProvA-XC5774-IPv4-OUT
add action=accept address-family=ipv6 chain=ProvA-XC5774-IPv6-IN prefix=::/0 prefix-length=0 protocol=bgp
add action=discard address-family=ipv6 chain=ProvA-XC5774-IPv6-IN
add action=accept chain=ProvA-XC5774-IPv6-OUT prefix=2axx:xxx0::/29 protocol=bgp set-bgp-prepend=4
add action=discard address-family=ipv6 chain=ProvA-XC5774-IPv6-OUT
add action=discard chain=ospf-out prefix=10.0.7.0/24
add action=accept address-family=ip chain=ProvB-XC6929-IPv4-IN prefix=0.0.0.0 prefix-length=0 protocol=bgp
add action=discard address-family=ip chain=ProvB-XC6929-IPv4-IN
add action=accept chain=ProvB-XC6929-IPv4-OUT prefix=1xx.xxx.x2.0 prefix-length=22 set-bgp-prepend=8
add action=accept chain=ProvB-XC6929-IPv4-OUT prefix=1xx.xxx.x2.0 prefix-length=23 set-bgp-prepend=4
add action=accept chain=ProvB-XC6929-IPv4-OUT prefix=1xx.xxx.x2.0 prefix-length=24 set-bgp-prepend=4
add action=accept chain=ProvB-XC6929-IPv4-OUT prefix=1xx.xxx.x3.0 prefix-length=24 set-bgp-prepend=4
add action=accept chain=ProvB-XC6929-IPv4-OUT disabled=yes prefix=1xx.xxx.x4.0 prefix-length=23 set-bgp-prepend=16
add action=accept chain=ProvB-XC6929-IPv4-OUT disabled=yes prefix=1xx.xxx.x4.0 prefix-length=24 set-bgp-prepend=16
add action=accept chain=ProvB-XC6929-IPv4-OUT disabled=yes prefix=1xx.xxx.x5.0 prefix-length=24 set-bgp-prepend=16
add action=discard address-family=ip chain=ProvB-XC6929-IPv4-OUT
add action=accept address-family=ipv6 chain=ProvB-XC6929-IPv6-IN prefix=::/0 prefix-length=0 protocol=bgp
add action=discard address-family=ipv6 chain=ProvB-XC6929-IPv6-IN
add action=accept chain=ProvB-XC6929-IPv6-OUT disabled=yes prefix=2axx:xxx0::/29 protocol=bgp set-bgp-prepend=4
add action=discard address-family=ipv6 chain=ProvB-XC6929-IPv6-OUT
/routing ospf interface
add authentication=md5 authentication-key=xXxXxX authentication-key-id=254 interface=sfp-sfpplus1_v3998_Transit-OSPF network-type=broadcast
/routing ospf network
add area=backbone network=10.0.25.0/24
Routing Table Router A
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
0 ADb 0.0.0.0/0 8x.xxx.xxx.153 20
1 A S 0.0.0.0/0 14x.xx.x.x7 1
2 A S 0.0.0.0/0 8x.xxx.xxx.153 1
3 ADb 0.0.0.0/0 14x.xx.x.x7 20
4 X S 0.0.0.0/0 14x.xx.x.x7 1
5 ADC 10.0.7.0/24 10.0.7.7 ether1_v2-xxxx-... 0
6 Do 10.0.7.0/24 10.0.25.10 110
7 ADo 10.0.8.0/24 10.0.25.20 110
8 ADo 10.0.9.0/24 10.0.25.30 110
9 ADo 10.0.20.0/24 10.0.25.10 110
10.0.25.30
10.0.25.20
10 ADo 10.0.21.0/24 10.0.25.10 110
10.0.25.30
10.0.25.20
11 ADo 10.0.22.0/24 10.0.25.30 110
12 ADo 10.0.22.0/29 10.0.25.10 110
13 ADC 10.0.25.0/24 10.0.25.1 sfp-sfpplus1_v3... 0
14 A S 10.0.27.0/24 10.0.7.2@main 1
15 ADo 10.0.28.0/24 10.0.25.10 110
10.0.25.30
10.0.25.20
10.0.25.2
16 ADo 10.0.29.0/24 10.0.25.10 110
10.0.25.30
10.0.25.20
17 ADo 10.0.30.0/24 10.0.25.10 110
18 A S 10.15.0.0/16 10.0.7.2@main 1
19 A S ;;; Static Route to Management VPN Networks
10.15.0.0/22 10.0.7.2 1
20 ADo 8x.xxx.xxx.152/30 10.0.25.2 110
21 ADC 8x.xxx.xxx.152/30 8x.xxx.xxx.154 sfp-sfpplus3 0
22 ADC 14x.xx.x.x8/28 14x.xx.x.x8 sfp-sfpplus2 0
23 ADo 14x.xx.x.x2/29 10.0.25.2 110
24 ADo 18x.xxx.x2.0/24 10.0.25.30 110
25 ADo 18x.xxx.x2.0/29 10.0.25.10 110
26 ADo 18x.xxx.x3.0/24 10.0.25.20 110
27 ADo 18x.xxx.x4.0/24 10.0.25.30 110
28 ADo 18x.xxx.x5.0/24 10.0.25.20 110
Router B Configuration
/routing bgp instance
set default disabled=yes
add as=20xxx0 name="AS2020 to ProvA XC5777 <-> sfp-sfpplus2" router-id=xxx.xx.x.x4
add as=20xxx0 name="AS2020 to ProvB XC-7632 <-> sfp-sfpplus3" router-id=8x.xxx.xxx.xx4 routing-table=ProvB-XC-7632
/routing ospf instance
set [ find default=yes ] distribute-default=always-as-type-1 name=cloud-service-ospf redistribute-bgp=as-type-1 redistribute-connected=as-type-1 redistribute-static=as-type-1 router-id=10.0.25.2
/routing bgp network
add network=2axx:xxxx::/29 synchronize=no
add network=18x.xxx.x2.0/22 synchronize=no
add network=18x.xxx.x2.0/23 synchronize=no
add network=18x.xxx.x2.0/24 synchronize=no
add network=18x.xxx.x3.0/24 synchronize=no
add network=18x.xxx.x4.0/23 synchronize=no
add network=18x.xxx.x4.0/24 synchronize=no
add network=18x.xxx.x5.0/24 synchronize=no
/routing bgp peer
add in-filter=ProvA-XC5777-IPv4-IN instance="AS2020 to ProvA XC5777 <-> sfp-sfpplus2" name="IPv4 AS2020 to ProvA XC5777" out-filter=ProvA-XC5777-IPv4-OUT remote-address=1xx.xx.x.x3 remote-as=xx4 tcp-md5-key=xXxXxX
add address-families=ipv6 in-filter=ProvA-XC5777-IPv6-IN instance="AS2020 to ProvA XC5777 <-> sfp-sfpplus2" name="IPv6 AS2020 to ProvA XC5777" out-filter=ProvA-XC5777-IPv6-OUT remote-address=\
20xx:xxx:xx:xx::xxx:1 remote-as=xx4 tcp-md5-key=xXxXxX
add in-filter=ProvB-XC7632-IPv4-IN instance="AS2020 to ProvB XC-7632 <-> sfp-sfpplus3" name="IPv4 AS2020 to ProvB XC7632" out-filter=ProvB-XC7632-IPv4-OUT remote-address=8x.xxx.xxx.xx3 remote-as=xxx0 tcp-md5-key=xXxXxX
add address-families=ipv6 in-filter=ProvB-XC7632-IPv6-IN instance="AS2020 to ProvB XC-7632 <-> sfp-sfpplus3" name="IPv6 AS2020 to ProvB XC7632" out-filter=ProvB-XC7632-IPv6-OUT remote-address=20xx:xx:xxxx:xxxx::1 \
remote-as=xxx0 tcp-md5-key=xXxXxX
/routing filter
add action=accept address-family=ip chain=ProvA-XC5777-IPv4-IN prefix=0.0.0.0 prefix-length=0 protocol=bgp
add action=discard address-family=ip chain=ProvA-XC5777-IPv4-IN
add action=accept chain=ProvA-XC5777-IPv4-OUT prefix=18x.xxx.x2.0 prefix-length=22 set-bgp-prepend=10
add action=accept chain=ProvA-XC5777-IPv4-OUT prefix=18x.xxx.x2.0 prefix-length=23 set-bgp-prepend=10
add action=accept chain=ProvA-XC5777-IPv4-OUT disabled=yes prefix=18x.xxx.x2.0 prefix-length=24 set-bgp-prepend=10
add action=accept chain=ProvA-XC5777-IPv4-OUT disabled=yes prefix=18x.xxx.x3.0 prefix-length=24 set-bgp-prepend=10
add action=accept chain=ProvA-XC5777-IPv4-OUT prefix=18x.xxx.x4.0 prefix-length=23 set-bgp-prepend=10
add action=accept chain=ProvA-XC5777-IPv4-OUT prefix=18x.xxx.x4.0 prefix-length=24 set-bgp-prepend=10
add action=accept chain=ProvA-XC5777-IPv4-OUT prefix=18x.xxx.x5.0 prefix-length=24 set-bgp-prepend=10
add action=discard address-family=ip chain=ProvA-XC5777-IPv4-OUT
add action=accept address-family=ipv6 chain=ProvA-XC5777-IPv6-IN prefix=::/0 prefix-length=0 protocol=bgp
add action=discard address-family=ipv6 chain=ProvA-XC5777-IPv6-IN
add action=accept chain=ProvA-XC5774-IPv6-OUT prefix=2axx:xxxx::/29 protocol=bgp set-bgp-prepend=7
add action=discard address-family=ipv6 chain=ProvA-XC5777-IPv6-OUT
add action=discard chain=ospf-out prefix=10.0.8.0/24
add action=accept address-family=ip chain=ProvB-XC7632-IPv4-IN prefix=0.0.0.0 prefix-length=0 protocol=bgp
add action=discard address-family=ip chain=ProvB-XC7632-IPv4-IN
add action=accept chain=ProvB-XC7632-IPv4-OUT prefix=18x.xxx.x2.0 prefix-length=22 set-bgp-prepend=10
add action=accept chain=ProvB-XC7632-IPv4-OUT prefix=18x.xxx.x2.0 prefix-length=23 set-bgp-prepend=8
add action=accept chain=ProvB-XC7632-IPv4-OUT prefix=18x.xxx.x2.0 prefix-length=24 set-bgp-prepend=8
add action=accept chain=ProvB-XC7632-IPv4-OUT prefix=18x.xxx.x3.0 prefix-length=24 set-bgp-prepend=8
add action=accept chain=ProvB-XC7632-IPv4-OUT disabled=yes prefix=18x.xxx.x4.0 prefix-length=23 set-bgp-prepend=16
add action=accept chain=ProvB-XC7632-IPv4-OUT disabled=yes prefix=18x.xxx.x4.0 prefix-length=24 set-bgp-prepend=16
add action=accept chain=ProvB-XC7632-IPv4-OUT disabled=yes prefix=18x.xxx.x5.0 prefix-length=24 set-bgp-prepend=16
add action=discard address-family=ip chain=ProvB-XC7632-IPv4-OUT
add action=accept address-family=ipv6 chain=ProvB-XC7632-IPv6-IN prefix=::/0 prefix-length=0 protocol=bgp
add action=discard address-family=ipv6 chain=ProvB-XC7632-IPv6-IN
add action=accept chain=ProvB-XC7632-IPv6-OUT disabled=yes prefix=2axx:xxxx::/29 protocol=bgp set-bgp-prepend=4
add action=discard address-family=ipv6 chain=ProvB-XC7632-IPv6-OUT
/routing ospf interface
add authentication=md5 authentication-key=xXxXxXxX authentication-key-id=254 cost=100 interface=sfp-sfpplus1_v3998_Transit-OSPF network-type=broadcast
/routing ospf network
add area=backbone network=10.0.25.0/24
Router B Routing Table:
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
0 ADb 0.0.0.0/0 8x.xxx.xxx.xx3 20
1 A S 0.0.0.0/0 8x.xxx.xxx.xx3 1
2 A S 0.0.0.0/0 1xx.xx.x.x3 1
3 ADb 0.0.0.0/0 1xx.xx.x.x3 20
4 X S ;;; Standard Gateway Route
0.0.0.0/0 1xx.xx.x.x3 1
5 ADo 10.0.7.0/24 10.0.25.10 110
6 ADC 10.0.8.0/24 10.0.8.7 ether1_v2-xxxx-... 0
7 Do 10.0.8.0/24 10.0.25.20 110
8 ADo 10.0.9.0/24 10.0.25.30 110
9 ADo 10.0.20.0/24 10.0.25.10 110
10.0.25.20
10.0.25.30
10 ADo 10.0.21.0/24 10.0.25.10 110
10.0.25.20
10.0.25.30
11 ADo 10.0.22.0/24 10.0.25.30 110
12 ADo 10.0.22.0/29 10.0.25.10 110
13 ADC 10.0.25.0/24 10.0.25.2 sfp-sfpplus1_v3... 0
14 ADo 10.0.27.0/24 10.0.25.10 110
10.0.25.20
10.0.25.30
10.0.25.1
15 A S 10.0.28.0/24 10.0.8.2 1
16 ADo 10.0.29.0/24 10.0.25.10 110
10.0.25.20
10.0.25.30
17 ADo 10.0.30.0/24 10.0.25.10 110
18 ADo 10.15.0.0/16 10.0.25.1 110
19 A S ;;; Static Route to Management VPN Networks
10.15.0.0/22 10.0.8.2 1
20 ADC 8x.xxx.xxx.xx2/30 8x.xxx.xxx.xx4 sfp-sfpplus3 0
21 ADo 8x.xxx.xxx.xx2/30 10.0.25.1 110
22 ADo 1xx.xx.x.x8/28 10.0.25.1 110
23 ADC 1xx.xx.x.x2/29 1xx.xx.x.x4 sfp-sfpplus2 0
24 ADo 1xx.xxx.x2.0/24 10.0.25.30 110
25 ADo 1xx.xxx.x2.0/29 10.0.25.10 110
26 ADo 1xx.xxx.x3.0/24 10.0.25.20 110
27 ADo 1xx.xxx.x4.0/24 10.0.25.30 110
28 ADo 1xx.xxx.x5.0/24 10.0.25.20 110

Who is online

Users browsing this forum: No registered users and 43 guests