Community discussions

MikroTik App
 
positronixtech3
just joined
Topic Author
Posts: 1
Joined: Wed May 20, 2020 7:00 pm

VoIP over VPN

Wed May 20, 2020 7:33 pm

So I have a Pre-existing Phone system setup behind my Mikrotik router Pretty simple and works.
I wanted to use a softphone app on my Cellphone to receive calls from out of the office so cleanest way I thought would just to setup a VPN.
In doing so I have connection to the PBX but I only get one way audio to the outgoing call and not to my Cellphone.
VPN Type is L2TP/ipsec. Where am I blocking the audio back to my Cellphone.

/ip firewall filter
add action=accept chain=forward comment="Sip Trunk Counter" dst-address=\
VoIPprovider dst-port=5060 protocol=udp
add action=drop chain=input comment="Secure Router" src-address-list=!secure
add action=drop chain=input comment="Drop invalid" connection-state=invalid
add action=accept chain=input dst-port=1723,1163 protocol=tcp
add action=accept chain=input protocol=gre
add action=drop chain=forward comment="Drop Invalid" connection-state=invalid \
src-address-list=!secure
add action=drop chain=forward comment="Drop invalids forwarded" \
connection-nat-state=!dstnat connection-state=new disabled=yes \
src-address-list=!secure

/ip firewall nat
add action=accept chain=srcnat comment=\
"NAT Bypass for VPN Internal Addresses" disabled=yes dst-address=\
192.168.0.0/16
add action=masquerade chain=srcnat comment="Regular NAT Rule" out-interface=\
ether1-gateway to-addresses=0.0.0.0

Who is online

Users browsing this forum: olgale and 13 guests