Page 1 of 1

Routing one ip range from 2 origins

Posted: Fri Jun 26, 2020 11:20 am
by Here4U
i have 2 AS#, lets say AS0001 and AS0002 , my AS0001 is peering with AS1001 and AS0002 is peering with AS2002, i have made route objects at RIPE for both networks to both my AS#. The route objects at RIPE is XXX.XXX.XXX.0/24 for both AS#

I want to use XXX.XXX.XXX.0/27 from location of AS0001 and
i want to use XXX.XXX.XXX32/28 from location AS0002 and later on start delegating more of the range as i see fit when it grows

Where do i do the splitting? is it in the filters? or the network?

/routing filter
add action=accept chain=peer1-out comment="Approve Advertisements of 2001:xxxx:xxxx:: (48)" prefix=2001:xxxx:xxxx::/48 prefix-length=48 set-bgp-communities=""
add action=accept chain=peer1-out comment="Approve advertisements of xxx.xxx.xxx.0/24" prefix=xxx.xxx.xxx.xxx/24 prefix-length=28
add action=accept chain=peer1-in set-bgp-communities=""

/routing bgp network
add network=2001:xxxx:xxxx::/48 synchronize=no
add network=xxx.xxx.xxx.0/24 synchronize=no

Or is this done automatic when i add a an address to a interface / bridge, or route in /ip route?