Community discussions

MikroTik App
 
mukeshkanojiya
just joined
Topic Author
Posts: 1
Joined: Mon Jul 27, 2020 12:08 pm

Cisco Router to Mikrotik Router Etherchannel(Bonding) issue

Mon Jul 27, 2020 12:57 pm

Hi All,

I am having issue with configuring Etherchannel(Bonding) between Cisco ASR 920 & Mikrotik CCR1036 router.

CIsco Router Config
----------------------------------------------------------------
interface GigabitEthernet0/0/8
no ip address
media-type sfp
negotiation auto
channel-group 1 mode active
end

interface GigabitEthernet0/0/9
no ip address
media-type sfp
negotiation auto
channel-group 1 mode active
end

ASR-920#show running-config interface po1

interface Port-channel1
ip address 10.189.189.1 255.255.255.252
negotiation auto
end

ASR-920#show etherchannel summary

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(RD) LACP Gi0/0/8(susp) Gi0/0/9(susp)
10 Po10(RU) LACP Gi0/0/5(bndl) Gi0/0/6(bndl)

ASR-920#show ip interface brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0/8 unassigned YES NVRAM up up
GigabitEthernet0/0/9 unassigned YES manual up up

Port-channel1 10.189.189.1 YES manual down down <----------------------------- Cisco to Mikrotik LACP show down
Port-channel10 103.25.155.129 YES manual up up <----------------------------- Cisco to Cisco LACP show up
ASR-920#
---------------------------------------------------------------------------------------------------------
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Mikrotik Config
---------------------------------------------------------------------------------------------------------
[mukesh@CCR] > /interface bonding print
Flags: X - disabled, R - running
0 R name="Port-channel1" mtu=1500 mac-address=E4:8D:8C:08:AF:2E arp=enabled arp-timeout=auto slaves=ether11_LAG,ether12_LAG mode=802.3ad primary=none link-monitoring=mii
arp-interval=100ms arp-ip-targets=10.189.189.1 mii-interval=100ms down-delay=0ms up-delay=0ms lacp-rate=30secs transmit-hash-policy=layer-2-and-3 min-links=0
---------------------------------------------------------------------------------------------------------

** Cisco to Mikrotik LACP link (Port-channel 1) is showing down.
Please help me to get this up and running..
Any help would be appreciated.
Thank You.
 
User avatar
cdiedrich
Forum Veteran
Forum Veteran
Posts: 987
Joined: Thu Feb 13, 2014 2:03 pm
Location: Basel, Switzerland // Bremen, Germany
Contact:

Re: Cisco Router to Mikrotik Router Etherchannel(Bonding) issue

Mon Jul 27, 2020 3:14 pm

Hmm...
I don't see any obvious misconfiguration in your setup.
Just double-checked it with a bonding I have up and running here and the only differences I see is explicit LACP protocol assignment to the interfaces on the cisco side and plain layer2-hashing on the Tik side.

Here's my working config (Tik to catalyst 9300, but it should be universal since it's all iOS):

MikroTik config:
/interface bonding
add arp=enabled arp-interval=100ms arp-ip-targets="" arp-timeout=auto disabled=no down-delay=0ms !forced-mac-address lacp-rate=30secs link-monitoring=mii mii-interval=100ms min-links=0 mode=802.3ad mtu=1500 name=bond0 primary=none slaves=ether9-office1/0/13,ether10-office2/0/13,ether11-office3/0/13 transmit-hash-policy=layer-2 up-delay=0ms

Cisco config:
interface Port-channel10
 description to edge-01
 switchport trunk allowed vlan 1,30,31,666
 switchport mode trunk
 switchport nonegotiate
 hold-queue 1000 out
end

!
interface TwoGigabitEthernet3/0/13
 description to edge-01
 switchport trunk allowed vlan 1,30,31,666
 switchport mode trunk
 switchport nonegotiate
 power inline never
 channel-protocol lacp
 channel-group 10 mode active
 spanning-tree guard root
 hold-queue 1000 out
end

!
interface TwoGigabitEthernet2/0/13
 description to edge-01
 switchport trunk allowed vlan 1,30,31,666
 switchport mode trunk
 switchport nonegotiate
 power inline never
 channel-protocol lacp
 channel-group 10 mode active
 spanning-tree guard root
 hold-queue 1000 out
end

!
interface TwoGigabitEthernet1/0/13
 description to edge-01
 switchport trunk allowed vlan 1,30,31,666
 switchport mode trunk
 switchport nonegotiate
 power inline never
 channel-protocol lacp
 channel-group 10 mode active
 spanning-tree guard root
 hold-queue 1000 out
end
-Chris
Christopher Diedrich
MTCNA, MTCUME, MTCWE
Basel, Switzerland
Bremen, Germany

There are 10 types of people: Those who understand binary and those who don't.
There are two types of people: Those who can extrapolate from incomplete data
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1312
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: Cisco Router to Mikrotik Router Etherchannel(Bonding) issue

Tue Aug 04, 2020 7:07 pm

MikroTik is using the slow LACP PDU rate of 30s, what rate is the Cisco LACP channel using? If it's set for 1s, i'd reconfigure to 30 and retest.
Global - MikroTik Support & Consulting - English | Español | Serbian | Danish +1 855-645-7684
https://iparchitechs.com/ecosystem/mikr ... consulting mikrotiksupport@iparchitechs.com

Who is online

Users browsing this forum: No registered users and 14 guests